aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeena Busireddy <neena.busireddy@freescale.com>2014-06-30 15:04:31 -0500
committerMartin Jansa <Martin.Jansa@gmail.com>2014-07-06 19:45:45 +0200
commited02fe97c53d4401b610844106e2f0b29e2c2fb7 (patch)
tree90ad96c6aba78082cff6be24000fdc6330399624
parent74925c7347095aed7af484cf4e59e54cd9390b65 (diff)
qt5nmapcarousedemo: Create recipe to demonstrate qt5 example.
Qt5 Nmapcarousel demonstrates the normal mapping technique using Qt5 This recipe originated from the wandboard wiki page http://wiki.wandboard.org/index.php/Integrate_Qt5_into_yocto_sato_image_on_Wandboard Signed-off-by: Neena Busireddy <neena.busireddy@freescale.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/examples/qt5nmapcarousedemo_1.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-qt/examples/qt5nmapcarousedemo_1.0.bb b/recipes-qt/examples/qt5nmapcarousedemo_1.0.bb
new file mode 100644
index 00000000..7edf7275
--- /dev/null
+++ b/recipes-qt/examples/qt5nmapcarousedemo_1.0.bb
@@ -0,0 +1,27 @@
+SUMMARY = "NMap Carousel application is demonstrating the normal mapping technique using Qt5"
+DESCRIPTION = "Normal mapping is used for making the icons appear 3D with lighting and shadows"
+HOMEPAGE = "http://quitcoding.com/?page=work#cinex"
+LICENSE = "CC-BY-3.0"
+LIC_FILES_CHKSUM = "file://README;beginline=44;endline=55;md5=3a9db934c393a0cf198cbe7e73ebec86"
+
+DEPENDS = "qtdeclarative qtgraphicaleffects"
+
+SRC_URI = "http://quitcoding.com/download/Qt5_NMap_CarouselDemo_1.0.tgz"
+SRC_URI[md5sum] = "c1b4568cdbb6b3af4ca10c5a90aa8128"
+SRC_URI[sha256sum] = "445da212074a10a432f4508d125814212bbe7a967bfa47b015b92dfac6bfd65f"
+
+S = "${WORKDIR}/Qt5_NMap_CarouselDemo_1.0"
+
+require recipes-qt/qt5/qt5.inc
+
+do_install() {
+ install -d ${D}${datadir}/${P}
+ install -m 0755 ${B}/Qt5_NMap_CarouselDemo ${D}${datadir}/${P}
+ cp ${S}/Qt5_NMap_CarouselDemo.qml ${D}${datadir}/${P}
+ cp -a ${S}/content ${D}${datadir}/${P}
+}
+
+FILES_${PN}-dbg += "${datadir}/${P}/.debug"
+FILES_${PN} += "${datadir}"
+
+RDEPENDS_${PN} = "qtdeclarative-qmlplugins qtgraphicaleffects-qmlplugins"