aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-12 20:24:39 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2019-11-20 13:51:18 +0100
commit1a4ee018f42cd98baa97acb918065490ccbd6209 (patch)
treec803307225b134784542de90769467e5db53c3d4
parent02715fff5ee26e8baa03420083f6aa60b45c13ea (diff)
qtwebengine: Fix musl build
Currently, musl build fails to generate .pc ( packageconfig ) files because qmake has logic to detect glibc, which obviously will be failing for musl, and as a result it does not generate all needed files which then fails during do_install like below | sed: can't read /mnt/b/yoe/build/tmp/work/core2-32-yoe-linux-musl/qtwebengine/5.13.2+gitAUTOINC+556576b55f_843d70ac87-r0/image/usr/lib/pkgconfig/Qt5WebEngineCore.pc: No such file or directory Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch29
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch b/recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch
new file mode 100644
index 00000000..73ef469f
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch
@@ -0,0 +1,29 @@
+From a5c8d833ffb8b54626b7b670b2782a6cf9a45075 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 12 Nov 2019 19:53:59 -0800
+Subject: [PATCH] mkspecs: Allow builds with libc != glibc
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ mkspecs/features/configure.prf | 5 -----
+ 1 file changed, 5 deletions(-)
+
+diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
+index cc84182b..c278ffae 100644
+--- a/mkspecs/features/configure.prf
++++ b/mkspecs/features/configure.prf
+@@ -75,11 +75,6 @@ defineTest(runConfigure) {
+ return(false)
+ }
+
+- !qtConfig(webengine-system-glibc) {
+- skipBuild("A suitable version >= 2.27 of libc could not be found.")
+- return(false)
+- }
+-
+ QT_FOR_CONFIG += gui-private
+
+ !qtConfig(webengine-system-khr) {
+--
+2.24.0
+
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index dc41c517..eab8225e 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -146,6 +146,7 @@ SRC_URI += " \
SRC_URI_append_libc-musl = "\
file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
file://0003-musl-link-against-libexecinfo.patch \
+ file://0004-mkspecs-Allow-builds-with-libc-glibc.patch \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/73-based