aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-01-11 14:12:10 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2020-01-11 14:59:12 +0100
commit1fde17e1a570aa5495ecbe8a8daae95b628db260 (patch)
tree8e9368e134349ab1dc69ddc3a573485cb97b10fc
parentca649e3f6f03c5351a090852ff93a23e7382c86a (diff)
qtbase: refresh the patches and upload them to meta-qt5 forks on github for maintenance
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb12
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb14
-rw-r--r--recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch10
-rw-r--r--recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch6
-rw-r--r--recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch6
-rw-r--r--recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch6
-rw-r--r--recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch8
-rw-r--r--recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch6
-rw-r--r--recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0015-corelib-Include-sys-types.h-for-uint32_t.patch4
-rw-r--r--recipes-qt/qt5/qtbase/0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0017-qfloat16-check-for-__ARM_FP-2.patch6
-rw-r--r--recipes-qt/qt5/qtbase/0018-input-Make-use-of-timeval-portable-for-64bit-time_t.patch14
-rw-r--r--recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch (renamed from recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch)6
-rw-r--r--recipes-qt/qt5/qtbase/0020-Avoid-renameeat2-for-native-sdk-builds.patch (renamed from recipes-qt/qt5/qtbase/0019-Avoid-renameeat2-for-native-sdk-builds.patch)6
-rw-r--r--recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch (renamed from recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch)6
-rw-r--r--recipes-qt/qt5/qtbase_git.bb4
24 files changed, 71 insertions, 69 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 165aa562..bac10639 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -22,8 +22,8 @@ require qt5-git.inc
FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtbase:"
# common for qtbase-native, qtbase-nativesdk and qtbase
-# Patches from https://github.com/meta-qt5/qtbase/commits/b5.13-shared
-# 5.13.meta-qt5-shared.1
+# Patches from https://github.com/meta-qt5/qtbase/commits/b5.14-shared
+# 5.14.meta-qt5-shared.1
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -46,11 +46,11 @@ SRC_URI += "\
"
# common for qtbase-native and nativesdk-qtbase
-# Patches from https://github.com/meta-qt5/qtbase/commits/b5.13-native
-# 5.13.meta-qt5-native.1
+# Patches from https://github.com/meta-qt5/qtbase/commits/b5.14-native
+# 5.14.meta-qt5-native.1
SRC_URI += " \
- file://0018-Always-build-uic-and-qvkgen.patch \
- file://0019-Avoid-renameeat2-for-native-sdk-builds.patch \
+ file://0019-Always-build-uic-and-qvkgen.patch \
+ file://0020-Avoid-renameeat2-for-native-sdk-builds.patch \
"
# CMake's toolchain configuration of nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 154740ee..37034b94 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -17,8 +17,8 @@ require qt5-native.inc
require qt5-git.inc
# common for qtbase-native, qtbase-nativesdk and qtbase
-# Patches from https://github.com/meta-qt5/qtbase/commits/b5.13-shared
-# 5.13.meta-qt5-shared.1
+# Patches from https://github.com/meta-qt5/qtbase/commits/b5.14-shared
+# 5.14.meta-qt5-shared.1
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -41,16 +41,16 @@ SRC_URI += "\
"
# common for qtbase-native and nativesdk-qtbase
-# Patches from https://github.com/meta-qt5/qtbase/commits/b5.13-native
-# 5.13.meta-qt5-native.1
+# Patches from https://github.com/meta-qt5/qtbase/commits/b5.14-native
+# 5.14.meta-qt5-native.1
SRC_URI += " \
- file://0018-Always-build-uic-and-qvkgen.patch \
- file://0019-Avoid-renameeat2-for-native-sdk-builds.patch \
+ file://0019-Always-build-uic-and-qvkgen.patch \
+ file://0020-Avoid-renameeat2-for-native-sdk-builds.patch \
"
# only for qtbase-native
SRC_URI += " \
- file://0020-Bootstrap-without-linkat-feature.patch \
+ file://0021-Bootstrap-without-linkat-feature.patch \
"
CLEANBROKEN = "1"
diff --git a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
index 02043ea0..3b71adad 100644
--- a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
+++ b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
@@ -1,4 +1,4 @@
-From 4310d415fd53a1c41b838dafc3913b61087bd799 Mon Sep 17 00:00:00 2001
+From 5668523aa073c1ef430b1662c735ead8fd64c83b Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Mon, 15 Apr 2013 04:29:32 +0200
Subject: [PATCH] Add linux-oe-g++ platform
@@ -31,10 +31,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
create mode 100644 mkspecs/linux-oe-g++/qplatformdefs.h
diff --git a/configure b/configure
-index ef7bad1bfc..dcca0f9135 100755
+index 6657870e4b..2f5d9a21ef 100755
--- a/configure
+++ b/configure
-@@ -712,7 +712,7 @@ fi
+@@ -711,7 +711,7 @@ fi
# is where the resulting variable is written to
setBootstrapVariable()
{
@@ -89,10 +89,10 @@ index 3a71376029..dd6020f1fe 100644
# run qmlimportscanner
qtPrepareTool(QMLIMPORTSCANNER, qmlimportscanner, , system)
diff --git a/mkspecs/features/qt_functions.prf b/mkspecs/features/qt_functions.prf
-index 1903e509c8..c093dd4592 100644
+index 661b7dd961..3bc73ab0c6 100644
--- a/mkspecs/features/qt_functions.prf
+++ b/mkspecs/features/qt_functions.prf
-@@ -69,7 +69,7 @@ defineTest(qtHaveModule) {
+@@ -76,7 +76,7 @@ defineTest(qtHaveModule) {
defineTest(qtPrepareTool) {
cmd = $$eval(QT_TOOL.$${2}.binary)
isEmpty(cmd) {
diff --git a/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
index abef9c2e..1a5adcaf 100644
--- a/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
+++ b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
@@ -1,4 +1,4 @@
-From c15b17e7289f7f17e30972c814e565e4a3c1c629 Mon Sep 17 00:00:00 2001
+From b0e51c74e3f550c2d72ee4e02d1f9c3f5d2e83b5 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 6 Apr 2013 13:15:07 +0200
Subject: [PATCH] cmake: Use OE_QMAKE_PATH_EXTERNAL_HOST_BINS
@@ -19,7 +19,7 @@ Change-Id: Iacaa1c5531cd6dcc094891610c351673db55d7b2
3 files changed, 6 insertions(+), 6 deletions(-)
diff --git a/src/corelib/Qt5CoreConfigExtras.cmake.in b/src/corelib/Qt5CoreConfigExtras.cmake.in
-index e0652fdcf9..7b8fed8931 100644
+index 9b672327ef..f0820b4f4e 100644
--- a/src/corelib/Qt5CoreConfigExtras.cmake.in
+++ b/src/corelib/Qt5CoreConfigExtras.cmake.in
@@ -5,7 +5,7 @@ if (NOT TARGET Qt5::qmake)
diff --git a/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
index 4428efda..6891d8c4 100644
--- a/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
+++ b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
@@ -1,4 +1,4 @@
-From 4ec7f7cb5b8779e50af4a3fe282e02f225f13ddf Mon Sep 17 00:00:00 2001
+From db95ec35c5e2a1604f82803fc5c09dc82b594175 Mon Sep 17 00:00:00 2001
From: Holger Freyther <zecke@selfish.org>
Date: Wed, 26 Sep 2012 17:22:30 +0200
Subject: [PATCH] qlibraryinfo: allow to set qt.conf from the outside using the
@@ -20,10 +20,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/src/corelib/global/qlibraryinfo.cpp b/src/corelib/global/qlibraryinfo.cpp
-index f2ada4ab30..62c6feae17 100644
+index f0f77fe68e..8ef04cb64f 100644
--- a/src/corelib/global/qlibraryinfo.cpp
+++ b/src/corelib/global/qlibraryinfo.cpp
-@@ -174,7 +174,10 @@ void QLibrarySettings::load()
+@@ -183,7 +183,10 @@ void QLibrarySettings::load()
QSettings *QLibraryInfoPrivate::findConfiguration()
{
#ifdef QT_BUILD_QMAKE
diff --git a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
index 6157a52c..25c3a66e 100644
--- a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
+++ b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
@@ -1,4 +1,4 @@
-From b7856b64c4273c25d3f9a0873632595151652c91 Mon Sep 17 00:00:00 2001
+From 3fa9db42f3b34f97929662a461c9a07982505178 Mon Sep 17 00:00:00 2001
From: Denys Dmytriyenko <denys@ti.com>
Date: Tue, 25 Aug 2015 10:05:15 -0400
Subject: [PATCH] configure: bump path length from 256 to 512 characters
@@ -15,10 +15,10 @@ Signed-off-by: Denys Dmytriyenko <denys@ti.com>
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/configure.pri b/configure.pri
-index 3778ece180..94bdfd2649 100644
+index 47882afeb6..a50aa0e176 100644
--- a/configure.pri
+++ b/configure.pri
-@@ -844,10 +844,10 @@ defineTest(qtConfOutput_preparePaths) {
+@@ -870,10 +870,10 @@ defineTest(qtConfOutput_preparePaths) {
$${currentConfig}.output.qconfigSource = \
"/* Installation Info */" \
diff --git a/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
index 79125fc6..c27f7ac2 100644
--- a/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
+++ b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
@@ -1,4 +1,4 @@
-From 50f0c25c0d45928a88a4a2c5a3484e6159f8580a Mon Sep 17 00:00:00 2001
+From 1ca3511433c55755c63dfa0fb78d712c6605b37a Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Mon, 24 Oct 2016 09:45:18 +0300
Subject: [PATCH] Disable all unknown features instead of erroring out
@@ -10,10 +10,10 @@ Change-Id: Ib884fe33cac74439f9592b145937f6b75ced8447
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/mkspecs/features/qt_configure.prf b/mkspecs/features/qt_configure.prf
-index 81110e9f6d..e6b4eeeb11 100644
+index 6537d98c5d..06d23e3847 100644
--- a/mkspecs/features/qt_configure.prf
+++ b/mkspecs/features/qt_configure.prf
-@@ -1604,7 +1604,8 @@ defineReplace(qtConfEvaluateSingleExpression) {
+@@ -1544,7 +1544,8 @@ defineReplace(qtConfEvaluateSingleExpression) {
error("Expression '$$1' is accessing field '$$var' of non-local feature $${feature}.")
return($$result)
}
diff --git a/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
index abc1cf31..03931f5c 100644
--- a/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
+++ b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
@@ -1,4 +1,4 @@
-From 11a7d56a5f57a13643bee171f80d9c4d80b2790b Mon Sep 17 00:00:00 2001
+From 37f7cae8d723341b12fe76bca12c4c76d98fb874 Mon Sep 17 00:00:00 2001
From: Pascal Bach <pascal.bach@siemens.com>
Date: Wed, 11 May 2016 15:20:41 +0200
Subject: [PATCH] Pretend Qt5 wasn't found if OE_QMAKE_PATH_EXTERNAL_HOST_BINS
@@ -30,7 +30,7 @@ Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
2 files changed, 10 insertions(+)
diff --git a/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in b/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in
-index f4a34d6e48..416f1b13bb 100644
+index 364c23e750..670b5c71f2 100644
--- a/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in
+++ b/mkspecs/features/data/cmake/Qt5BasicConfig.cmake.in
@@ -3,6 +3,11 @@ if (CMAKE_VERSION VERSION_LESS 3.1.0)
diff --git a/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
index 29c566fc..1a1d696f 100644
--- a/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
+++ b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
@@ -1,4 +1,4 @@
-From de968b7efc0248052eb96ce430e216a6dfec60d2 Mon Sep 17 00:00:00 2001
+From 2b0adcafba19d87ef452dad156c8fda8ec8396b0 Mon Sep 17 00:00:00 2001
From: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
Date: Wed, 7 Jun 2017 21:00:49 +0900
Subject: [PATCH] Delete qlonglong and qulonglong
diff --git a/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
index 1c33a51f..fe3e0754 100644
--- a/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
+++ b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
@@ -1,4 +1,4 @@
-From a12d09f70178952f5be68110714386a0be00b017 Mon Sep 17 00:00:00 2001
+From 98fbf9fcbe29886dbc84a7e95a9f58a588a8e8ea Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 27 Jul 2017 08:02:51 -0700
Subject: [PATCH] Replace pthread_yield with sched_yield
@@ -14,7 +14,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
2 files changed, 5 insertions(+), 4 deletions(-)
diff --git a/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp b/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp
-index e2bb7dab2a..683c7bafcd 100644
+index 12c29a6e13..7d31799da6 100644
--- a/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp
+++ b/tests/auto/corelib/kernel/qmetatype/tst_qmetatype.cpp
@@ -35,7 +35,7 @@
@@ -36,7 +36,7 @@ index e2bb7dab2a..683c7bafcd 100644
QMetaType info(tp);
if (!info.isValid()) {
diff --git a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
-index 10b09629bc..858fc5fc99 100644
+index 75b9b23259..77b5bf1525 100644
--- a/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
+++ b/tests/auto/network/socket/qtcpsocket/tst_qtcpsocket.cpp
@@ -78,6 +78,7 @@
@@ -47,7 +47,7 @@ index 10b09629bc..858fc5fc99 100644
#endif
#include "private/qhostinfo_p.h"
-@@ -2151,8 +2152,8 @@ public slots:
+@@ -2177,8 +2178,8 @@ public slots:
#if defined(Q_OS_MAC)
pthread_yield_np();
diff --git a/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch b/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
index a0120a4a..fd2716ec 100644
--- a/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
+++ b/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
@@ -1,4 +1,4 @@
-From 69999f5af72d090ec5ddd7003e099af5dfb448ac Mon Sep 17 00:00:00 2001
+From 46b07eaf67735ad21b56c67a61737491c1150760 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 09:11:44 -0700
Subject: [PATCH] Add OE specific specs for clang compiler
diff --git a/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch b/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
index fec487a6..b9c95c5e 100644
--- a/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
+++ b/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
@@ -1,4 +1,4 @@
-From 82111f824764051266d0b807ab3c61bf13b1056a Mon Sep 17 00:00:00 2001
+From df0f6f03af2494d7dc73035273e0a7e65780f3d7 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 09:44:48 -0700
Subject: [PATCH] linux-clang: Invert conditional for defining QT_SOCKLEN_T
diff --git a/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch b/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
index d5c23c38..bd835f1e 100644
--- a/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
+++ b/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
@@ -1,4 +1,4 @@
-From 78d1a6005263f3a7d2dd4ce22f13d3d35b3c6c2f Mon Sep 17 00:00:00 2001
+From fab74db07a1f4f7502d37c4f4c2a04f540dbe6a5 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 10:11:50 -0700
Subject: [PATCH] tst_qlocale: Enable QT_USE_FENV only on glibc
@@ -11,7 +11,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/tests/auto/corelib/text/qlocale/tst_qlocale.cpp b/tests/auto/corelib/text/qlocale/tst_qlocale.cpp
-index 676c66d..ba05aad 100644
+index 20ed7500b5..90181fd078 100644
--- a/tests/auto/corelib/text/qlocale/tst_qlocale.cpp
+++ b/tests/auto/corelib/text/qlocale/tst_qlocale.cpp
@@ -46,7 +46,7 @@
diff --git a/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch b/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
index 1f1ec8bd..c5a2a67f 100644
--- a/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
+++ b/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
@@ -1,4 +1,4 @@
-From f01d43195be86fb5b06ad042551d65c54e34425a Mon Sep 17 00:00:00 2001
+From 716d70f9ac91725155f7e6c14727ab86fbdf44f4 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Wed, 14 Feb 2018 17:08:43 -0800
Subject: [PATCH] mkspecs/common/gcc-base.conf: Use -I instead of -isystem
@@ -22,7 +22,7 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/mkspecs/common/clang.conf b/mkspecs/common/clang.conf
-index df210fe42d..79a3ddf2f8 100644
+index aead581478..8e06a069b4 100644
--- a/mkspecs/common/clang.conf
+++ b/mkspecs/common/clang.conf
@@ -18,7 +18,7 @@ QMAKE_PCH_OUTPUT_EXT = .pch
@@ -35,7 +35,7 @@ index df210fe42d..79a3ddf2f8 100644
QMAKE_CFLAGS_USE_PRECOMPILE = -Xclang -include-pch -Xclang ${QMAKE_PCH_OUTPUT}
QMAKE_CFLAGS_LTCG = -flto=thin
diff --git a/mkspecs/common/gcc-base.conf b/mkspecs/common/gcc-base.conf
-index 44b4267207..9756a02014 100644
+index 4d82321cba..0b03ec99a6 100644
--- a/mkspecs/common/gcc-base.conf
+++ b/mkspecs/common/gcc-base.conf
@@ -46,7 +46,7 @@ QMAKE_CFLAGS_DEBUG += -g
diff --git a/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch b/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch
index 34e41a18..6797e903 100644
--- a/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch
+++ b/recipes-qt/qt5/qtbase/0013-Disable-ltcg-for-host_build.patch
@@ -1,4 +1,4 @@
-From 7804eb38b11b3a03217a6505d4b64c335d5a1d0d Mon Sep 17 00:00:00 2001
+From 63cf72b8519dd58a5fb6eeeef67b19842806cddc Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Tue, 23 Oct 2018 09:54:57 +0300
Subject: [PATCH] Disable ltcg for host_build
@@ -15,7 +15,7 @@ Upstream-Status: Inappropriate [embedded specific]
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/mkspecs/features/ltcg.prf b/mkspecs/features/ltcg.prf
-index a94f6d0eeb..ccab725843 100644
+index d81f340edd..dc1d196710 100644
--- a/mkspecs/features/ltcg.prf
+++ b/mkspecs/features/ltcg.prf
@@ -1,6 +1,6 @@
diff --git a/recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch b/recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
index 8f0568ad..91f12f64 100644
--- a/recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
+++ b/recipes-qt/qt5/qtbase/0014-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
@@ -1,4 +1,4 @@
-From e8d9ebf65245a7ca17bdc3f1ed313c60736e7c9b Mon Sep 17 00:00:00 2001
+From 5630158766df351317ead6059ca7039cd125ab27 Mon Sep 17 00:00:00 2001
From: Max Krummenacher <max.krummenacher@toradex.com>
Date: Sat, 27 Oct 2018 12:29:31 +0000
Subject: [PATCH] Qt5GuiConfigExtras.cmake.in: cope with variable path to
diff --git a/recipes-qt/qt5/qtbase/0015-corelib-Include-sys-types.h-for-uint32_t.patch b/recipes-qt/qt5/qtbase/0015-corelib-Include-sys-types.h-for-uint32_t.patch
index 78b13ddd..2906e763 100644
--- a/recipes-qt/qt5/qtbase/0015-corelib-Include-sys-types.h-for-uint32_t.patch
+++ b/recipes-qt/qt5/qtbase/0015-corelib-Include-sys-types.h-for-uint32_t.patch
@@ -1,4 +1,4 @@
-From 1dbee5ad3c0bc44c4c208ac27448535ef412a0ea Mon Sep 17 00:00:00 2001
+From a1508aff41a526b900f958831a1196f2655c57e9 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 6 Dec 2018 11:47:52 -0800
Subject: [PATCH] corelib: Include sys/types.h for uint32_t
@@ -14,7 +14,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 1 insertion(+)
diff --git a/src/corelib/global/qnumeric_p.h b/src/corelib/global/qnumeric_p.h
-index 4a225b2599..4414865c71 100644
+index 86e7997680..73bcd370c2 100644
--- a/src/corelib/global/qnumeric_p.h
+++ b/src/corelib/global/qnumeric_p.h
@@ -55,6 +55,7 @@
diff --git a/recipes-qt/qt5/qtbase/0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch b/recipes-qt/qt5/qtbase/0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch
index d30f335f..eff1e0b2 100644
--- a/recipes-qt/qt5/qtbase/0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch
+++ b/recipes-qt/qt5/qtbase/0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch
@@ -1,4 +1,4 @@
-From 6ba1d79754bea482b2ac5ae2bb3e60681d435d37 Mon Sep 17 00:00:00 2001
+From e983e9e5451d6961a11206360aeae599f090f971 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 6 Dec 2018 15:06:20 -0800
Subject: [PATCH] Define QMAKE_CXX.COMPILER_MACROS for clang on linux
diff --git a/recipes-qt/qt5/qtbase/0017-qfloat16-check-for-__ARM_FP-2.patch b/recipes-qt/qt5/qtbase/0017-qfloat16-check-for-__ARM_FP-2.patch
index 8411b83d..ebaa7b65 100644
--- a/recipes-qt/qt5/qtbase/0017-qfloat16-check-for-__ARM_FP-2.patch
+++ b/recipes-qt/qt5/qtbase/0017-qfloat16-check-for-__ARM_FP-2.patch
@@ -1,4 +1,4 @@
-From b938d809624660a2998ea7f844aba715e40acfc6 Mon Sep 17 00:00:00 2001
+From a0f5ac48354dd86aaa53c07e08e30098c62f5097 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sat, 5 Oct 2019 16:21:08 -0700
Subject: [PATCH] qfloat16: check for __ARM_FP & 2
@@ -20,10 +20,10 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/corelib/global/qfloat16.cpp b/src/corelib/global/qfloat16.cpp
-index 87ff796368..37dec371a6 100644
+index 6c21b7de5a..98d34a96a5 100644
--- a/src/corelib/global/qfloat16.cpp
+++ b/src/corelib/global/qfloat16.cpp
-@@ -148,7 +148,7 @@ f16cextern void qFloatFromFloat16_fast(float *out, const quint16 *in, qsizetype
+@@ -205,7 +205,7 @@ f16cextern void qFloatFromFloat16_fast(float *out, const quint16 *in, qsizetype
#undef f16cextern
}
diff --git a/recipes-qt/qt5/qtbase/0018-input-Make-use-of-timeval-portable-for-64bit-time_t.patch b/recipes-qt/qt5/qtbase/0018-input-Make-use-of-timeval-portable-for-64bit-time_t.patch
index c027fb68..7a5c7754 100644
--- a/recipes-qt/qt5/qtbase/0018-input-Make-use-of-timeval-portable-for-64bit-time_t.patch
+++ b/recipes-qt/qt5/qtbase/0018-input-Make-use-of-timeval-portable-for-64bit-time_t.patch
@@ -1,4 +1,4 @@
-From c200c1704501e5a74f72dedc3b3b76567d679e0d Mon Sep 17 00:00:00 2001
+From b83804eb1f9087800295cf40916577f932673dc8 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Mon, 25 Nov 2019 08:27:39 -0800
Subject: [PATCH] input: Make use of timeval portable for 64bit time_t
@@ -10,11 +10,13 @@ and keeps old input.h implementation functional as well.
See https://sourceware.org/glibc/wiki/Y2038ProofnessDesign
Upstream-Status: Submitted [https://codereview.qt-project.org/c/qt/qtbase/+/282610]
Change-Id: Ie4d66a5e7d83065f1a904a542c711431e1d20845
-
---
+ .../input/evdevkeyboard/qevdevkeyboardhandler.cpp | 10 +++++++++-
+ .../input/evdevtouch/qevdevtouchhandler.cpp | 7 ++++++-
+ 2 files changed, 15 insertions(+), 2 deletions(-)
diff --git a/src/platformsupport/input/evdevkeyboard/qevdevkeyboardhandler.cpp b/src/platformsupport/input/evdevkeyboard/qevdevkeyboardhandler.cpp
-index 3555763..e7dc57c 100644
+index 3555763b89..e7dc57c027 100644
--- a/src/platformsupport/input/evdevkeyboard/qevdevkeyboardhandler.cpp
+++ b/src/platformsupport/input/evdevkeyboard/qevdevkeyboardhandler.cpp
@@ -58,6 +58,11 @@
@@ -29,7 +31,7 @@ index 3555763..e7dc57c 100644
QT_BEGIN_NAMESPACE
Q_LOGGING_CATEGORY(qLcEvdevKey, "qt.qpa.input")
-@@ -150,7 +155,10 @@
+@@ -150,7 +155,10 @@ void QEvdevKeyboardHandler::switchLed(int led, bool state)
qCDebug(qLcEvdevKey, "switchLed %d %d", led, int(state));
struct ::input_event led_ie;
@@ -42,7 +44,7 @@ index 3555763..e7dc57c 100644
led_ie.code = led;
led_ie.value = state;
diff --git a/src/platformsupport/input/evdevtouch/qevdevtouchhandler.cpp b/src/platformsupport/input/evdevtouch/qevdevtouchhandler.cpp
-index 78728ef..1d65f9b 100644
+index c51db59e1f..1f3726e291 100644
--- a/src/platformsupport/input/evdevtouch/qevdevtouchhandler.cpp
+++ b/src/platformsupport/input/evdevtouch/qevdevtouchhandler.cpp
@@ -58,6 +58,11 @@
@@ -57,7 +59,7 @@ index 78728ef..1d65f9b 100644
#include <math.h>
#if QT_CONFIG(mtdev)
-@@ -573,7 +578,7 @@
+@@ -576,7 +581,7 @@ void QEvdevTouchScreenData::processInputEvent(input_event *data)
// update timestamps
m_lastTimeStamp = m_timeStamp;
diff --git a/recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch b/recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch
index 2ebab22b..86dfac2c 100644
--- a/recipes-qt/qt5/qtbase/0018-Always-build-uic-and-qvkgen.patch
+++ b/recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch
@@ -1,4 +1,4 @@
-From 86effd1f524ebe13d3c288e5ccd1bd477508c0d0 Mon Sep 17 00:00:00 2001
+From eff8ae2d5748626dfd173fa6cb5860bb72ffeafa Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 16 Nov 2013 00:32:30 +0100
Subject: [PATCH] Always build uic and qvkgen
@@ -14,10 +14,10 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/src.pro b/src/src.pro
-index ce3db6d783..2bd15f57d9 100644
+index 8ff3ec4c1f..7a26fd3596 100644
--- a/src/src.pro
+++ b/src/src.pro
-@@ -231,7 +231,7 @@ qtConfig(gui) {
+@@ -235,7 +235,7 @@ qtConfig(gui) {
}
}
}
diff --git a/recipes-qt/qt5/qtbase/0019-Avoid-renameeat2-for-native-sdk-builds.patch b/recipes-qt/qt5/qtbase/0020-Avoid-renameeat2-for-native-sdk-builds.patch
index 2393673f..bde4f76c 100644
--- a/recipes-qt/qt5/qtbase/0019-Avoid-renameeat2-for-native-sdk-builds.patch
+++ b/recipes-qt/qt5/qtbase/0020-Avoid-renameeat2-for-native-sdk-builds.patch
@@ -1,4 +1,4 @@
-From 0ee2fc2de566efc5ad579dec693534105199f33d Mon Sep 17 00:00:00 2001
+From 37ea0b0c40f541cf9741c064e97ec9e9327ba7a1 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Sun, 14 Apr 2019 13:27:58 +0200
Subject: [PATCH] Avoid renameeat2 for native(sdk) builds
@@ -24,7 +24,7 @@ Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
2 files changed, 2 insertions(+), 12 deletions(-)
diff --git a/src/corelib/global/qconfig-bootstrapped.h b/src/corelib/global/qconfig-bootstrapped.h
-index 10458e41d7..8cfa40e461 100644
+index e6ad80525a..283ce1ce26 100644
--- a/src/corelib/global/qconfig-bootstrapped.h
+++ b/src/corelib/global/qconfig-bootstrapped.h
@@ -104,7 +104,7 @@
@@ -46,7 +46,7 @@ index 10458e41d7..8cfa40e461 100644
# define QT_FEATURE_statx -1
#endif
diff --git a/src/corelib/io/qfilesystemengine_unix.cpp b/src/corelib/io/qfilesystemengine_unix.cpp
-index c3abec8..6229c61 100644
+index c3abec8989..6229c611b8 100644
--- a/src/corelib/io/qfilesystemengine_unix.cpp
+++ b/src/corelib/io/qfilesystemengine_unix.cpp
@@ -1223,16 +1223,6 @@ bool QFileSystemEngine::renameFile(const QFileSystemEntry &source, const QFileSy
diff --git a/recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch b/recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch
index a12ba359..70f25ca2 100644
--- a/recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch
+++ b/recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch
@@ -1,4 +1,4 @@
-From 9d40b6e665f67f5096eba41bea13492d3eda056c Mon Sep 17 00:00:00 2001
+From 7596905dbe3ff36a129b5793966da30579d877f4 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Fri, 24 Nov 2017 15:16:31 +0200
Subject: [PATCH] Bootstrap without linkat feature
@@ -13,10 +13,10 @@ Upstream-Status: Inappropriate [OE specific]
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/corelib/global/qconfig-bootstrapped.h b/src/corelib/global/qconfig-bootstrapped.h
-index 8cfa40e461..f2fba9ebd8 100644
+index 283ce1ce26..dfcbb15a6b 100644
--- a/src/corelib/global/qconfig-bootstrapped.h
+++ b/src/corelib/global/qconfig-bootstrapped.h
-@@ -91,7 +91,7 @@
+@@ -95,7 +95,7 @@
#define QT_FEATURE_itemmodel -1
#define QT_FEATURE_library -1
#ifdef __linux__
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 5f6e2e65..16e25d7f 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -13,8 +13,8 @@ LIC_FILES_CHKSUM = " \
"
# common for qtbase-native, qtbase-nativesdk and qtbase
-# Patches from https://github.com/meta-qt5/qtbase/commits/b5.13-shared
-# 5.13.meta-qt5-shared.1
+# Patches from https://github.com/meta-qt5/qtbase/commits/b5.14-shared
+# 5.14.meta-qt5-shared.1
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \