aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-04-29 11:23:25 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-05-10 12:49:06 +0200
commit72772ba86f43610557d86b2d7af38776213b1aec (patch)
tree03178ff53826d25297c85a12856e4fd68e32d78f
parentc92031e3729d778f0b52d98f6cd6def87139c7b7 (diff)
qtwebengine: lower MODULE_VERSION to 5.15.2
* as we cannot upgrade all modules past 5.15.2 due to license change and the branches for 5.15.4 not available publicly, but qtwebengine and the chromium bits which are probably most important for security fixes are available and hopefully we can use them for non-commercial use Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine/0002-qmake.conf-lower-MODULE_VERSION-to-5.15.2.patch34
-rw-r--r--recipes-qt/qt5/qtwebengine/0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch (renamed from recipes-qt/qt5/qtwebengine/0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0004-musl-link-against-libexecinfo.patch (renamed from recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine/0005-mkspecs-Allow-builds-with-libc-glibc.patch (renamed from recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch)2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb11
5 files changed, 43 insertions, 8 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0002-qmake.conf-lower-MODULE_VERSION-to-5.15.2.patch b/recipes-qt/qt5/qtwebengine/0002-qmake.conf-lower-MODULE_VERSION-to-5.15.2.patch
new file mode 100644
index 00000000..ce327f69
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0002-qmake.conf-lower-MODULE_VERSION-to-5.15.2.patch
@@ -0,0 +1,34 @@
+From 1dd91e504648f94a41509cde9f04b0ec2b2ad6cf Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Fri, 12 Mar 2021 15:47:50 +0100
+Subject: [PATCH] qmake.conf: lower MODULE_VERSION to 5.15.2
+
+* to avoid incompatibility when searching for qtwebchannel:
+
+CMake Error at /OE/build/luneos-hardknott/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.browser/0.5.0-14+gitAUTOINC+4b5398142b-r0/recipe-sysroot/usr/lib/cmake/Qt5WebEngineCore/Qt5WebEngineCoreConfig.cmake:116 (find_package):
+ Could not find a configuration file for package "Qt5WebChannel" that is
+ compatible with requested version "5.15.4".
+
+ The following configuration files were considered but not accepted:
+
+ /OE/build/luneos-hardknott/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.browser/0.5.0-14+gitAUTOINC+4b5398142b-r0/recipe-sysroot/usr/lib/cmake/Qt5WebChannel/Qt5WebChannelConfig.cmake, version: 5.15.2
+
+Call Stack (most recent call first):
+ /OE/build/luneos-hardknott/webos-ports/tmp-glibc/work/core2-64-webos-linux/org.webosports.app.browser/0.5.0-14+gitAUTOINC+4b5398142b-r0/recipe-sysroot/usr/lib/cmake/Qt5WebEngine/Qt5WebEngineConfig.cmake:116 (find_package)
+ CMakeLists.txt:19 (find_package)
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ .qmake.conf | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/.qmake.conf b/.qmake.conf
+index d5e64505..8de72145 100644
+--- a/.qmake.conf
++++ b/.qmake.conf
+@@ -5,4 +5,4 @@ QTWEBENGINE_OUT_ROOT = $$shadowed($$PWD)
+ load(qt_build_config)
+ CONFIG += warning_clean
+
+-MODULE_VERSION = 5.15.4
++MODULE_VERSION = 5.15.2
diff --git a/recipes-qt/qt5/qtwebengine/0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch b/recipes-qt/qt5/qtwebengine/0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch
index 33e19e87..6bd3e641 100644
--- a/recipes-qt/qt5/qtwebengine/0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch
+++ b/recipes-qt/qt5/qtwebengine/0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch
@@ -1,4 +1,4 @@
-From 5fced4923a35066d1a7ff4a36f5881528fa93e77 Mon Sep 17 00:00:00 2001
+From 5047c9dfe57c29f9b39829ba6404bd23df669571 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Tue, 12 Dec 2017 16:06:14 +0200
Subject: [PATCH] musl: don't use pvalloc as it's not available on musl
diff --git a/recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch b/recipes-qt/qt5/qtwebengine/0004-musl-link-against-libexecinfo.patch
index 597e9a99..74899024 100644
--- a/recipes-qt/qt5/qtwebengine/0003-musl-link-against-libexecinfo.patch
+++ b/recipes-qt/qt5/qtwebengine/0004-musl-link-against-libexecinfo.patch
@@ -1,4 +1,4 @@
-From 424795a1b7fb485d6aa41e13f02608bc523a4e3e Mon Sep 17 00:00:00 2001
+From e8ca5b9f0dde416a726e94b000b2a775fcd58ad5 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Thu, 14 Dec 2017 11:28:10 +0200
Subject: [PATCH] musl: link against libexecinfo
diff --git a/recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch b/recipes-qt/qt5/qtwebengine/0005-mkspecs-Allow-builds-with-libc-glibc.patch
index 42fdcbba..9e0050dc 100644
--- a/recipes-qt/qt5/qtwebengine/0004-mkspecs-Allow-builds-with-libc-glibc.patch
+++ b/recipes-qt/qt5/qtwebengine/0005-mkspecs-Allow-builds-with-libc-glibc.patch
@@ -1,4 +1,4 @@
-From 93c14cef9c8918fac79e3b059cc9653979856c62 Mon Sep 17 00:00:00 2001
+From addc1b0951db494fa42b141cf7e1c0f5d462e49a Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 12 Nov 2019 19:53:59 -0800
Subject: [PATCH] mkspecs: Allow builds with libc != glibc
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 3bf0fd85..7a3e045b 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -149,17 +149,18 @@ QT_MODULE_BRANCH = "5.15"
PV = "5.15.4+git${SRCPV}"
# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15-glibc
-# 5.15-glibc.meta-qt5.11
+# 5.15-glibc.meta-qt5.12
SRC_URI += " \
${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
file://0001-Force-host-toolchain-configuration.patch \
+ file://0002-qmake.conf-lower-MODULE_VERSION-to-5.15.2.patch \
"
# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15
-# 5.15.meta-qt5.11
+# 5.15.meta-qt5.12
SRC_URI_append_libc-musl = "\
- file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
- file://0003-musl-link-against-libexecinfo.patch \
- file://0004-mkspecs-Allow-builds-with-libc-glibc.patch \
+ file://0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
+ file://0004-musl-link-against-libexecinfo.patch \
+ file://0005-mkspecs-Allow-builds-with-libc-glibc.patch \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based-glibc