aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Belloni <alexandre.belloni@free-electrons.com>2016-07-01 14:24:49 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-08 23:45:55 +0200
commitccae79be69c5268df3b47e4e14cea0591c39a531 (patch)
treee37c64d4cc886b067aef2a8d6df5a186b316519e
parent63f018e5a795e30f913ead00e840ad3263cb0edf (diff)
qtquick1: fix qtwebkit support
40b7a93a3c6cf05136c606824c1cea848b75bcb6 ("qtquick1: allow to disable qtwebkit support") allowed to disable qtwebkit but actually disabled it in every cases. Use the same mechanism as qttools to implement the feature. Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtquick1_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qtquick1_git.bb b/recipes-qt/qt5/qtquick1_git.bb
index f826b54c..a2163ffe 100644
--- a/recipes-qt/qt5/qtquick1_git.bb
+++ b/recipes-qt/qt5/qtquick1_git.bb
@@ -18,10 +18,12 @@ DEPENDS += "qtscript qtsvg qtxmlpatterns"
# qttools
PACKAGECONFIG ??= "webkit"
-PACKAGECONFIG[webkit] = "CONFIG+=enable-webkit,CONFIG-=enable-webkit,qtwebkit"
+PACKAGECONFIG[webkit] = ",,qtwebkit"
+
+EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'webkit', '', 'CONFIG+=noqtwebkit', d)}"
do_configure_prepend() {
- sed -i 's#^qtHaveModule(webkitwidgets):#enable-webkit:qtHaveModule(webkitwidgets):#g' ${S}/src/imports/imports.pro
+ sed -i 's#^qtHaveModule(webkitwidgets):#qtHaveModule(webkitwidgets):!contains(CONFIG, noqtwebkit):#g' ${S}/src/imports/imports.pro
}
SRCREV = "e90625f00a3727ca1c89a94407b7686327d03c19"