aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnders Darander <anders@chargestorm.se>2015-10-19 08:17:05 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-10-27 12:03:01 +0100
commitf432ddee16a33136a107ddbc70e1d36a18d7990a (patch)
tree869c6c8d05a8171acfa032722ecc80eb1ec0c5c0
parentfe7850c411871af7b496bc238761bd4972680376 (diff)
qtbase: fix QA warning of host uid leakage
By using cp, the wrong uid ended up in the package. Use install, as that will automatically handle the uid and gid. Signed-off-by: Anders Darander <anders@chargestorm.se> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 4cffccf7..ecaccd33 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -231,7 +231,7 @@ do_install_append() {
cp -a ${S}/lib/fonts/* ${D}/${OE_QMAKE_PATH_QT_FONTS}
chown -R root:root ${D}/${OE_QMAKE_PATH_QT_FONTS}
fi
- cp -a ${B}/lib/libqt* ${D}${libdir}
+ install -m 0644 ${B}/lib/libqt* ${D}${libdir}
# Remove example.pro file as it is useless
rm -f ${D}${OE_QMAKE_PATH_EXAMPLES}/examples.pro