aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorUlrich Ölmann <u.oelmann@pengutronix.de>2021-03-02 17:02:01 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2021-03-02 17:23:37 +0100
commit7e08416b2fda65caf716f16ef4b995f6a11da351 (patch)
treebbe09d86015cec576826c1fe6c9470b29c83527b
parent23f7a1c8eabaf1beb80cc6214954c0e1751c4cbd (diff)
qtdeclarative: fix buildtime configuration
Without this line PACKAGECONFIG did not have any influence on the actual package configuration. Signed-off-by: Ulrich Ölmann <u.oelmann@pengutronix.de>
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 91e239f7..cadc62cb 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -27,6 +27,8 @@ PACKAGECONFIG[qml-debug] = "-qml-debug,-no-qml-debug"
PACKAGECONFIG[qml-network] = "-qml-network, -no-qml-network"
PACKAGECONFIG[static] = ",,qtdeclarative-native"
+EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
+
do_install_ptest() {
mkdir -p ${D}${PTEST_PATH}
for var in `find ${B}/tests/auto/ -name tst_*`; do