aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-04-14 07:56:02 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2022-04-15 14:53:44 +0200
commit851a0ad540c41cfa6c09d66cd8fec15b63149492 (patch)
tree9f4cca0a45062e8e6ba91b8c99b93325bfd71122
parent98086b549b8252b6ae8e69f84c235402c68370db (diff)
maliit-framework-qt5, maliit-plugins-qt5: Disable tests for gcc too
gcc12 has started failing with same error like clang | ../../../recipe-sysroot/usr/include/QtTest/qtestcase.h:340:34: error: invalid operands to binary expression ('const MImServerCommonOptions' and 'const MImServerCommonOptions') | return compare_helper(t1 == t2, "Compared values are not the same", | ~~ ^ ~~ There do not keep it clang specific anymore Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/maliit/maliit-framework-qt5_git.bb4
-rw-r--r--recipes-qt/maliit/maliit-plugins-qt5_git.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/recipes-qt/maliit/maliit-framework-qt5_git.bb b/recipes-qt/maliit/maliit-framework-qt5_git.bb
index 5ded0b75..1df83e7c 100644
--- a/recipes-qt/maliit/maliit-framework-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-framework-qt5_git.bb
@@ -61,8 +61,8 @@ EXTRA_QMAKEVARS_PRE = "\
CONFIG+=qt5-inputcontext \
"
-# tests fail to build with clang
-EXTRA_QMAKEVARS_PRE:append:toolchain-clang = " CONFIG+=notests"
+# tests fail to build with gcc12/clang
+EXTRA_QMAKEVARS_PRE:append = " CONFIG+=notests"
EXTRA_OEMAKE += "INSTALL_ROOT=${D}"
diff --git a/recipes-qt/maliit/maliit-plugins-qt5_git.bb b/recipes-qt/maliit/maliit-plugins-qt5_git.bb
index 38e82850..d0576415 100644
--- a/recipes-qt/maliit/maliit-plugins-qt5_git.bb
+++ b/recipes-qt/maliit/maliit-plugins-qt5_git.bb
@@ -27,8 +27,8 @@ EXTRA_QMAKEVARS_PRE = "\
CONFIG+=nodoc \
"
-# tests fail to build with clang
-EXTRA_QMAKEVARS_PRE:append:toolchain-clang = " CONFIG+=notests"
+# tests fail to build with gcc12/clang
+EXTRA_QMAKEVARS_PRE:append = " CONFIG+=notests"
FILES:${PN} += "\
${libdir}/maliit \