aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-09-25 23:31:07 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-26 20:56:01 +0000
commit0cf5966d395f8d0a58dafd5153e5fb8047e4bce0 (patch)
tree1394785a4bd234477b8c983586e5d9e5f0d6203c
parent4fb1e6084c7fec8e5e5667bca6e4a4ddfd8b500e (diff)
qt5-creator: upgrade to 4.7.1+
botan was replaced with botan2 in: http://code.qt.io/cgit/qt-creator/qt-creator.git/commit/?h=4.7&id=a44fe2e4f03fc18ce9c3d050f71fe369916259b8 lets see if we still need those fixes for botan Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch91
-rw-r--r--recipes-qt/qt5/qt5-creator/0001-Use-correct-path-prefix.patch (renamed from recipes-qt/qt5/qt5-creator/0002-Use-correct-path-prefix.patch)4
-rw-r--r--recipes-qt/qt5/qt5-creator/0002-Link-with-libexecinfo-on-musl.patch (renamed from recipes-qt/qt5/qt5-creator/0004-Link-with-libexecinfo-on-musl.patch)2
-rw-r--r--recipes-qt/qt5/qt5-creator/0003-botan-check-for-i386-x86_64.patch28
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb (renamed from recipes-qt/qt5/qt5-creator_4.5.1.bb)20
5 files changed, 12 insertions, 133 deletions
diff --git a/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch b/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch
deleted file mode 100644
index ea336360..00000000
--- a/recipes-qt/qt5/qt5-creator/0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch
+++ /dev/null
@@ -1,91 +0,0 @@
-From 231e0cf0c764d3b63cd5ec788ac0ee901b47fc8e Mon Sep 17 00:00:00 2001
-From: Greg Nietsky <gregory@distrotech.co.za>
-Date: Tue, 4 Mar 2014 11:33:40 +0200
-Subject: [PATCH] Fix: Allow qt-creator to build on arm aarch32 and aarch64
-
-Botan is imported hardwired for x86 this small patch allows it
-too operate on arm other platforms could be added.
-
-Task-number: QTCREATORBUG-8107
-Change-Id: Iddea28f21c9fa1afd2fdd5d16a44e6c96a516a7a
----
- src/libs/3rdparty/botan/botan.cpp | 16 +++++++++++++++-
- src/libs/3rdparty/botan/botan.h | 2 ++
- 2 files changed, 17 insertions(+), 1 deletion(-)
-
-diff --git a/src/libs/3rdparty/botan/botan.cpp b/src/libs/3rdparty/botan/botan.cpp
-index 87736d5fe3..2e950d88bf 100644
---- a/src/libs/3rdparty/botan/botan.cpp
-+++ b/src/libs/3rdparty/botan/botan.cpp
-@@ -1101,6 +1101,8 @@ class Montgomery_Exponentiator : public Modular_Exponentiator
-
- #if (BOTAN_MP_WORD_BITS != 32)
- #error The mp_x86_32 module requires that BOTAN_MP_WORD_BITS == 32
-+#elif !defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
-+typedef Botan::u64bit dword;
- #endif
-
- #ifdef Q_OS_UNIX
-@@ -1118,6 +1120,7 @@ extern "C" {
- */
- inline word word_madd2(word a, word b, word* c)
- {
-+#if defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
- asm(
- ASM("mull %[b]")
- ASM("addl %[c],%[a]")
-@@ -1127,6 +1130,11 @@ inline word word_madd2(word a, word b, word* c)
- : "0"(a), "1"(b), [c]"g"(*c) : "cc");
-
- return a;
-+#else
-+ dword z = (dword)a * b + *c;
-+ *c = (word)(z >> BOTAN_MP_WORD_BITS);
-+ return (word)z;
-+#endif
- }
-
- /*
-@@ -1134,6 +1142,7 @@ inline word word_madd2(word a, word b, word* c)
- */
- inline word word_madd3(word a, word b, word c, word* d)
- {
-+#if defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
- asm(
- ASM("mull %[b]")
-
-@@ -1147,6 +1156,11 @@ inline word word_madd3(word a, word b, word c, word* d)
- : "0"(a), "1"(b), [c]"g"(c), [d]"g"(*d) : "cc");
-
- return a;
-+#else
-+ dword z = (dword)a * b + c + *d;
-+ *d = (word)(z >> BOTAN_MP_WORD_BITS);
-+ return (word)z;
-+#endif
- }
-
- }
-@@ -2315,7 +2329,7 @@ namespace Botan {
-
- extern "C" {
-
--#ifdef Q_OS_UNIX
-+#if defined(Q_OS_UNIX) && defined(BOTAN_TARGET_CPU_IS_X86_FAMILY)
- /*
- * Helper Macros for x86 Assembly
- */
-diff --git a/src/libs/3rdparty/botan/botan.h b/src/libs/3rdparty/botan/botan.h
-index d7b90cc92f..26ca8aca37 100644
---- a/src/libs/3rdparty/botan/botan.h
-+++ b/src/libs/3rdparty/botan/botan.h
-@@ -85,7 +85,9 @@
- #endif
-
- #define BOTAN_TARGET_CPU_IS_LITTLE_ENDIAN
-+#if !defined(__arm__) && !defined(__aarch64__)
- #define BOTAN_TARGET_CPU_IS_X86_FAMILY
-+#endif
- #define BOTAN_TARGET_UNALIGNED_MEMORY_ACCESS_OK 1
-
- #if defined(BOTAN_TARGET_CPU_IS_LITTLE_ENDIAN) || \
diff --git a/recipes-qt/qt5/qt5-creator/0002-Use-correct-path-prefix.patch b/recipes-qt/qt5/qt5-creator/0001-Use-correct-path-prefix.patch
index 1c589cad..c064a9a9 100644
--- a/recipes-qt/qt5/qt5-creator/0002-Use-correct-path-prefix.patch
+++ b/recipes-qt/qt5/qt5-creator/0001-Use-correct-path-prefix.patch
@@ -1,4 +1,4 @@
-From 22ff2f705ee47d41c41a0a39bbda454ce54f9819 Mon Sep 17 00:00:00 2001
+From 50443809cc261a3f466cdebd3fa2dd4dda6e6a28 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 25 Sep 2018 23:15:08 +0000
Subject: [PATCH] Use correct path prefix
@@ -12,7 +12,7 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/share/qtcreator/translations/translations.pro b/share/qtcreator/translations/translations.pro
-index 5f752f2855..87bc3d9cab 100644
+index 0df9762fcc..de09bc47ed 100644
--- a/share/qtcreator/translations/translations.pro
+++ b/share/qtcreator/translations/translations.pro
@@ -12,10 +12,10 @@ defineReplace(prependAll) {
diff --git a/recipes-qt/qt5/qt5-creator/0004-Link-with-libexecinfo-on-musl.patch b/recipes-qt/qt5/qt5-creator/0002-Link-with-libexecinfo-on-musl.patch
index 93938428..9b225a57 100644
--- a/recipes-qt/qt5/qt5-creator/0004-Link-with-libexecinfo-on-musl.patch
+++ b/recipes-qt/qt5/qt5-creator/0002-Link-with-libexecinfo-on-musl.patch
@@ -1,4 +1,4 @@
-From 9841dfba76dba7812405418049f259802cd06163 Mon Sep 17 00:00:00 2001
+From 88afa7173c7d0c97e15d9ee9c58e8c0364799bb7 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Tue, 16 Jan 2018 13:26:57 +0000
Subject: [PATCH] Link with libexecinfo on musl
diff --git a/recipes-qt/qt5/qt5-creator/0003-botan-check-for-i386-x86_64.patch b/recipes-qt/qt5/qt5-creator/0003-botan-check-for-i386-x86_64.patch
deleted file mode 100644
index 32671815..00000000
--- a/recipes-qt/qt5/qt5-creator/0003-botan-check-for-i386-x86_64.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 925868614c475d9e90bff8d9a33525f5d65d907c Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Tue, 25 Sep 2018 23:17:42 +0000
-Subject: [PATCH] botan: check for i386 || x86_64
-
-Just check for x86 or x86_64 to define X86 based support
-This makes sure it compiles for non-x86 platforms
-
-Upstream-Status: Pending
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- src/libs/3rdparty/botan/botan.h | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/libs/3rdparty/botan/botan.h b/src/libs/3rdparty/botan/botan.h
-index 26ca8aca37..969405c56e 100644
---- a/src/libs/3rdparty/botan/botan.h
-+++ b/src/libs/3rdparty/botan/botan.h
-@@ -85,7 +85,7 @@
- #endif
-
- #define BOTAN_TARGET_CPU_IS_LITTLE_ENDIAN
--#if !defined(__arm__) && !defined(__aarch64__)
-+#if defined(__i386__) || defined(__x86_64__)
- #define BOTAN_TARGET_CPU_IS_X86_FAMILY
- #endif
- #define BOTAN_TARGET_UNALIGNED_MEMORY_ACCESS_OK 1
diff --git a/recipes-qt/qt5/qt5-creator_4.5.1.bb b/recipes-qt/qt5/qt5-creator_git.bb
index 6451b334..482b10d0 100644
--- a/recipes-qt/qt5/qt5-creator_4.5.1.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -17,21 +17,19 @@ inherit qmake5
DEPENDS = "qtbase qtscript qtwebkit qtxmlpatterns qtx11extras qtdeclarative qttools qttools-native qtsvg chrpath-replacement-native"
DEPENDS_append_libc-musl = " libexecinfo"
-# Patches from https://github.com/meta-qt5/qtcreator/commits/b4.5.1
-# 4.5.1.meta-qt5.2
+SRCREV = "8768e39d3c8e74e583eca3897cc6de53a99c3dde"
+PV = "4.7.1+git${SRCPV}"
+
+# Patches from https://github.com/meta-qt5/qtcreator/commits/b4.7.1
+# 4.7.1.meta-qt5.1
SRC_URI = " \
- http://download.qt.io/official_releases/qtcreator/4.5/${PV}/qt-creator-opensource-src-${PV}.tar.gz \
- file://0001-Fix-Allow-qt-creator-to-build-on-arm-aarch32-and-aar.patch \
- file://0002-Use-correct-path-prefix.patch \
- file://0003-botan-check-for-i386-x86_64.patch \
+ git://code.qt.io/qt-creator/qt-creator.git;branch=4.7 \
+ file://0001-Use-correct-path-prefix.patch \
file://qtcreator.desktop.in \
"
-SRC_URI_append_libc-musl = " file://0004-Link-with-libexecinfo-on-musl.patch"
-
-SRC_URI[md5sum] = "bd7fdbcdfa84df1171fb28174353e57f"
-SRC_URI[sha256sum] = "5fdfc8f05694e37162f208616627262c9971749d6958d8881d62933b3b53e909"
+SRC_URI_append_libc-musl = " file://0002-Link-with-libexecinfo-on-musl.patch"
-S = "${WORKDIR}/qt-creator-opensource-src-${PV}"
+S = "${WORKDIR}/git"
EXTRA_QMAKEVARS_PRE += "IDE_LIBRARY_BASENAME=${baselib}${QT_DIR_NAME}"