aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Belloni <alexandre.belloni@free-electrons.com>2016-07-01 14:24:49 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-08-03 16:18:36 +0200
commit42305c58a2e168709f0f7609bcd86041ecf40e04 (patch)
tree40d1cf581b2aeea4406dc33bbdb6fefada5e5264
parent43cbe31c5b8249466e1757952a813f9750829db7 (diff)
qtquick1: fix qtwebkit support
40b7a93a3c6cf05136c606824c1cea848b75bcb6 ("qtquick1: allow to disable qtwebkit support") allowed to disable qtwebkit but actually disabled it in every cases. Use the same mechanism as qttools to implement the feature. Signed-off-by: Alexandre Belloni <alexandre.belloni@free-electrons.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtquick1_git.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qtquick1_git.bb b/recipes-qt/qt5/qtquick1_git.bb
index e34cc227..55179fa6 100644
--- a/recipes-qt/qt5/qtquick1_git.bb
+++ b/recipes-qt/qt5/qtquick1_git.bb
@@ -19,10 +19,12 @@ DEPENDS += "qtscript qtsvg qtxmlpatterns"
SRC_URI += "file://0001-qdeclarativetextinput-update-to-match-QWidgetLineCon.patch"
PACKAGECONFIG ??= "webkit"
-PACKAGECONFIG[webkit] = "CONFIG+=enable-webkit,CONFIG-=enable-webkit,qtwebkit"
+PACKAGECONFIG[webkit] = ",,qtwebkit"
+
+EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'webkit', '', 'CONFIG+=noqtwebkit', d)}"
do_configure_prepend() {
- sed -i 's#^qtHaveModule(webkitwidgets):#enable-webkit:qtHaveModule(webkitwidgets):#g' ${S}/src/imports/imports.pro
+ sed -i 's#^qtHaveModule(webkitwidgets):#qtHaveModule(webkitwidgets):!contains(CONFIG, noqtwebkit):#g' ${S}/src/imports/imports.pro
}
SRCREV = "5e3bd5cb28e7af95b289a617ca2f7a8892498225"