aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-11-06 14:04:54 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-11 13:24:53 +0100
commitc44294bb8b2ad3035d15c02b751916993c54eccd (patch)
tree6b20767b06f732d7c6b4328b49319b08e5bf75ac
parent39110d2465b0c2bd156aa1288363bfdfee4291af (diff)
qtwebengine: add dependency on libxscrnsaver with x11 in DISTRO_FEATURES
* when qtbase is built with x11 support, xcb is enabled in QT_CONFIG and qtwebengine checks for libxscrnsaver. Unfortunately such check isn't fatal for do_configure task, it will only show something like this: libxscrnsaver wasn't found, qtwebengine won't be built in log.do_configure and continue to do_compile and do_install (which will also finish successfully, saying "Nothing to do"). Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb6
1 files changed, 6 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 65e6d409..dc19f60e 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -17,6 +17,12 @@ DEPENDS += " \
libcap \
"
+# when qtbase is built with xcb enabled (default with x11 in DISTRO_FEATURES),
+# qtwebengine will have additional dependencies:
+# contains(QT_CONFIG, xcb): REQUIRED_PACKAGES += libdrm xcomposite xcursor xi xrandr xscrnsaver xtst
+# xscreensaver isn't covered in qtbase DEPENDS
+DEPENDS += "${@base_contains('DISTRO_FEATURES', 'x11', 'libxscrnsaver', '', d)}"
+
COMPATIBLE_MACHINE = "(-)"
COMPATIBLE_MACHINE_x86 = "(.*)"
COMPATIBLE_MACHINE_x86-64 = "(.*)"