aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-11-30 12:11:57 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-17 09:18:59 +0100
commit4b5f80c1f6831d4e22de00f33f69f3992d08dfba (patch)
treec977c05b7696426a81ce2b2cb7fca582fe587095
parent4f74e02ff0a0a767aa3fd39d8ec8ef1579806801 (diff)
qtwebkit: Always enable icu in QT_CONFIG
Allow qtwebkit to be built even if qtbase was configured without icu. Signed-off-by: Andreas Oberritter <obi@opendreambox.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 78ca1f54..d0d7ee8c 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -64,6 +64,9 @@ do_configure_prepend() {
sed -e 's/\s\(config_fontconfig: \)/ OE_FONTCONFIG_ENABLED:\1/' -i ${S}/Tools/qmake/mkspecs/features/features.prf
}
+# Forcibly enable ICU, so qtbase doesn't need it.
+EXTRA_QMAKEVARS_PRE += "QT_CONFIG+=icu"
+
# qtwebkit gets terribly big when linking with all debug info, disable by default
QTWEBKIT_DEBUG = "QMAKE_CFLAGS+=-g0 QMAKE_CXXFLAGS+=-g0"
EXTRA_QMAKEVARS_PRE += "${QTWEBKIT_DEBUG}"