aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-07-27 13:04:33 +0000
committerMartin 'JaMa' Jansa <Martin.Jansa@gmail.com>2018-07-27 15:11:26 +0200
commit4587cc3b2b8707ed71eb15b9a0a460d76099606e (patch)
treec361ab75c5a39752b0e6a4498f6240383deac429
parent3a4ad5408a8a3c14ab1691910228872003eaacb1 (diff)
qtchooser: drop useless patch, set PV
* set PV to something better than just 'git' * drop 0001-Makefile-install-the-man-dir.patch, the change was already applied long before the currently used SRCREV, do_patch WARNING: was correctly complaining: WARNING: qtchooser-git-r0 do_patch: Some of the context lines in patches were ignored. This can lead to incorrectly applied patches. The context lines in the patches can be updated with devtool: devtool modify <recipe> devtool finish --force-patch-refresh <recipe> <layer_path> Then the updated patches and the source tree (in devtool's workspace) should be reviewed to make sure the patches apply in the correct place and don't introduce duplicate lines (which can, and does happen when some of the context is ignored). Further information: http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450 Details: Applying patch 0001-Makefile-install-the-man-dir.patch patching file Makefile Hunk #1 succeeded at 2 with fuzz 1 (offset 1 line). Hunk #2 succeeded at 79 with fuzz 2 (offset 22 lines). Now at patch 0001-Makefile-install-the-man-dir.patch Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qtchooser/qtchooser/0001-Makefile-install-the-man-dir.patch35
-rw-r--r--recipes-qt/qtchooser/qtchooser_git.bb5
2 files changed, 2 insertions, 38 deletions
diff --git a/recipes-qt/qtchooser/qtchooser/0001-Makefile-install-the-man-dir.patch b/recipes-qt/qtchooser/qtchooser/0001-Makefile-install-the-man-dir.patch
deleted file mode 100644
index 8e8e1c69..00000000
--- a/recipes-qt/qtchooser/qtchooser/0001-Makefile-install-the-man-dir.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 3f142e100cc3dd69b816ce79152760c823cb86e9 Mon Sep 17 00:00:00 2001
-From: Li Xin <lixin.fnst@cn.fujitsu.com>
-Date: Fri, 29 Apr 2016 12:41:34 +0900
-Subject: [PATCH] Makefile: install the man dir
-
-upstream-status: backported
-
-Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com>
----
- Makefile | 3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/Makefile b/Makefile
-index 20b9100..1fd8cd3 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,5 +1,6 @@
- prefix = /usr
- bindir = $(prefix)/bin
-+MKDIR = mkdir -p
- TOOLS = assistant \
- designer \
- lconvert \
-@@ -56,6 +57,8 @@ install:
- case `uname -s` in Darwin) \
- for tool in $(MACTOOLS); do ln -sf qtchooser "$(INSTALL_ROOT)$(bindir)/$$tool"; done \
- ;; esac
-+ $(MKDIR) $(INSTALL_ROOT)$(prefix)/share/man/man1
-+ install -m 644 -p doc/qtchooser.1 $(INSTALL_ROOT)$(prefix)/share/man/man1
-
- uninstall:
- cd src/qtchooser && $(MAKE) uninstall
---
-1.8.4.2
-
diff --git a/recipes-qt/qtchooser/qtchooser_git.bb b/recipes-qt/qtchooser/qtchooser_git.bb
index e745e8ad..06b1ae91 100644
--- a/recipes-qt/qtchooser/qtchooser_git.bb
+++ b/recipes-qt/qtchooser/qtchooser_git.bb
@@ -1,8 +1,7 @@
DESCRIPTION = "Wrapper to select between Qt development binary versions"
HOMEPAGE = "http://macieira.org/qtchooser"
LICENSE = "LGPL-2.1 & Digia-Qt-LGPL-Exception-1.1 | GPL-3.0"
-SRC_URI = "git://code.qt.io/cgit/qtsdk/qtchooser.git;branch=master \
- file://0001-Makefile-install-the-man-dir.patch"
+SRC_URI = "git://code.qt.io/cgit/qtsdk/qtchooser.git"
LIC_FILES_CHKSUM = " \
file://LGPL_EXCEPTION.txt;md5=0145c4d1b6f96a661c2c139dfb268fb6 \
@@ -11,7 +10,7 @@ LIC_FILES_CHKSUM = " \
"
S = "${WORKDIR}/git"
SRCREV = "a1b6736e4f2daf86cd1626004d40ef57db85fbb5"
-#PV = "39+git${SRCREV}"
+PV = "39+git${SRCPV}"
inherit pkgconfig