aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-08-16 11:55:34 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-14 08:24:06 +0000
commit823fa380c5a15817040c2e511c3c6a0d06ef2a3d (patch)
tree91d403467c79d1e1ac40221f865e2f800f243aec
parent9ffdd55c7c03d9e608409a95ed4c51ae0fb3d511 (diff)
qtwebengine: enable debug info for webengine
Enable debug info for webengine builds. The mkspec needed fixing, otherwise CFLAGS were fed incorrectly to Ninja. Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch20
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 10 insertions, 11 deletions
diff --git a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
index 8f7afb6d..f36364e5 100644
--- a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
+++ b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
@@ -1,4 +1,4 @@
-From bb416ea80d421c53012e13280d68bdcefc815b8f Mon Sep 17 00:00:00 2001
+From a0a36aaaeb0509d5964566f501b717d2dd27b205 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Mon, 15 Apr 2013 04:29:32 +0200
Subject: [PATCH] Add linux-oe-g++ platform
@@ -23,14 +23,14 @@ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
configure | 2 +-
mkspecs/features/configure.prf | 4 +--
mkspecs/features/qt_functions.prf | 2 +-
- mkspecs/linux-oe-g++/qmake.conf | 42 ++++++++++++++++++++++++++++
+ mkspecs/linux-oe-g++/qmake.conf | 40 ++++++++++++++++++++++++++++
mkspecs/linux-oe-g++/qplatformdefs.h | 1 +
- 5 files changed, 47 insertions(+), 4 deletions(-)
+ 5 files changed, 45 insertions(+), 4 deletions(-)
create mode 100644 mkspecs/linux-oe-g++/qmake.conf
create mode 100644 mkspecs/linux-oe-g++/qplatformdefs.h
diff --git a/configure b/configure
-index 2830a1b189..6445dc2d5a 100755
+index 2830a1b1897..6445dc2d5a0 100755
--- a/configure
+++ b/configure
@@ -712,7 +712,7 @@ fi
@@ -43,7 +43,7 @@ index 2830a1b189..6445dc2d5a 100755
# build qmake
diff --git a/mkspecs/features/configure.prf b/mkspecs/features/configure.prf
-index 934a18a924..0f5b1b6333 100644
+index 934a18a9249..0f5b1b63334 100644
--- a/mkspecs/features/configure.prf
+++ b/mkspecs/features/configure.prf
@@ -46,14 +46,14 @@ defineTest(qtCompileTest) {
@@ -64,7 +64,7 @@ index 934a18a924..0f5b1b6333 100644
msg = "test $$1 succeeded"
write_file($$QMAKE_CONFIG_LOG, msg, append)
diff --git a/mkspecs/features/qt_functions.prf b/mkspecs/features/qt_functions.prf
-index 1903e509c8..c093dd4592 100644
+index 1903e509c8e..c093dd4592d 100644
--- a/mkspecs/features/qt_functions.prf
+++ b/mkspecs/features/qt_functions.prf
@@ -69,7 +69,7 @@ defineTest(qtHaveModule) {
@@ -78,10 +78,10 @@ index 1903e509c8..c093dd4592 100644
cmd = perl -w $$system_path($${cmd}.pl)
diff --git a/mkspecs/linux-oe-g++/qmake.conf b/mkspecs/linux-oe-g++/qmake.conf
new file mode 100644
-index 0000000000..30d31ed16d
+index 00000000000..d90dfeb4482
--- /dev/null
+++ b/mkspecs/linux-oe-g++/qmake.conf
-@@ -0,0 +1,42 @@
+@@ -0,0 +1,40 @@
+#
+# qmake configuration for linux-g++ with modifications for building with OpenEmbedded
+#
@@ -110,8 +110,6 @@ index 0000000000..30d31ed16d
+QMAKE_CC = $$(OE_QMAKE_CC)
+QMAKE_CXX = $$(OE_QMAKE_CXX)
+
-+QMAKE_CFLAGS_RELEASE_WITH_DEBUGINFO += $$(OE_QMAKE_CFLAGS)
-+
+QMAKE_LINK = $$(OE_QMAKE_LINK)
+QMAKE_LINK_SHLIB = $$(OE_QMAKE_LINK)
+QMAKE_LINK_C = $$(OE_QMAKE_LINK)
@@ -126,7 +124,7 @@ index 0000000000..30d31ed16d
+load(qt_config)
diff --git a/mkspecs/linux-oe-g++/qplatformdefs.h b/mkspecs/linux-oe-g++/qplatformdefs.h
new file mode 100644
-index 0000000000..5d22fb4101
+index 00000000000..5d22fb41013
--- /dev/null
+++ b/mkspecs/linux-oe-g++/qplatformdefs.h
@@ -0,0 +1 @@
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index a10db075..9e28e02e 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -31,6 +31,7 @@ DEPENDS += " \
DEPENDS_append_libc-musl = " libexecinfo"
EXTRA_QMAKEVARS_CONFIGURE += "-feature-webengine-system-ninja -no-feature-webengine-system-gn"
+EXTRA_QMAKEVARS_PRE += "CONFIG+=force_debug_info"
# chromium/third_party/openh264/openh264.gyp adds
# -Wno-format to openh264_cflags_add