aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-04-04 12:10:13 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2018-04-18 11:55:08 +0000
commit4d0975195e211f10a77ee603abb1b55426f31e25 (patch)
tree88d3a5c621a54c65bc3d5ea671becf79bc871a1c
parent8666a500425d9781c16a9252dfbae8392626c9ff (diff)
qtwebkit: Fix build on armv7ve (rpi)
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index b23d4d6f..be7951f5 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -18,6 +18,14 @@ DEPENDS += "qtbase qtdeclarative icu ruby-native sqlite3 glib-2.0 libxslt gperf-
ARM_INSTRUCTION_SET_armv4 = "arm"
ARM_INSTRUCTION_SET_armv5 = "arm"
+# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
+# https://bugs.webkit.org/show_bug.cgi?id=159880
+# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
+# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
+ARM_INSTRUCTION_SET_armv7a = "thumb"
+ARM_INSTRUCTION_SET_armv7r = "thumb"
+ARM_INSTRUCTION_SET_armv7ve = "thumb"
+
# Patches from https://github.com/meta-qt5/qtwebkit/commits/b5.10
# 5.10.meta-qt5.1
SRC_URI += "\