aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-02-21 20:29:40 -0800
committerMartin 'JaMa' Jansa <Martin.Jansa@gmail.com>2018-08-15 13:12:40 +0200
commit8e64c11ace3dab0acbf19ab45adef51a047eb202 (patch)
treea036a5d0c7d6bbeabf950b096debe7786642b001
parent4b96f70a083eacfc4ff4a45d4efbb2d131f88c82 (diff)
qtbase: Add packageconfigs for renameat2 and getentropy use
These features depend on underlying syscall support in kernel and if older kernels are in use, then we can have a knob to turn them off. Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Alban Bedel <alban.bedel@avionic-design.de> (cherry picked from commit 1ac92b6d8a7e1e1395929c87465e347789961086)
-rw-r--r--recipes-qt/qt5/qtbase_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 3064b748..8892b410 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -149,6 +149,10 @@ PACKAGECONFIG[widgets] = "-widgets,-no-widgets"
PACKAGECONFIG[libproxy] = "-libproxy,-no-libproxy,libproxy"
PACKAGECONFIG[libinput] = "-libinput,-no-libinput,libinput"
PACKAGECONFIG[journald] = "-journald,-no-journald,systemd"
+# needs kernel 3.16+
+PACKAGECONFIG[renameat2] = "-feature-renameat2,-no-feature-renameat2,"
+# needs kernel 3.17+
+PACKAGECONFIG[getentropy] = "-feature-getentropy,-no-feature-getentropy,"
QT_CONFIG_FLAGS_GOLD = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', '-use-gold-linker', '-no-use-gold-linker', d)}"
QT_CONFIG_FLAGS += " \