aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Mack <daniel@zonque.org>2017-10-24 22:29:29 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-11-14 18:42:31 +0000
commit06d1c47396508ea50112a00e1c70c40da559aa1a (patch)
tree1178bafb98db219f0458bbe34b9323b069c8bb09
parentd87335a50a9dd35d890786edbd79b8953fdaa11a (diff)
qtwebengine: make test suite succeed
Make the qtwebengine test suite succeed when Qt was built without accessibility features. Upstream bug report: https://bugreports.qt.io/browse/QTBUG-64015 Signed-off-by: Daniel Mack <daniel@zonque.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine/0005-tests-make-accessibility-tests-conditional.patch37
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0005-tests-make-accessibility-tests-conditional.patch b/recipes-qt/qt5/qtwebengine/0005-tests-make-accessibility-tests-conditional.patch
new file mode 100644
index 00000000..8b82010c
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0005-tests-make-accessibility-tests-conditional.patch
@@ -0,0 +1,37 @@
+From 006f08373cbaa8485311f491ab8e67433c0e9ad6 Mon Sep 17 00:00:00 2001
+From: Daniel Mack <daniel@zonque.org>
+Date: Tue, 24 Oct 2017 15:46:19 +0200
+Subject: [PATCH] tests: make accessibility tests conditional
+
+Only test the accessibility functions if accessibility was enabled in the Qt
+config.
+---
+ tests/auto/widgets/widgets.pro | 5 ++++-
+ 1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/tests/auto/widgets/widgets.pro b/tests/auto/widgets/widgets.pro
+index 441eea0f..7bab18f0 100644
+--- a/tests/auto/widgets/widgets.pro
++++ b/tests/auto/widgets/widgets.pro
+@@ -1,7 +1,6 @@
+ TEMPLATE = subdirs
+
+ SUBDIRS += \
+- qwebengineaccessibility \
+ qwebenginedefaultsurfaceformat \
+ qwebenginedownloads \
+ qwebenginefaviconmanager \
+@@ -14,6 +13,10 @@ SUBDIRS += \
+ qwebenginesettings \
+ qwebengineview
+
++qtConfig(accessibility) {
++ SUBDIRS += qwebengineaccessibility
++}
++
+ contains(WEBENGINE_CONFIG, use_spellchecker):!cross_compile {
+ !contains(WEBENGINE_CONFIG, use_native_spellchecker) {
+ SUBDIRS += qwebenginespellcheck
+--
+2.13.6
+
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 4ced7925..50a98b66 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -137,6 +137,7 @@ SRC_URI += " \
file://0002-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \
file://0003-Include-dependency-to-QCoreApplication-translate.patch \
file://0004-Force-host-toolchain-configuration.patch \
+ file://0005-tests-make-accessibility-tests-conditional.patch \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/56-based