aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-02-01 23:42:26 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2019-02-14 17:40:27 +0000
commit6d919b0bf1ede1d585a6a198257d9e01cf01bd94 (patch)
tree0c98c60f0918fffff9ff24d557313c7e606fdc18
parent6713882563f4622ac92b87b4e95830b2556284bf (diff)
qt5-plugin-generic-vboxtouch: Fix build with clang/libc++
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qt5-plugin-generic-vboxtouch/0001-include-errno.h-for-errno-definition.patch38
-rw-r--r--recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb6
2 files changed, 42 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qt5-plugin-generic-vboxtouch/0001-include-errno.h-for-errno-definition.patch b/recipes-qt/qt5/qt5-plugin-generic-vboxtouch/0001-include-errno.h-for-errno-definition.patch
new file mode 100644
index 00000000..ff0eb56f
--- /dev/null
+++ b/recipes-qt/qt5/qt5-plugin-generic-vboxtouch/0001-include-errno.h-for-errno-definition.patch
@@ -0,0 +1,38 @@
+From 2486c9ecc1db12132ee8c77ed69b1d301e75786b Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Fri, 1 Feb 2019 23:35:24 -0800
+Subject: [PATCH] include errno.h for errno definition
+
+This fixes errors with clang/libc++
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ vboxtouch/setshape.cpp | 1 +
+ vboxtouch/vboxtouch.cpp | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/vboxtouch/setshape.cpp b/vboxtouch/setshape.cpp
+index 092f888..4dd25a1 100644
+--- a/vboxtouch/setshape.cpp
++++ b/vboxtouch/setshape.cpp
+@@ -24,6 +24,7 @@
+ #include <QByteArray>
+ #include <QDebug>
+
++#include <errno.h>
+ #include <stdint.h>
+ #include <string.h>
+
+diff --git a/vboxtouch/vboxtouch.cpp b/vboxtouch/vboxtouch.cpp
+index 345fdcb..ffe1d50 100644
+--- a/vboxtouch/vboxtouch.cpp
++++ b/vboxtouch/vboxtouch.cpp
+@@ -32,6 +32,7 @@
+
+ #include <qpa/qwindowsysteminterface.h>
+
++#include <errno.h>
+ #include <fcntl.h>
+ #include <string.h>
+ #include <unistd.h>
diff --git a/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb b/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb
index 1f29dcfe..4e83c267 100644
--- a/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb
+++ b/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb
@@ -16,7 +16,10 @@ DEPENDS = "qtbase"
# Needed with gcc-5.2 https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65801
CXXFLAGS += "-Wno-narrowing"
-SRC_URI = "git://github.com/nemomobile/qt5-plugin-generic-vboxtouch.git"
+SRC_URI = "git://github.com/nemomobile/qt5-plugin-generic-vboxtouch.git \
+ file://0001-VirtualboxTouchScreenHandler-initialize-m_mouse.patch;patchdir=.. \
+ file://0001-include-errno.h-for-errno-definition.patch;patchdir=.. \
+ "
SRCREV = "3f2bdb5a1d346f02d5ab185522271ba2288a42bb"
S = "${WORKDIR}/git/vboxtouch"
@@ -25,4 +28,3 @@ inherit qmake5
FILES_${PN} += "${OE_QMAKE_PATH_PLUGINS}/generic/libvboxtouchplugin.so"
FILES_${PN}-dev += "${OE_QMAKE_PATH_LIBS}/cmake/*"
-SRC_URI += "file://0001-VirtualboxTouchScreenHandler-initialize-m_mouse.patch;patchdir=.."