aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-11-06 14:11:35 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-11 13:24:53 +0100
commit7855f970fface496bcc57eafbf619f0397acadc9 (patch)
treec273313d5770520b0352c462678c91a970eb65ed
parent768cd0229e1bf21a0475f1c90fde52ec7de5d0f7 (diff)
qtwebengine: add dependency on yasm-native and use it
* latest chromium is failing to build yasm, because it's mixing native (x86_64) with target (x86 qemux86) libraries during the build: FAILED: /OE/build/oe-core/tmp-glibc/sysroots/x86_64-linux/usr/bin/i586-oe-linux/i586-oe-linux-g++ -m32 -march=i586 --sysroot=/OE/build/oe-core/tmp-glibc/sysroots/qemux86 -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -Wl,-z,now -Wl,-z,relro -Wl,--fatal-warnings -Wl,-z,defs -pthread -Wl,-z,noexecstack -fPIC -Wl,--disable-new-dtags -Wl,--gc-sections -o genstring -Wl,--start-group obj.host/src/3rdparty/chromium/third_party/yasm/source/patched-yasm/genstring.genstring.o -Wl,--end-group /OE/build/oe-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/i586-oe-linux/gcc/i586-oe-linux/5.2.0/ld: i386:x86-64 architecture of input file `obj.host/src/3rdparty/chromium/third_party/yasm/source/patched-yasm/genstring.genstring.o' is incompatible with i386 output /OE/build/oe-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/i586-oe-linux/gcc/i586-oe-linux/5.2.0/ld: obj.host/src/3rdparty/chromium/third_party/yasm/source/patched-yasm/genstring.genstring.o: file class ELFCLASS64 incompatible with ELFCLASS32 /OE/build/oe-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/i586-oe-linux/gcc/i586-oe-linux/5.2.0/ld: final link failed: File in wrong format collect2: error: ld returned 1 exit status ninja: build stopped: subcommand failed. Makefile.gyp_run:262: recipe for target 'invoke_ninja' failed make[3]: *** [invoke_ninja] Error 1 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index cf6d1cf3..0d6cd8f4 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -23,6 +23,9 @@ DEPENDS += " \
# xscreensaver isn't covered in qtbase DEPENDS
DEPENDS += "${@base_contains('DISTRO_FEATURES', 'x11', 'libxscrnsaver', '', d)}"
+DEPENDS += "yasm-native"
+EXTRA_QMAKEVARS_PRE += "GYP_CONFIG+=use_system_yasm"
+
COMPATIBLE_MACHINE = "(-)"
COMPATIBLE_MACHINE_x86 = "(.*)"
COMPATIBLE_MACHINE_x86-64 = "(.*)"