aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-24 00:09:00 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-24 08:29:40 +0000
commitc67abd66ff15feeaae5acc2688b932e5dec72317 (patch)
tree303dc4916ab9a3be3fce45092d2e2200bfa0659e
parentf69fc4063ccbc3774df6f73fa59f9558eede8128 (diff)
qtbase: Fix build with gcc 4.8
Fixes errors like In file included from ../include/QtCore/qendian.h:1:0, from TOPDIR/build/tmp/work/x86_64-linux/qtbase-native/5.12.0+gitAUTOINC+13ed06640c-r0/git/src/corelib/codecs/qutfcodec.cpp:43: ../include/QtCore/../../../git/src/corelib/global/qendian.h:165:61: error: redeclaration ‘constexpr T qbswap(T) [with T = qfloat16]’ differs in ‘constexpr’ Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb7
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb9
-rw-r--r--recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0013-Check-glibc-version-for-renameat2-statx-on-non-boots.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0014-Disable-ltcg-for-host_build.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0015-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0016-corelib-Include-sys-types.h-for-uint32_t.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0018-Fix-compile-issue-with-gcc-9.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch49
-rw-r--r--recipes-qt/qt5/qtbase/0020-Always-build-uic-and-qvkgen.patch (renamed from recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch)2
-rw-r--r--recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch (renamed from recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch)2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb3
23 files changed, 79 insertions, 27 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index 31687913..6c9853ea 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -23,7 +23,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtbase:"
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.2
+# 5.12.meta-qt5-shared.3
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -43,13 +43,14 @@ SRC_URI += "\
file://0016-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0018-Fix-compile-issue-with-gcc-9.patch \
+ file://0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.2
+# 5.12.meta-qt5-native.3
SRC_URI += " \
- file://0019-Always-build-uic-and-qvkgen.patch \
+ file://0020-Always-build-uic-and-qvkgen.patch \
"
# CMake's toolchain configuration of nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 3dc92499..d224487c 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -18,7 +18,7 @@ require qt5-git.inc
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.2
+# 5.12.meta-qt5-shared.3
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -38,18 +38,19 @@ SRC_URI += "\
file://0016-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0018-Fix-compile-issue-with-gcc-9.patch \
+ file://0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.2
+# 5.12.meta-qt5-native.3
SRC_URI += " \
- file://0019-Always-build-uic-and-qvkgen.patch \
+ file://0020-Always-build-uic-and-qvkgen.patch \
"
# only for qtbase-native
SRC_URI += " \
- file://0020-Bootstrap-without-linkat-feature.patch \
+ file://0021-Bootstrap-without-linkat-feature.patch \
"
CLEANBROKEN = "1"
diff --git a/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
index c08f4901..96bad560 100644
--- a/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
+++ b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
@@ -1,4 +1,4 @@
-From bd8119aaabd75c4a80141b25be48eb990e50ade8 Mon Sep 17 00:00:00 2001
+From 0b3ead1ff3942cdcb19ab949a0386b3618b20d2a Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 6 Apr 2013 13:15:07 +0200
Subject: [PATCH] cmake: Use OE_QMAKE_PATH_EXTERNAL_HOST_BINS
diff --git a/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
index fd2ed42a..6f284949 100644
--- a/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
+++ b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
@@ -1,4 +1,4 @@
-From 77eec5eff2a1e24911bc38f1f96e5bf055058274 Mon Sep 17 00:00:00 2001
+From 2881fc4c8871dc5f4dd3798894bef0cdad04194f Mon Sep 17 00:00:00 2001
From: Holger Freyther <zecke@selfish.org>
Date: Wed, 26 Sep 2012 17:22:30 +0200
Subject: [PATCH] qlibraryinfo: allow to set qt.conf from the outside using the
diff --git a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
index eb866c7e..7e5674be 100644
--- a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
+++ b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
@@ -1,4 +1,4 @@
-From 394f8c1f2faae7cf54dc6882b3817c226d84152c Mon Sep 17 00:00:00 2001
+From e5036f7002281cd122a9992da59270a25d9cff89 Mon Sep 17 00:00:00 2001
From: Denys Dmytriyenko <denys@ti.com>
Date: Tue, 25 Aug 2015 10:05:15 -0400
Subject: [PATCH] configure: bump path length from 256 to 512 characters
diff --git a/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
index 3c1adaa2..9b563b26 100644
--- a/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
+++ b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
@@ -1,4 +1,4 @@
-From 13dc97ded965a67af44d8cecad2762dedc928701 Mon Sep 17 00:00:00 2001
+From af450d151f0f9329fb207b7f06bbaa72d97aad0f Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Mon, 24 Oct 2016 09:45:18 +0300
Subject: [PATCH] Disable all unknown features instead of erroring out
diff --git a/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
index 18bbd8b0..8e9e0b29 100644
--- a/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
+++ b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
@@ -1,4 +1,4 @@
-From 18ffe421246444e5f599fdb76d05a5981f4c611a Mon Sep 17 00:00:00 2001
+From f691e01eb5d30d4b18193f33b8b042d9ef8d30fe Mon Sep 17 00:00:00 2001
From: Pascal Bach <pascal.bach@siemens.com>
Date: Wed, 11 May 2016 15:20:41 +0200
Subject: [PATCH] Pretend Qt5 wasn't found if OE_QMAKE_PATH_EXTERNAL_HOST_BINS
diff --git a/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
index 607b88a0..bb93d8b9 100644
--- a/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
+++ b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
@@ -1,4 +1,4 @@
-From b6cb180ea1fed0c7fa0e77ba9fbe36335b4f2780 Mon Sep 17 00:00:00 2001
+From 2d0c0a470b2b0cb0b1d4b6fcdbbd5e49bbb268e9 Mon Sep 17 00:00:00 2001
From: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
Date: Wed, 7 Jun 2017 21:00:49 +0900
Subject: [PATCH] Delete qlonglong and qulonglong
diff --git a/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
index ea58a9f1..871e9ace 100644
--- a/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
+++ b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
@@ -1,4 +1,4 @@
-From ebe76b93dc894598b91cfd5934724ead5e4e62d0 Mon Sep 17 00:00:00 2001
+From cbdcde6b124da35443cf435e0f04cfe75360ce90 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 27 Jul 2017 08:02:51 -0700
Subject: [PATCH] Replace pthread_yield with sched_yield
diff --git a/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch b/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
index e0595715..664767dd 100644
--- a/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
+++ b/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
@@ -1,4 +1,4 @@
-From 7aef68ed29b5fc96c99d65ccd5e217775044d27d Mon Sep 17 00:00:00 2001
+From 12d00d903a16dba6f7aad0f4652addbd395765fe Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 09:11:44 -0700
Subject: [PATCH] Add OE specific specs for clang compiler
diff --git a/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch b/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
index e984d315..b0136274 100644
--- a/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
+++ b/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
@@ -1,4 +1,4 @@
-From cb7f43dd24bc59baf1466b9f55c48b170c5912cf Mon Sep 17 00:00:00 2001
+From 0e57390700e0c5e727307ced58f7664138a97a53 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 09:44:48 -0700
Subject: [PATCH] linux-clang: Invert conditional for defining QT_SOCKLEN_T
diff --git a/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch b/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
index d988f514..2b9cbd20 100644
--- a/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
+++ b/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
@@ -1,4 +1,4 @@
-From 784a7d274ae96a5598ff886be0fab100e4919c31 Mon Sep 17 00:00:00 2001
+From aaeb2c108346466614e8b2f16408cccf1626dbcf Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 10:11:50 -0700
Subject: [PATCH] tst_qlocale: Enable QT_USE_FENV only on glibc
diff --git a/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch b/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
index fa0f7bfa..4ecbef82 100644
--- a/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
+++ b/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
@@ -1,4 +1,4 @@
-From 9b4355142608fecdf8353dc958f85b08a5bfb2b9 Mon Sep 17 00:00:00 2001
+From 25fe85b199ab52bfa0a2e4c1da41fee1f4a26fbe Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Wed, 14 Feb 2018 17:08:43 -0800
Subject: [PATCH] mkspecs/common/gcc-base.conf: Use -I instead of -isystem
diff --git a/recipes-qt/qt5/qtbase/0013-Check-glibc-version-for-renameat2-statx-on-non-boots.patch b/recipes-qt/qt5/qtbase/0013-Check-glibc-version-for-renameat2-statx-on-non-boots.patch
index c3f2aed0..7a0f334a 100644
--- a/recipes-qt/qt5/qtbase/0013-Check-glibc-version-for-renameat2-statx-on-non-boots.patch
+++ b/recipes-qt/qt5/qtbase/0013-Check-glibc-version-for-renameat2-statx-on-non-boots.patch
@@ -1,4 +1,4 @@
-From 4a810779f45444d3432ce14bf24d053f5d049ca8 Mon Sep 17 00:00:00 2001
+From 3aa91c5947c880e9e0380c9b481bfafd2eeb566c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Tue, 21 Aug 2018 00:29:06 +0200
Subject: [PATCH] Check glibc version for renameat2/statx on non bootstrapped
diff --git a/recipes-qt/qt5/qtbase/0014-Disable-ltcg-for-host_build.patch b/recipes-qt/qt5/qtbase/0014-Disable-ltcg-for-host_build.patch
index c73733dc..f8a51572 100644
--- a/recipes-qt/qt5/qtbase/0014-Disable-ltcg-for-host_build.patch
+++ b/recipes-qt/qt5/qtbase/0014-Disable-ltcg-for-host_build.patch
@@ -1,4 +1,4 @@
-From 83f34d8a82867132b05394f9ce33b8b394454a8b Mon Sep 17 00:00:00 2001
+From d64de84020798e9f4645d876b99a81cedfc051fa Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Tue, 23 Oct 2018 09:54:57 +0300
Subject: [PATCH] Disable ltcg for host_build
diff --git a/recipes-qt/qt5/qtbase/0015-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch b/recipes-qt/qt5/qtbase/0015-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
index b8b5b39f..b4e98a3f 100644
--- a/recipes-qt/qt5/qtbase/0015-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
+++ b/recipes-qt/qt5/qtbase/0015-Qt5GuiConfigExtras.cmake.in-cope-with-variable-path-.patch
@@ -1,4 +1,4 @@
-From d7bd980370d701fa9aeea48f1494d2df6ce3dd2f Mon Sep 17 00:00:00 2001
+From 852a06e11ece7b1a74785bdea2235583d0275007 Mon Sep 17 00:00:00 2001
From: Max Krummenacher <max.krummenacher@toradex.com>
Date: Sat, 27 Oct 2018 12:29:31 +0000
Subject: [PATCH] Qt5GuiConfigExtras.cmake.in: cope with variable path to
diff --git a/recipes-qt/qt5/qtbase/0016-corelib-Include-sys-types.h-for-uint32_t.patch b/recipes-qt/qt5/qtbase/0016-corelib-Include-sys-types.h-for-uint32_t.patch
index 855f8550..06b7ae45 100644
--- a/recipes-qt/qt5/qtbase/0016-corelib-Include-sys-types.h-for-uint32_t.patch
+++ b/recipes-qt/qt5/qtbase/0016-corelib-Include-sys-types.h-for-uint32_t.patch
@@ -1,4 +1,4 @@
-From a138a37e24dd3926e4b3818f99f33139e22e52dc Mon Sep 17 00:00:00 2001
+From 05d36eef240f707d309f9abbbeead2a428e6828b Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 6 Dec 2018 11:47:52 -0800
Subject: [PATCH] corelib: Include sys/types.h for uint32_t
diff --git a/recipes-qt/qt5/qtbase/0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch b/recipes-qt/qt5/qtbase/0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch
index c6963f6d..191c475d 100644
--- a/recipes-qt/qt5/qtbase/0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch
+++ b/recipes-qt/qt5/qtbase/0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch
@@ -1,4 +1,4 @@
-From d836722dee0305cec50c23620600743f363b35c6 Mon Sep 17 00:00:00 2001
+From 8d03a813e3354af543f6b54928629c75ce989781 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 6 Dec 2018 15:06:20 -0800
Subject: [PATCH] Define QMAKE_CXX.COMPILER_MACROS for clang on linux
diff --git a/recipes-qt/qt5/qtbase/0018-Fix-compile-issue-with-gcc-9.patch b/recipes-qt/qt5/qtbase/0018-Fix-compile-issue-with-gcc-9.patch
index db79e846..e5e9813b 100644
--- a/recipes-qt/qt5/qtbase/0018-Fix-compile-issue-with-gcc-9.patch
+++ b/recipes-qt/qt5/qtbase/0018-Fix-compile-issue-with-gcc-9.patch
@@ -1,4 +1,4 @@
-From cde196cf74805cc0f47fbebce884a871859862b2 Mon Sep 17 00:00:00 2001
+From 4bc9f80bb0875648a2f3eca5b14e4e9e56cfda4d Mon Sep 17 00:00:00 2001
From: Allan Sandfeld Jensen <allan.jensen@qt.io>
Date: Tue, 13 Nov 2018 16:00:23 +0100
Subject: [PATCH] Fix compile issue with gcc 9
diff --git a/recipes-qt/qt5/qtbase/0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch b/recipes-qt/qt5/qtbase/0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch
new file mode 100644
index 00000000..42c3d2fb
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch
@@ -0,0 +1,49 @@
+From c10b4df78f56f4ad3db563fe73d0ebece3e5284c Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 24 Dec 2018 00:05:06 -0800
+Subject: [PATCH] qendian: Adding Q_DECL_CONSTEXPR to float conversion
+ specializations
+
+This fixes build failures seen with gcc 4.8
+Fixes https://bugreports.qt.io/browse/QTBUG-71945
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/corelib/global/qendian.h | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/corelib/global/qendian.h b/src/corelib/global/qendian.h
+index 0e67a1ab8e..75f109f26c 100644
+--- a/src/corelib/global/qendian.h
++++ b/src/corelib/global/qendian.h
+@@ -153,7 +153,7 @@ template <> inline Q_DECL_CONSTEXPR qint8 qbswap<qint8>(qint8 source)
+ }
+
+ // floating specializations
+-template<typename Float>
++template<typename Float> Q_DECL_CONSTEXPR
+ Float qbswapFloatHelper(Float source)
+ {
+ // memcpy call in qFromUnaligned is recognized by optimizer as a correct way of type prunning
+@@ -162,17 +162,17 @@ Float qbswapFloatHelper(Float source)
+ return qFromUnaligned<Float>(&temp);
+ }
+
+-template <> inline qfloat16 qbswap<qfloat16>(qfloat16 source)
++template <> inline Q_DECL_CONSTEXPR qfloat16 qbswap<qfloat16>(qfloat16 source)
+ {
+ return qbswapFloatHelper(source);
+ }
+
+-template <> inline float qbswap<float>(float source)
++template <> inline Q_DECL_CONSTEXPR float qbswap<float>(float source)
+ {
+ return qbswapFloatHelper(source);
+ }
+
+-template <> inline double qbswap<double>(double source)
++template <> inline Q_DECL_CONSTEXPR double qbswap<double>(double source)
+ {
+ return qbswapFloatHelper(source);
+ }
diff --git a/recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch b/recipes-qt/qt5/qtbase/0020-Always-build-uic-and-qvkgen.patch
index 77437485..89ea8778 100644
--- a/recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch
+++ b/recipes-qt/qt5/qtbase/0020-Always-build-uic-and-qvkgen.patch
@@ -1,4 +1,4 @@
-From 3a870fb87411802a3e56b5bfa8423240c0036b44 Mon Sep 17 00:00:00 2001
+From f43c877cc27a1042c5ba898fd3865164a200ce40 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 16 Nov 2013 00:32:30 +0100
Subject: [PATCH] Always build uic and qvkgen
diff --git a/recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch b/recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch
index afc2fcb9..6ac54fdf 100644
--- a/recipes-qt/qt5/qtbase/0020-Bootstrap-without-linkat-feature.patch
+++ b/recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch
@@ -1,4 +1,4 @@
-From 8820b1008d832aeab005406fcce1f6b4520426d6 Mon Sep 17 00:00:00 2001
+From f21492a98b2a738e53134be8b7bf8ce44af71712 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Fri, 24 Nov 2017 15:16:31 +0200
Subject: [PATCH] Bootstrap without linkat feature
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 001b01e2..3f7ee3c7 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.2
+# 5.12.meta-qt5-shared.3
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -34,6 +34,7 @@ SRC_URI += "\
file://0016-corelib-Include-sys-types.h-for-uint32_t.patch \
file://0017-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0018-Fix-compile-issue-with-gcc-9.patch \
+ file://0019-qendian-Adding-Q_DECL_CONSTEXPR-to-float-conversion-.patch \
"