aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-09-21 17:50:13 +0200
committerMartin Jansa <martin.jansa@lge.com>2021-10-02 10:48:58 -0700
commitca2138bd259f11d5d1966c766ea007606eec729b (patch)
tree9475dfefb0d94c8f1ffe99647465eec3e9bd95ee
parent4519f9eec988719162fe420fb8864f420231627e (diff)
qtwebengine: inherit pkgconfig
* Newer oe-core doesn't pull many default dependencies anymore: https://lists.openembedded.org/g/openembedded-core/message/156185 add explicit dependency on pkgconfig through pkgconfig.bbclass as we're using it here. * fixes: | sed: can't read /OE/build/luneos-honister/webos-ports/tmp-glibc/work/core2-64-webos-linux/qtwebengine/5.15.4+gitAUTOINC+dd7f7a9166_7aad021f2e-r0/image/usr/lib/pkgconfig/Qt5WebEngineCore.pc: No such file or directory because without pkgconfig detected this file isn't created during the build Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 575df87d..1a3fcae5 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -30,6 +30,8 @@ DEPENDS += " \
DEPENDS_append_libc-musl = " libexecinfo"
+inherit pkgconfig
+
EXTRA_QMAKEVARS_CONFIGURE += "-feature-webengine-system-ninja -no-feature-webengine-system-gn"
EXTRA_QMAKEVARS_PRE += "CONFIG+=force_debug_info"