aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-11-05 00:08:00 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-11-11 13:24:53 +0100
commitcb6c6ff59ccb760de9fe6a3ea83382f92521458b (patch)
treed0452b9a4b12a17ca43196c7ffeda1aa3d0447bb
parenta5f8cb00ffe7f8ddaafd031bc29b126000a73690 (diff)
qtsvg: fix incorrect heart.svg installation path
* fixes: WARNING: QA Issue: qtsvg: Files/directories were installed but not shipped in any package: /OE /OE/build /OE/build/owpb /OE/build/owpb/webos-ports /OE/build/owpb/webos-ports/tmp-glibc /OE/build/owpb/webos-ports/tmp-glibc/work /OE/build/owpb/webos-ports/tmp-glibc/work/i586-webos-linux /OE/build/owpb/webos-ports/tmp-glibc/work/i586-webos-linux/qtsvg /OE/build/owpb/webos-ports/tmp-glibc/work/i586-webos-linux/qtsvg/5.5.99+5.6.0-alpha1+gitAUTOINC+9ee5ee12a7-r0 /OE/build/owpb/webos-ports/tmp-glibc/work/i586-webos-linux/qtsvg/5.5.99+5.6.0-alpha1+gitAUTOINC+9ee5ee12a7-r0/git /OE/build/owpb/webos-ports/tmp-glibc/work/i586-webos-linux/qtsvg/5.5.99+5.6.0-alpha1+gitAUTOINC+9ee5ee12a7-r0/git/examples /OE/build/owpb/webos-ports/tmp-glibc/work/i586-webos-linux/qtsvg/5.5.99+5.6.0-alpha1+gitAUTOINC+9ee5ee12a7-r0/git/examples/svg /OE/build/owpb/webos-ports/tmp-glibc/work/i586-webos-linux/qtsvg/5.5.99+5.6.0-alpha1+gitAUTOINC+9ee5ee12a7-r0/git/examples/svg/richtext /OE/build/owpb/webos-ports/tmp-glibc/work/i586-webos-linux/qtsvg/5.5.99+5.6.0-alpha1+gitAUTOINC+9ee5ee12a7-r0/git/examples/svg/richtext/textobject /OE/build/owpb/webos-ports/tmp-glibc/work/i586-webos-linux/qtsvg/5.5.99+5.6.0-alpha1+gitAUTOINC+9ee5ee12a7-r0/git/examples/svg/richtext/textobject/files /OE/build/owpb/webos-ports/tmp-glibc/work/i586-webos-linux/qtsvg/5.5.99+5.6.0-alpha1+gitAUTOINC+9ee5ee12a7-r0/git/examples/svg/richtext/textobject/files/heart.svg Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. qtsvg: 16 installed and not shipped files. [installed-vs-shipped] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtsvg/0001-textobject.pro-use-DEPLOYMENT-only-for-wince-like-ot.patch30
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtsvg/0001-textobject.pro-use-DEPLOYMENT-only-for-wince-like-ot.patch b/recipes-qt/qt5/qtsvg/0001-textobject.pro-use-DEPLOYMENT-only-for-wince-like-ot.patch
new file mode 100644
index 00000000..4c9c643d
--- /dev/null
+++ b/recipes-qt/qt5/qtsvg/0001-textobject.pro-use-DEPLOYMENT-only-for-wince-like-ot.patch
@@ -0,0 +1,30 @@
+From d539c7e4ef98fd4933573eac606a4edee6655d8c Mon Sep 17 00:00:00 2001
+From: Martin Jansa <Martin.Jansa@gmail.com>
+Date: Thu, 5 Nov 2015 12:25:05 +0100
+Subject: [PATCH] textobject.pro: use DEPLOYMENT only for wince like other
+ examples
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ examples/svg/richtext/textobject/textobject.pro | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/examples/svg/richtext/textobject/textobject.pro b/examples/svg/richtext/textobject/textobject.pro
+index 794ad32..0ecd2c7 100644
+--- a/examples/svg/richtext/textobject/textobject.pro
++++ b/examples/svg/richtext/textobject/textobject.pro
+@@ -12,6 +12,8 @@ RESOURCES = resources.qrc
+ target.path = $$[QT_INSTALL_EXAMPLES]/svg/richtext/textobject
+ INSTALLS += target
+
+-filesToDeploy.files = files/*.svg
+-filesToDeploy.path = files
+-DEPLOYMENT += filesToDeploy
++wince* {
++ filesToDeploy.files = files/*.svg
++ filesToDeploy.path = files
++ DEPLOYMENT += filesToDeploy
++}
+--
+2.6.2
+
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index b3bc50f6..57e9b4fa 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -14,3 +14,5 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
SRCREV = "9ee5ee12a7b92a57624dafed935b3ac1fad426d9"
+
+SRC_URI += "file://0001-textobject.pro-use-DEPLOYMENT-only-for-wince-like-ot.patch"