aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-24 03:24:19 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2018-09-25 09:50:40 +0000
commitd0cd7a7a70d3fe3b3041d41391c5c082d8f23a0d (patch)
tree727231310f8a41b47e8c5697f33df0266c8ce9a2
parent81239229dfda6d9a4b72dc44245fdfb9f10e6fcb (diff)
qtbase: Fix errors due to -isystem
empty out QMAKE_CFLAGS_ISYSTEM this will ensure that -isystem is not used instead it will use -I to include internal QT headers Dont hardcode QMAKE_DEFAULT_INCDIRS when cross compile Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb4
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb4
-rw-r--r--recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch6
-rw-r--r--recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch6
-rw-r--r--recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch40
-rw-r--r--recipes-qt/qt5/qtbase/0013-Upgrade-double-conversion-to-v3.0.0.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0015-double-conversion-support-AARCH64EB-and-arm-BE.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0016-Always-build-uic-and-qvkgen.patch2
-rw-r--r--recipes-qt/qt5/qtbase/0017-Bootstrap-without-linkat-feature.patch2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
20 files changed, 60 insertions, 30 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index ac16e5d8..5eab04d0 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -23,7 +23,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtbase:"
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.11-shared
-# 5.11.meta-qt5-shared.9
+# 5.11.meta-qt5-shared.10
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -44,7 +44,7 @@ SRC_URI += "\
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.11-native
-# 5.11.meta-qt5-native.9
+# 5.11.meta-qt5-native.10
SRC_URI += " \
file://0016-Always-build-uic-and-qvkgen.patch \
"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 25d0963c..d3c2b239 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -18,7 +18,7 @@ require qt5-git.inc
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.11-shared
-# 5.11.meta-qt5-shared.9
+# 5.11.meta-qt5-shared.10
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -39,7 +39,7 @@ SRC_URI += "\
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.10-native
-# 5.11.meta-qt5-native.9
+# 5.11.meta-qt5-native.10
SRC_URI += " \
file://0016-Always-build-uic-and-qvkgen.patch \
"
diff --git a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
index a793ab49..acb0a7d4 100644
--- a/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
+++ b/recipes-qt/qt5/qtbase/0001-Add-linux-oe-g-platform.patch
@@ -1,4 +1,4 @@
-From 4c54d7c45a47a9a63530e821468f7bc76dd78f77 Mon Sep 17 00:00:00 2001
+From a6f4987a281315dacc7b8b55928b9c0793cd0813 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Mon, 15 Apr 2013 04:29:32 +0200
Subject: [PATCH] Add linux-oe-g++ platform
@@ -103,7 +103,7 @@ index 1903e509c8..c093dd4592 100644
cmd = perl -w $$system_path($${cmd}.pl)
diff --git a/mkspecs/linux-oe-g++/qmake.conf b/mkspecs/linux-oe-g++/qmake.conf
new file mode 100644
-index 0000000000..d90dfeb448
+index 0000000000..f34a66599a
--- /dev/null
+++ b/mkspecs/linux-oe-g++/qmake.conf
@@ -0,0 +1,40 @@
@@ -139,7 +139,7 @@ index 0000000000..d90dfeb448
+QMAKE_LINK_SHLIB = $$(OE_QMAKE_LINK)
+QMAKE_LINK_C = $$(OE_QMAKE_LINK)
+QMAKE_LINK_C_SHLIB = $$(OE_QMAKE_LINK)
-+
++QMAKE_CFLAGS_ISYSTEM =
+# for the SDK
+isEmpty(QMAKE_QT_CONFIG):QMAKE_QT_CONFIG = $$(OE_QMAKE_QT_CONFIG)
+
diff --git a/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
index 477aa470..3e266ff4 100644
--- a/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
+++ b/recipes-qt/qt5/qtbase/0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch
@@ -1,4 +1,4 @@
-From 34692222faebb1345a1830c4f0d25adee10161ab Mon Sep 17 00:00:00 2001
+From 2409068a4a7f51f12122629ed6ba043d872a6ff6 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 6 Apr 2013 13:15:07 +0200
Subject: [PATCH] cmake: Use OE_QMAKE_PATH_EXTERNAL_HOST_BINS
diff --git a/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
index c3ee8ee9..4e5b02e6 100644
--- a/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
+++ b/recipes-qt/qt5/qtbase/0003-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch
@@ -1,4 +1,4 @@
-From 74aefb4f9841ab99eea7d817babad4b01e44c6c8 Mon Sep 17 00:00:00 2001
+From 6d828cb28acc5b3fccc8ccc45b600c0f7c20201f Mon Sep 17 00:00:00 2001
From: Holger Freyther <zecke@selfish.org>
Date: Wed, 26 Sep 2012 17:22:30 +0200
Subject: [PATCH] qlibraryinfo: allow to set qt.conf from the outside using the
diff --git a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
index 185f27f0..2ed169f9 100644
--- a/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
+++ b/recipes-qt/qt5/qtbase/0004-configure-bump-path-length-from-256-to-512-character.patch
@@ -1,4 +1,4 @@
-From 40d61921f44c6f52a44f6efce0439a42f5186e1f Mon Sep 17 00:00:00 2001
+From d10cf6bb2b0c4637bd0df07c559fcdd461379b4d Mon Sep 17 00:00:00 2001
From: Denys Dmytriyenko <denys@ti.com>
Date: Tue, 25 Aug 2015 10:05:15 -0400
Subject: [PATCH] configure: bump path length from 256 to 512 characters
diff --git a/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
index c49a2fe8..0414af4e 100644
--- a/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
+++ b/recipes-qt/qt5/qtbase/0005-Disable-all-unknown-features-instead-of-erroring-out.patch
@@ -1,4 +1,4 @@
-From 458e2b0192ec1b4b2add05aa7554302f598a9470 Mon Sep 17 00:00:00 2001
+From fc51c10426c68137c57b5ea6c7ea2bdfe0055aaf Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Mon, 24 Oct 2016 09:45:18 +0300
Subject: [PATCH] Disable all unknown features instead of erroring out
diff --git a/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
index eb1fddc7..e2e31e86 100644
--- a/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
+++ b/recipes-qt/qt5/qtbase/0006-Pretend-Qt5-wasn-t-found-if-OE_QMAKE_PATH_EXTERNAL_H.patch
@@ -1,4 +1,4 @@
-From 3450dba78d488d76cb4827ebfe0c8eda8d1517ca Mon Sep 17 00:00:00 2001
+From f13bad486f825f88ec7757e1c5d2dbc849d9797a Mon Sep 17 00:00:00 2001
From: Pascal Bach <pascal.bach@siemens.com>
Date: Wed, 11 May 2016 15:20:41 +0200
Subject: [PATCH] Pretend Qt5 wasn't found if OE_QMAKE_PATH_EXTERNAL_HOST_BINS
diff --git a/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
index c4d1fd5b..9b8f0096 100644
--- a/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
+++ b/recipes-qt/qt5/qtbase/0007-Delete-qlonglong-and-qulonglong.patch
@@ -1,4 +1,4 @@
-From b4088245535393a75ebf6747acd281f6b9187e12 Mon Sep 17 00:00:00 2001
+From 7fc8b8c15007e0a1687680c66292d8ed55000053 Mon Sep 17 00:00:00 2001
From: Huang Qiyu <huangqy.fnst@cn.fujitsu.com>
Date: Wed, 7 Jun 2017 21:00:49 +0900
Subject: [PATCH] Delete qlonglong and qulonglong
diff --git a/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
index 3011f5f2..6fac905d 100644
--- a/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
+++ b/recipes-qt/qt5/qtbase/0008-Replace-pthread_yield-with-sched_yield.patch
@@ -1,4 +1,4 @@
-From f3f00676d204b56010d80a1373ad18abe80d455a Mon Sep 17 00:00:00 2001
+From 83965aee0017fb424406d895af5ec2cec696f26c Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Thu, 27 Jul 2017 08:02:51 -0700
Subject: [PATCH] Replace pthread_yield with sched_yield
diff --git a/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch b/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
index c5586852..ca74f0f7 100644
--- a/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
+++ b/recipes-qt/qt5/qtbase/0009-Add-OE-specific-specs-for-clang-compiler.patch
@@ -1,4 +1,4 @@
-From 563e954aaa4cf82560f157af79344c4b7cb7ca6d Mon Sep 17 00:00:00 2001
+From 51bc56305205a154db22c1373eb19d835ba2c64e Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 09:11:44 -0700
Subject: [PATCH] Add OE specific specs for clang compiler
@@ -13,7 +13,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
diff --git a/mkspecs/linux-oe-clang/qmake.conf b/mkspecs/linux-oe-clang/qmake.conf
new file mode 100644
-index 0000000000..ffc9f051db
+index 0000000000..b0a5630fdd
--- /dev/null
+++ b/mkspecs/linux-oe-clang/qmake.conf
@@ -0,0 +1,43 @@
@@ -52,7 +52,7 @@ index 0000000000..ffc9f051db
+QMAKE_LINK_SHLIB = $$(OE_QMAKE_LINK)
+QMAKE_LINK_C = $$(OE_QMAKE_LINK)
+QMAKE_LINK_C_SHLIB = $$(OE_QMAKE_LINK)
-+
++QMAKE_CFLAGS_ISYSTEM =
+# for the SDK
+isEmpty(QMAKE_QT_CONFIG):QMAKE_QT_CONFIG = $$(OE_QMAKE_QT_CONFIG)
+
diff --git a/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch b/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
index 7dbce146..ff7dceed 100644
--- a/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
+++ b/recipes-qt/qt5/qtbase/0010-linux-clang-Invert-conditional-for-defining-QT_SOCKL.patch
@@ -1,4 +1,4 @@
-From 7dff9f4506d9d0e3059d0016de748ea2074e19aa Mon Sep 17 00:00:00 2001
+From f5d4eed2a82b327130f3301ea5f8e56169df3dcf Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 09:44:48 -0700
Subject: [PATCH] linux-clang: Invert conditional for defining QT_SOCKLEN_T
diff --git a/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch b/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
index 04e8a0a3..1864ab8f 100644
--- a/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
+++ b/recipes-qt/qt5/qtbase/0011-tst_qlocale-Enable-QT_USE_FENV-only-on-glibc.patch
@@ -1,4 +1,4 @@
-From 5e108991e3f781026a71be241ba7d0c5b06ac655 Mon Sep 17 00:00:00 2001
+From 5cbe22a0f46ab9bcdc5ff8d293ce925d94e951fd Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 3 Sep 2017 10:11:50 -0700
Subject: [PATCH] tst_qlocale: Enable QT_USE_FENV only on glibc
diff --git a/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch b/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
index d636c633..8b7f1425 100644
--- a/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
+++ b/recipes-qt/qt5/qtbase/0012-mkspecs-common-gcc-base.conf-Use-I-instead-of-isyste.patch
@@ -1,4 +1,4 @@
-From 18d57dc5c7946f06f087031be259b9b8922f4691 Mon Sep 17 00:00:00 2001
+From 4cd70420175107d3d707b66735729f3668a447df Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Wed, 14 Feb 2018 17:08:43 -0800
Subject: [PATCH] mkspecs/common/gcc-base.conf: Use -I instead of -isystem
@@ -15,11 +15,26 @@ Upstream-Status: Pending
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
- mkspecs/common/gcc-base.conf | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
+ mkspecs/common/clang.conf | 2 +-
+ mkspecs/common/gcc-base.conf | 2 +-
+ mkspecs/features/toolchain.prf | 4 ++--
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+diff --git a/mkspecs/common/clang.conf b/mkspecs/common/clang.conf
+index 0fb84bc1b3..68b49b5303 100644
+--- a/mkspecs/common/clang.conf
++++ b/mkspecs/common/clang.conf
+@@ -16,7 +16,7 @@ QMAKE_LINK_SHLIB = $$QMAKE_CXX
+ CONFIG += clang_pch_style
+ QMAKE_PCH_OUTPUT_EXT = .pch
+
+-QMAKE_CFLAGS_ISYSTEM = -isystem
++QMAKE_CFLAGS_ISYSTEM =
+ QMAKE_CFLAGS_PRECOMPILE = -x c-header -c ${QMAKE_PCH_INPUT} -o ${QMAKE_PCH_OUTPUT}
+ QMAKE_CFLAGS_USE_PRECOMPILE = -Xclang -include-pch -Xclang ${QMAKE_PCH_OUTPUT}
+ QMAKE_CFLAGS_LTCG = -flto
diff --git a/mkspecs/common/gcc-base.conf b/mkspecs/common/gcc-base.conf
-index 234f71d495..ee3da023e6 100644
+index 234f71d495..c7d81a902e 100644
--- a/mkspecs/common/gcc-base.conf
+++ b/mkspecs/common/gcc-base.conf
@@ -46,7 +46,7 @@ QMAKE_CFLAGS_DEBUG += -g
@@ -27,7 +42,22 @@ index 234f71d495..ee3da023e6 100644
QMAKE_CFLAGS_STATIC_LIB += $$QMAKE_CFLAGS_PIC
QMAKE_CFLAGS_APP += $$QMAKE_CFLAGS_PIC
-QMAKE_CFLAGS_ISYSTEM = -isystem
-+QMAKE_CFLAGS_ISYSTEM = -I
++QMAKE_CFLAGS_ISYSTEM =
QMAKE_CFLAGS_YACC += -Wno-unused -Wno-parentheses
QMAKE_CFLAGS_HIDESYMS += -fvisibility=hidden
QMAKE_CFLAGS_EXCEPTIONS_OFF += -fno-exceptions
+diff --git a/mkspecs/features/toolchain.prf b/mkspecs/features/toolchain.prf
+index fdf3d1cdd3..fb5413736f 100644
+--- a/mkspecs/features/toolchain.prf
++++ b/mkspecs/features/toolchain.prf
+@@ -152,8 +152,8 @@ isEmpty($${target_prefix}.INCDIRS) {
+ }
+
+ unix {
+- isEmpty(QMAKE_DEFAULT_INCDIRS): QMAKE_DEFAULT_INCDIRS = /usr/include /usr/local/include
+- isEmpty(QMAKE_DEFAULT_LIBDIRS): QMAKE_DEFAULT_LIBDIRS = /lib /usr/lib
++ isEmpty(QMAKE_DEFAULT_INCDIRS) & !cross_compile: QMAKE_DEFAULT_INCDIRS = /usr/include /usr/local/include
++ isEmpty(QMAKE_DEFAULT_LIBDIRS) & !cross_compile: QMAKE_DEFAULT_LIBDIRS = /lib /usr/lib
+ }
+
+ cache($${target_prefix}.INCDIRS, set stash, QMAKE_DEFAULT_INCDIRS)
diff --git a/recipes-qt/qt5/qtbase/0013-Upgrade-double-conversion-to-v3.0.0.patch b/recipes-qt/qt5/qtbase/0013-Upgrade-double-conversion-to-v3.0.0.patch
index bc7f0cb7..c6f2f098 100644
--- a/recipes-qt/qt5/qtbase/0013-Upgrade-double-conversion-to-v3.0.0.patch
+++ b/recipes-qt/qt5/qtbase/0013-Upgrade-double-conversion-to-v3.0.0.patch
@@ -1,4 +1,4 @@
-From 1f0101170508a11618ed444d3691cb5369daf7e5 Mon Sep 17 00:00:00 2001
+From 70ea08d861a30b82dc4fa7f2c8dfd62f43a4f365 Mon Sep 17 00:00:00 2001
From: Ulf Hermann <ulf.hermann@qt.io>
Date: Fri, 27 Apr 2018 10:38:18 +0200
Subject: [PATCH] Upgrade double-conversion to v3.0.0
diff --git a/recipes-qt/qt5/qtbase/0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch b/recipes-qt/qt5/qtbase/0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch
index 673e8fd9..d47a38ff 100644
--- a/recipes-qt/qt5/qtbase/0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch
+++ b/recipes-qt/qt5/qtbase/0014-Check-glibc-version-for-renameat2-statx-on-non-boots.patch
@@ -1,4 +1,4 @@
-From 067dd79223c12e40930e612964a77066393a4131 Mon Sep 17 00:00:00 2001
+From 21cb4725d17fa2f491da8e1cd228d74d9d890292 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Tue, 21 Aug 2018 00:29:06 +0200
Subject: [PATCH] Check glibc version for renameat2/statx on non bootstrapped
diff --git a/recipes-qt/qt5/qtbase/0015-double-conversion-support-AARCH64EB-and-arm-BE.patch b/recipes-qt/qt5/qtbase/0015-double-conversion-support-AARCH64EB-and-arm-BE.patch
index 64e454a2..8ee3a57f 100644
--- a/recipes-qt/qt5/qtbase/0015-double-conversion-support-AARCH64EB-and-arm-BE.patch
+++ b/recipes-qt/qt5/qtbase/0015-double-conversion-support-AARCH64EB-and-arm-BE.patch
@@ -1,4 +1,4 @@
-From 3aada36f6706f86b811dafb26e622cd6c99341d6 Mon Sep 17 00:00:00 2001
+From bd82e15fc5d9d5cecade652c8854f33aa71212dd Mon Sep 17 00:00:00 2001
From: Lei Maohui <leimaohui@cn.fujitsu.com>
Date: Wed, 29 Aug 2018 18:20:14 +0900
Subject: [PATCH] double-conversion: support AARCH64EB and arm BE
diff --git a/recipes-qt/qt5/qtbase/0016-Always-build-uic-and-qvkgen.patch b/recipes-qt/qt5/qtbase/0016-Always-build-uic-and-qvkgen.patch
index dfef2508..81ac4f59 100644
--- a/recipes-qt/qt5/qtbase/0016-Always-build-uic-and-qvkgen.patch
+++ b/recipes-qt/qt5/qtbase/0016-Always-build-uic-and-qvkgen.patch
@@ -1,4 +1,4 @@
-From c6edfce8778d1497383124d5a9ed9cb7b9edb1d4 Mon Sep 17 00:00:00 2001
+From 87df95f5ecf85d0053ddc0aa045bbdcd1c6d40e8 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 16 Nov 2013 00:32:30 +0100
Subject: [PATCH] Always build uic and qvkgen
diff --git a/recipes-qt/qt5/qtbase/0017-Bootstrap-without-linkat-feature.patch b/recipes-qt/qt5/qtbase/0017-Bootstrap-without-linkat-feature.patch
index c191a421..353de485 100644
--- a/recipes-qt/qt5/qtbase/0017-Bootstrap-without-linkat-feature.patch
+++ b/recipes-qt/qt5/qtbase/0017-Bootstrap-without-linkat-feature.patch
@@ -1,4 +1,4 @@
-From 365b1b7059d333331a208418b66e9107dc2a4fcc Mon Sep 17 00:00:00 2001
+From dafd3b158d62313cad5217c99036322ea86cc24a Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Fri, 24 Nov 2017 15:16:31 +0200
Subject: [PATCH] Bootstrap without linkat feature
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 72fa2301..9a5f4024 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.11-shared
-# 5.11.meta-qt5-shared.9
+# 5.11.meta-qt5-shared.10
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \