aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-04-17 09:35:00 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2018-04-18 06:01:39 +0000
commitd6b6664ef23c38db48e48be36b90a34ae92dc558 (patch)
tree817b670eddf20ad7d272b1263e4fe471b93f3176
parent93863ffb8e4964391bd95574a2cca7941ef15ff9 (diff)
qt5: update submodulesv5.11.0-beta4
Update to Qt 5.11.0 Beta4 RC Task-number: QTBUG-67589 Change-Id: Ic064bbdae4b61ad3ec86edd70e6cb789723eec1b Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d/0002-Fix-BlenderDNA-for-clang-cross-compiler.patch44
-rw-r--r--recipes-qt/qt5/qt3d_git.bb3
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtknx_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols_git.bb2
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialport_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qttranslations_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb4
-rw-r--r--recipes-qt/qt5/qtwebglplugin_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebsockets_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb2
23 files changed, 23 insertions, 68 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index df87e053..9df5c7a9 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -206,4 +206,4 @@ do_install() {
sed -i -e 's:${SDKPATHNATIVE}:$OECORE_NATIVE_SYSROOT:g' $script
}
-SRCREV = "3e1ecdd74cfb85d1c73f96289fc2114708881c6b"
+SRCREV = "436a6fbb835906e1c62a11dfc7de61461ec767b0"
diff --git a/recipes-qt/qt5/qt3d/0002-Fix-BlenderDNA-for-clang-cross-compiler.patch b/recipes-qt/qt5/qt3d/0002-Fix-BlenderDNA-for-clang-cross-compiler.patch
deleted file mode 100644
index 3357fa3e..00000000
--- a/recipes-qt/qt5/qt3d/0002-Fix-BlenderDNA-for-clang-cross-compiler.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From fc23039612ab9aed4f994b4390016e71ceee8165 Mon Sep 17 00:00:00 2001
-From: Kim Kulling <kim.kulling@googlemail.com>
-Date: Mon, 7 Nov 2016 17:19:49 +0100
-Subject: [PATCH] Fix BlenderDNA for clang cross compiler.
-
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- src/3rdparty/assimp/code/BlenderDNA.cpp | 16 ++++++++--------
- 1 file changed, 8 insertions(+), 8 deletions(-)
-
-diff --git a/src/3rdparty/assimp/code/BlenderDNA.cpp b/src/3rdparty/assimp/code/BlenderDNA.cpp
-index 18ec9f2..5b0b209 100644
---- a/src/3rdparty/assimp/code/BlenderDNA.cpp
-+++ b/src/3rdparty/assimp/code/BlenderDNA.cpp
-@@ -55,10 +55,10 @@ using namespace Assimp::Formatter;
-
- bool match4(StreamReaderAny& stream, const char* string) {
- char tmp[] = {
-- (stream).GetI1(),
-- (stream).GetI1(),
-- (stream).GetI1(),
-- (stream).GetI1()
-+ (const char)(stream).GetI1(),
-+ (const char)(stream).GetI1(),
-+ (const char)(stream).GetI1(),
-+ (const char)(stream).GetI1()
- };
- return (tmp[0]==string[0] && tmp[1]==string[1] && tmp[2]==string[2] && tmp[3]==string[3]);
- }
-@@ -345,10 +345,10 @@ void SectionParser :: Next()
- stream.SetCurrentPos(current.start + current.size);
-
- const char tmp[] = {
-- stream.GetI1(),
-- stream.GetI1(),
-- stream.GetI1(),
-- stream.GetI1()
-+ (const char)stream.GetI1(),
-+ (const char)stream.GetI1(),
-+ (const char)stream.GetI1(),
-+ (const char)stream.GetI1()
- };
- current.id = std::string(tmp,tmp[3]?4:tmp[2]?3:tmp[1]?2:1);
-
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 38281d2b..ded3508f 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -15,7 +15,6 @@ DEPENDS_class-target += "qtdeclarative qt3d-native"
# 5.10.meta-qt5.2
SRC_URI += " \
file://0001-Allow-a-tools-only-build.patch \
- file://0002-Fix-BlenderDNA-for-clang-cross-compiler.patch \
"
PACKAGECONFIG ??= ""
@@ -37,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "2a260617b96281375e2ee018af8c7547d99e4a6d"
+SRCREV = "4f7726155f586ae3aef0b111ae25eacaab91afe9"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index b72d281c..fa7b4364 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -136,4 +136,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "3e1ecdd74cfb85d1c73f96289fc2114708881c6b"
+SRCREV = "436a6fbb835906e1c62a11dfc7de61461ec767b0"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index ac046be8..7318543b 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -247,4 +247,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "3e1ecdd74cfb85d1c73f96289fc2114708881c6b"
+SRCREV = "436a6fbb835906e1c62a11dfc7de61461ec767b0"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index 482e06ee..713f70c6 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtdeclarative-native qtmultimedia"
-SRCREV = "f61c26916edf9944ed1dd465f031620a80e98597"
+SRCREV = "165c768306357ace7c6a52e72c9c4c883c59de0c"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 63ad0317..8e64020f 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "54666d4b42cc212ad1639a058e90ad1f17eed898"
+SRCREV = "96afc728c508708da7a5fa16266dcafafcb60d0b"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 3fed3b49..2699b9a2 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -32,6 +32,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "d2ed475b84d872181b872472c742297476c062c2"
+SRCREV = "73a34bf8319178f2761811240e7c885849f272e9"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtknx_git.bb b/recipes-qt/qt5/qtknx_git.bb
index f962ebd3..3b67827e 100644
--- a/recipes-qt/qt5/qtknx_git.bb
+++ b/recipes-qt/qt5/qtknx_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "bab7fcbf40aad405666316ca55aa7e2e2925ed63"
+SRCREV = "a68b518c322d6392f725c8cb8757e02d7aface21"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 679b23e1..19ab9bc9 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -28,7 +28,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=upstream/qt-staging;protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "0ffb89591a9e2463b36948cdd5e2948de72e14c4"
+SRCREV_qtlocation = "a4d9f8cbf2220fbc8aafd8f491313e39e0bf4a5f"
SRCREV_qtlocation-mapboxgl = "8c1be4ec01ef46bf453856531ebf53b48ce3dbe7"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index c73a98ab..96c78eaa 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -9,4 +9,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "88e0b0fc7e828533fa387f7a367e94b81674e3b1"
+SRCREV = "0d845e00a000f376101165ec9a5c9096030db25c"
diff --git a/recipes-qt/qt5/qtopcua_git.bb b/recipes-qt/qt5/qtopcua_git.bb
index d25b3920..2d5cf6a8 100644
--- a/recipes-qt/qt5/qtopcua_git.bb
+++ b/recipes-qt/qt5/qtopcua_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "2a17f34290fd9a57ecbd21a21616e356145743d5"
+SRCREV = "ef0d2cd86b4f2d11db267b9ae77f89be1c798daa"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index f84acc2f..e790646b 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtdeclarative-native"
-SRCREV = "393cb6f0bacecfe2997c11307a102a9f0f17c173"
+SRCREV = "ca406d69544e6ddf20d940d903c9c97bca07ff90"
diff --git a/recipes-qt/qt5/qtquickcontrols_git.bb b/recipes-qt/qt5/qtquickcontrols_git.bb
index 08be1d13..6378ed27 100644
--- a/recipes-qt/qt5/qtquickcontrols_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols_git.bb
@@ -17,4 +17,4 @@ FILES_${PN}-qmlplugins += " \
${OE_QMAKE_PATH_QML}/QtQuick/Dialogs/qml/icons.ttf \
"
-SRCREV = "a41a3268c7b1f1d510c452e5430db0d5e5ee4055"
+SRCREV = "654de8242411dae548795f9b17648608f8a8c28d"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index b39bfd1a..8b58c2a4 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -24,6 +24,6 @@ PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "35dd08098f8a4b422d523792261aefe039358f6a"
+SRCREV = "c09db54aaac45d4acd9b7c52d8d9b1cb48b6fe55"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtserialport_git.bb b/recipes-qt/qt5/qtserialport_git.bb
index a6eda471..c63b05b2 100644
--- a/recipes-qt/qt5/qtserialport_git.bb
+++ b/recipes-qt/qt5/qtserialport_git.bb
@@ -14,4 +14,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "ea1a95d3567f1264126bf34218a5532ffb5afc51"
+SRCREV = "0c988e14a90f3e1579365dc3dc99fbdd02ac3d4c"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 4477b717..521a8012 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -29,7 +29,7 @@ PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}"
-SRCREV = "944b0f8b7b4426471fb475bc9b98152d005b197b"
+SRCREV = "c66dc18b37bf50d8b773089d161bccd286d4cd3a"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qttranslations_git.bb b/recipes-qt/qt5/qttranslations_git.bb
index 01a69d23..2d8b6117 100644
--- a/recipes-qt/qt5/qttranslations_git.bb
+++ b/recipes-qt/qt5/qttranslations_git.bb
@@ -111,4 +111,4 @@ FILES_${PN}-qt = " \
${OE_QMAKE_PATH_TRANSLATIONS}/qt_*.qm \
"
-SRCREV = "d168acdd2afc6ffb1fa3c1d6788b628affbcac59"
+SRCREV = "446f2f8e444362b393efe57904e178a20346e88f"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index 7425c41e..e789aa3e 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -53,4 +53,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtdeclarative-native qtmultimedia qtquickcontrols qtsvg qtxmlpatterns"
-SRCREV = "7c193dfb8d7f85561411e25224e9028b7c5943e4"
+SRCREV = "a94870b1583857ee5a485ce68369373efb3a9fdc"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index d39da29c..2e715ad3 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -159,8 +159,8 @@ SRC_URI_append_libc-musl = "\
file://0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "dd2acb8a0a5ccbbf34664987fdcf4b3a418c54f9"
-SRCREV_chromium = "293e8de891f03c47d336bb91aa631d496f19fdb3"
+SRCREV_qtwebengine = "db7187bb1420bcbdd933035451895372782ed7e1"
+SRCREV_chromium = "aa9e7d7264980e8ca189dcae4d841cf0e33e03db"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebglplugin_git.bb b/recipes-qt/qt5/qtwebglplugin_git.bb
index 26459ac7..5c45f1a3 100644
--- a/recipes-qt/qt5/qtwebglplugin_git.bb
+++ b/recipes-qt/qt5/qtwebglplugin_git.bb
@@ -18,4 +18,4 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
-SRCREV = "40dff6727a2f70b795df9a93f9d890dd1b8fb834"
+SRCREV = "7bbbe5a86779fd1ff55b07dbda433779f4aff6a7"
diff --git a/recipes-qt/qt5/qtwebsockets_git.bb b/recipes-qt/qt5/qtwebsockets_git.bb
index ae63182d..cd55bdd7 100644
--- a/recipes-qt/qt5/qtwebsockets_git.bb
+++ b/recipes-qt/qt5/qtwebsockets_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "bcea7a1a8b46aa1e9e5fcf3e43bd251360cf8634"
+SRCREV = "34ce4b65ba35a487bdb8afa5e59b57cfa3f9b0e0"
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index b84d08c1..f8c24258 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -19,4 +19,4 @@ COMPATIBLE_MACHINE_armv7a = "(.*)"
COMPATIBLE_MACHINE_armv7ve = "(.*)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
-SRCREV = "574bb84a8b17b510b2ad8661a3bc5fa54e021310"
+SRCREV = "bb7dda99936b97cc262f07b25fcb500f8a552c8a"