aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2018-10-11 09:43:29 +0300
committerMikko Gronoff <mikko.gronoff@qt.io>2018-10-15 06:00:43 +0000
commite6bbbf6f225d4ae926342d4c2f49976641bea8c0 (patch)
treee2dfe18592e33a316c909c42e25451262e9a8727
parent13c852b79587fe8495744cc8523322c9eadd72ae (diff)
qt5: update submodules
Update to latest Qt 5.12.0 snapshot Task-number: QTBUG-70847 Change-Id: Ic909ffe6ba3ba3eb1e0751a86ef51abe0eeb57f1 Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch12
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtserialbus_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebview_git.bb2
-rw-r--r--recipes-qt/qt5/qtxmlpatterns_git.bb2
19 files changed, 24 insertions, 24 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index c8af32e6..880c13c8 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -208,4 +208,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "18be2337ea85655e39f4ffe3b77d2b3ab243c140"
+SRCREV = "5c94130a6708a7f7b4631645e52abd8768a48b7b"
diff --git a/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
index de6826bd..d62c3d5a 100644
--- a/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
+++ b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
@@ -1,4 +1,4 @@
-From 46137e8cf94fd24fe5270739da72e03b7bb92673 Mon Sep 17 00:00:00 2001
+From 55670231dcc22e00e08ec44acda8ca93c9368860 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@theqtcompany.com>
Date: Wed, 10 Feb 2016 09:02:09 +0200
Subject: [PATCH] Allow a tools-only build
@@ -10,12 +10,12 @@ Subject: [PATCH] Allow a tools-only build
3 files changed, 8 insertions(+), 3 deletions(-)
diff --git a/qt3d.pro b/qt3d.pro
-index 6f759b293..5f07c7c4e 100644
+index 3fc7d14..7311eff 100644
--- a/qt3d.pro
+++ b/qt3d.pro
@@ -1,4 +1,4 @@
--requires(qtConfig(opengl):!html5)
-+!tools-only:requires(qtConfig(opengl):!html5)
+-requires(qtConfig(opengl):!wasm)
++!tools-only:requires(qtConfig(opengl):!wasm)
CONFIG += examples_need_tools
load(qt_parts)
@@ -29,7 +29,7 @@ index 6f759b293..5f07c7c4e 100644
+ SUBDIRS = sub_tools
+}
diff --git a/src/3rdparty/assimp/assimp_dependency.pri b/src/3rdparty/assimp/assimp_dependency.pri
-index 8ba2d9a41..e973d93dd 100644
+index 8ba2d9a..e973d93 100644
--- a/src/3rdparty/assimp/assimp_dependency.pri
+++ b/src/3rdparty/assimp/assimp_dependency.pri
@@ -1,5 +1,5 @@
@@ -40,7 +40,7 @@ index 8ba2d9a41..e973d93dd 100644
} else {
include(assimp.pri)
diff --git a/tools/tools.pro b/tools/tools.pro
-index c2f692034..24c49ad5a 100644
+index c2f6920..24c49ad 100644
--- a/tools/tools.pro
+++ b/tools/tools.pro
@@ -1,5 +1,5 @@
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 4c72d78c..459750fa 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -36,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "ece6a7759d4590b50ced79a0c86323318ac8815d"
+SRCREV = "6c77dea4711b6a88e80e30db21d622808e5ef9b6"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index c5f1c37d..0803e612 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -134,4 +134,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "18be2337ea85655e39f4ffe3b77d2b3ab243c140"
+SRCREV = "5c94130a6708a7f7b4631645e52abd8768a48b7b"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 396e5aa9..2d699196 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -250,4 +250,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "18be2337ea85655e39f4ffe3b77d2b3ab243c140"
+SRCREV = "5c94130a6708a7f7b4631645e52abd8768a48b7b"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index 3d421cef..7ecd1e90 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia"
-SRCREV = "3ad4866256e9efdc313ac557326c2796dfac8dfb"
+SRCREV = "bd9f0b27169dcbc3f8bb3914d3e21b1daddeeee5"
# The same issue as in qtbase:
# http://errors.yoctoproject.org/Errors/Details/152641/
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index a1dcb5cb..f5cfe314 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "54f9fe2c230963797dd4f0f9efed7132b0dc429e"
+SRCREV = "35a97ca4b43b4dc481b907d37204613460b07bbd"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index 2335671d..73a007c5 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "913b61e09d5aead27be69fc31eefb4178a64e69a"
+SRCREV = "12d9593daeb8ffc7e50d068923afaf848083dcd4"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 92a0afe3..f265494b 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -33,6 +33,6 @@ do_install_append_class-nativesdk() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtxmlpatterns', 'CONFIG+=OE_QTXMLPATTERNS_ENABLED', '', d)}"
-SRCREV = "ec866a4d72ee5d07c44257d409796c171bcd04f2"
+SRCREV = "7cd9447e14159be90a5fdb927a4a3ed2cbff50b2"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 9ed43c1f..6d208b58 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -31,7 +31,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=${QT_MODULE_BRANCH_MAPBOXGL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "eaffef633e98e2ea94acf5fd0e1a10676591bfa8"
+SRCREV_qtlocation = "8b702b66aa09d6e59da1c99af353eac36cff01e4"
SRCREV_qtlocation-mapboxgl = "4b85252fbe811a786c6ee9eabedb7639b031dc53"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 0c497620..3ee82705 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -37,4 +37,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "ad9f763efea36663bf17321459d44e8dd5e5e653"
+SRCREV = "7750d9014ee38cffe349af5c50f715774e7b1982"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index d80fcd56..e59bbccd 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -9,4 +9,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "876cd89e273851f6e430d1f9ea47f6e667716c89"
+SRCREV = "0930d394d7e2aa51499fc4f735556c97da85afe8"
diff --git a/recipes-qt/qt5/qtserialbus_git.bb b/recipes-qt/qt5/qtserialbus_git.bb
index 96e21d49..315f9dd0 100644
--- a/recipes-qt/qt5/qtserialbus_git.bb
+++ b/recipes-qt/qt5/qtserialbus_git.bb
@@ -11,4 +11,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtserialport"
-SRCREV = "4bfbdd3d061e88de147102db94e70283b89ffff5"
+SRCREV = "7577cd3fa7ebfa35b199d485233f3b41cec79e46"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 983952aa..ebed3e08 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -32,7 +32,7 @@ EXTRA_QMAKEVARS_PRE += " \
${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \
"
-SRCREV = "ede2bcd3a9dacd31e0b274b2591850dd15cf8b7d"
+SRCREV = "1251d22560474bd5272ed31923bd42122a39f9ae"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index c825415e..9526069c 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -49,4 +49,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns qtdeclarative-native"
-SRCREV = "2c603d66246e80b1f974b9ad5f712136d83bb354"
+SRCREV = "6bcc33aea90d5d725a08b51eda7374a50408ee07"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 5a85d042..352e0185 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[wayland-libhybris-egl-server-buffer] = "-feature-wayland-libhybris
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "a1ca3ae56f33bff34db71d1dec6104d0d6614e6d"
+SRCREV = "43d12496c684b5f2b08c6a8c0b994f06efc25712"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 62242f04..85943b0f 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -172,7 +172,7 @@ SRC_URI_append_libc-musl = "\
file://chromium/0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "f89ded9f17a59ca1ffe4d8711c0af4d54489e105"
+SRCREV_qtwebengine = "8b0f6b343dd807236001cacbae9bacb7e4923369"
SRCREV_chromium = "3f8994c671d1cfc674ab64e118304b897a84762c"
SRCREV = "${SRCREV_qtwebengine}"
diff --git a/recipes-qt/qt5/qtwebview_git.bb b/recipes-qt/qt5/qtwebview_git.bb
index dc91d360..34108d40 100644
--- a/recipes-qt/qt5/qtwebview_git.bb
+++ b/recipes-qt/qt5/qtwebview_git.bb
@@ -19,4 +19,4 @@ COMPATIBLE_MACHINE_armv7a = "(.*)"
COMPATIBLE_MACHINE_armv7ve = "(.*)"
COMPATIBLE_MACHINE_aarch64 = "(.*)"
-SRCREV = "cd0814a2431db435279cf775a0fca460a0b81582"
+SRCREV = "eea4b92dbb1c333f073e6ad7f146957ac95624aa"
diff --git a/recipes-qt/qt5/qtxmlpatterns_git.bb b/recipes-qt/qt5/qtxmlpatterns_git.bb
index 2956d480..1f1ddec3 100644
--- a/recipes-qt/qt5/qtxmlpatterns_git.bb
+++ b/recipes-qt/qt5/qtxmlpatterns_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "d5762832ea8e5ca37457b2fa895bacf70173fde5"
+SRCREV = "7df0037316cc2efa7ac082231b72a3fe5dcdfe8f"
BBCLASSEXTEND =+ "native nativesdk"