aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-05-14 16:16:24 +0300
committerSamuli Piippo <samuli.piippo@qt.io>2018-05-15 05:48:50 +0000
commite721ad37f5f29cef5a036c28dcee7e4fa838062c (patch)
tree12433d0002127bd080fe285056d9fe8d49e07f56
parentdf18090b2dede916094a812fb0af70cade3e6ab2 (diff)
qtquickcompiler: add dependency into PACKAGECONFIG
qtdeclarative-native provides the required qmlcachegen binary, add dependency to it into PACKAGECONFIG instead of each recipe. Change-Id: I2f687fc95403502679e2c14dbc9e597314ddc674 Reviewed-by: Mikko Gronoff <mikko.gronoff@qt.io>
-rw-r--r--recipes-qt/qt5/qt5.inc2
-rw-r--r--recipes-qt/qt5/qtcharts_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc
index b17feaa4..edae5724 100644
--- a/recipes-qt/qt5/qt5.inc
+++ b/recipes-qt/qt5/qt5.inc
@@ -7,7 +7,7 @@ PACKAGECONFIG_OPENSSL ?= "openssl"
PACKAGECONFIG[examples] = ""
PACKAGECONFIG[tests] = ""
-PACKAGECONFIG[qtquickcompiler] = ""
+PACKAGECONFIG[qtquickcompiler] = ",,qtdeclarative-native"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'examples', 'QT_BUILD_PARTS+=examples', '', d)}"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'tests', 'QT_BUILD_PARTS+=tests', '', d)}"
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtquickcompiler', 'CONFIG+=qtquickcompiler', '', d)}"
diff --git a/recipes-qt/qt5/qtcharts_git.bb b/recipes-qt/qt5/qtcharts_git.bb
index e0bacf63..a6ec17f8 100644
--- a/recipes-qt/qt5/qtcharts_git.bb
+++ b/recipes-qt/qt5/qtcharts_git.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = " \
file://LICENSE.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
"
-DEPENDS += "qtbase qtdeclarative qtdeclarative-native qtmultimedia"
+DEPENDS += "qtbase qtdeclarative qtmultimedia"
SRCREV = "4f66d1ffeecd95b4bf6666b71536c42dea7450ed"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index b20b1d77..1a79093e 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -11,7 +11,7 @@ LIC_FILES_CHKSUM = " \
file://src/3rdparty/mapbox-gl-native/LICENSE.md;md5=0ab9025299bcee16858021d557f09449 \
"
-DEPENDS += "qtbase qtxmlpatterns qtdeclarative qtdeclarative-native qtquickcontrols"
+DEPENDS += "qtbase qtxmlpatterns qtdeclarative qtquickcontrols"
PACKAGECONFIG ??= ""
# older geoclue 0.12.99 is needed