aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Gronoff <mikko.gronoff@qt.io>2019-02-19 15:27:44 +0200
committerMikko Gronoff <mikko.gronoff@qt.io>2019-02-21 15:31:15 +0000
commited327d9cd97c0996e0875b0c03f86cbd76232977 (patch)
tree1b1b89d8617badc2e4a9b35af4d3472613b06a12
parent282f531e63961300be055665acc454356de889fa (diff)
qt5: update submodules
Update to latest content in Qt 5.13 branch Task-number: QTBUG-72311 Change-Id: If99527ca97867b99d5273e229d7e98a6cd149f5e Reviewed-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch16
-rw-r--r--recipes-qt/qt5/qt3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb2
-rw-r--r--recipes-qt/qt5/qtdatavis3d_git.bb2
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb2
-rw-r--r--recipes-qt/qt5/qtimageformats_git.bb2
-rw-r--r--recipes-qt/qt5/qtlocation_git.bb2
-rw-r--r--recipes-qt/qt5/qtmqtt_git.bb2
-rw-r--r--recipes-qt/qt5/qtmultimedia_git.bb2
-rw-r--r--recipes-qt/qt5/qtnetworkauth_git.bb2
-rw-r--r--recipes-qt/qt5/qtopcua_git.bb2
-rw-r--r--recipes-qt/qt5/qtpurchasing_git.bb2
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb2
-rw-r--r--recipes-qt/qt5/qtremoteobjects_git.bb2
-rw-r--r--recipes-qt/qt5/qtscript_git.bb2
-rw-r--r--recipes-qt/qt5/qtscxml_git.bb2
-rw-r--r--recipes-qt/qt5/qtsvg_git.bb2
-rw-r--r--recipes-qt/qt5/qttools_git.bb2
-rw-r--r--recipes-qt/qt5/qtvirtualkeyboard_git.bb2
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb2
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch26
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0001-chromium-Force-host-toolchain-configuration.patch33
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb5
-rw-r--r--recipes-qt/qt5/qtwebglplugin_git.bb2
27 files changed, 55 insertions, 71 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index bca866c7..55de4271 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -193,4 +193,4 @@ fakeroot do_generate_qt_environment_file() {
do_generate_qt_environment_file[umask] = "022"
addtask generate_qt_environment_file after do_install before do_package
-SRCREV = "c1f4286a5cbc1794fe7be5bdbbd6a0bf29ef84d4"
+SRCREV = "99e9666492095e3b96ac16f03e28f20288cc0af6"
diff --git a/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
index e4d9c2a0..b7c66a97 100644
--- a/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
+++ b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch
@@ -1,25 +1,27 @@
-From d3053e33c76cdb41eeeec3c853fa88c7c7bfb8a5 Mon Sep 17 00:00:00 2001
+From 4c9ae42a69cf1be055df9fce1ae9ebda301b1f58 Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Fri, 17 Aug 2018 13:23:58 +0300
Subject: [PATCH] Allow a tools-only build
---
- qt3d.pro | 7 ++++++-
+ qt3d.pro | 9 +++++++--
src/3rdparty/assimp/assimp_dependency.pri | 2 +-
tools/tools.pro | 2 +-
- 3 files changed, 8 insertions(+), 3 deletions(-)
+ 3 files changed, 9 insertions(+), 4 deletions(-)
diff --git a/qt3d.pro b/qt3d.pro
-index 3fc7d1452..7311eff5b 100644
+index 847507f..286286d 100644
--- a/qt3d.pro
+++ b/qt3d.pro
-@@ -1,4 +1,4 @@
+@@ -1,5 +1,5 @@
+-requires(qtHaveModule(gui))
-requires(qtConfig(opengl):!wasm)
++!tools-only:requires(qtHaveModule(gui))
+!tools-only:requires(qtConfig(opengl):!wasm)
CONFIG += examples_need_tools
load(qt_parts)
-@@ -14,3 +14,8 @@ load(qt_parts)
+@@ -15,3 +15,8 @@ load(qt_parts)
OTHER_FILES += \
sync.profile
@@ -40,7 +42,7 @@ index 8ba2d9a..e973d93 100644
} else {
include(assimp.pri)
diff --git a/tools/tools.pro b/tools/tools.pro
-index 121507613..24c49ad5a 100644
+index 1215076..24c49ad 100644
--- a/tools/tools.pro
+++ b/tools/tools.pro
@@ -1,5 +1,5 @@
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index 9d2acd99..a510276e 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -36,6 +36,6 @@ do_configure_prepend() {
${S}/src/quick3d/imports/input/importsinput.pro
}
-SRCREV = "bf40a6cbf6b0045c157431f2717697c37bd20697"
+SRCREV = "e8f551be32913f5a9f9e9ce011b172a4a2a366b0"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index aae297a7..c281d865 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -139,4 +139,4 @@ do_install() {
echo 'set(_qt5_corelib_extra_includes "${_qt5Core_install_prefix}/lib${QT_DIR_NAME}/mkspecs/linux-oe-g++")' > ${D}${libdir}/cmake/Qt5Core/Qt5CoreConfigExtrasMkspecDir.cmake
}
-SRCREV = "c1f4286a5cbc1794fe7be5bdbbd6a0bf29ef84d4"
+SRCREV = "99e9666492095e3b96ac16f03e28f20288cc0af6"
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index b9cb7184..2acd833e 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -253,4 +253,4 @@ INSANE_SKIP_${PN}-mkspecs += "file-rdeps"
RRECOMMENDS_${PN}-plugins += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libx11-locale', '', d)}"
-SRCREV = "c1f4286a5cbc1794fe7be5bdbbd6a0bf29ef84d4"
+SRCREV = "99e9666492095e3b96ac16f03e28f20288cc0af6"
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 8a96d821..2cadbdb0 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -19,4 +19,4 @@ PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "005cef90c6e06ef419dcec8f4619402677470301"
+SRCREV = "cc615e02420769e61993e6183897087992a47d6c"
diff --git a/recipes-qt/qt5/qtdatavis3d_git.bb b/recipes-qt/qt5/qtdatavis3d_git.bb
index 2d6965f6..b12dea39 100644
--- a/recipes-qt/qt5/qtdatavis3d_git.bb
+++ b/recipes-qt/qt5/qtdatavis3d_git.bb
@@ -8,4 +8,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative qtmultimedia qtxmlpatterns"
-SRCREV = "7d7038d47a72cd203785080e997458f0d44f5e15"
+SRCREV = "7044c0c82c1bccbff9f7ab0d8344c89fcf7cc043"
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 5192649a..3fb847c6 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -24,6 +24,6 @@ do_install_append_class-nativesdk() {
rm -rf ${D}${OE_QMAKE_PATH_QML}
}
-SRCREV = "e04e5db13d2a1d03e4afe139fcc29e0ed5b1edab"
+SRCREV = "fee0fcfef08a05ed4ba9369d2352c876b514d69c"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtimageformats_git.bb b/recipes-qt/qt5/qtimageformats_git.bb
index 06600e08..4bcd0cef 100644
--- a/recipes-qt/qt5/qtimageformats_git.bb
+++ b/recipes-qt/qt5/qtimageformats_git.bb
@@ -25,4 +25,4 @@ PACKAGECONFIG[libwebp] = ",CONFIG+=done_config_libwebp,libwebp"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "5904479f50ccafc9556475b4e039d707eadc58b7"
+SRCREV = "2decf5c6dd3df823b385dce62b067fb5b13d399d"
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb
index 7bc2dc7b..da882baa 100644
--- a/recipes-qt/qt5/qtlocation_git.bb
+++ b/recipes-qt/qt5/qtlocation_git.bb
@@ -31,7 +31,7 @@ SRC_URI += " \
${QT_GIT}/qtlocation-mapboxgl.git;name=qtlocation-mapboxgl;branch=${QT_MODULE_BRANCH_MAPBOXGL};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty/mapbox-gl-native \
"
-SRCREV_qtlocation = "ad7bcebc575922fc7c5654c118794e5758d347d2"
+SRCREV_qtlocation = "dc6b519f08916b8e48d27700e87c3e355fffbd33"
SRCREV_qtlocation-mapboxgl = "4b85252fbe811a786c6ee9eabedb7639b031dc53"
SRCREV_FORMAT = "qtlocation_qtlocation-mapboxgl"
diff --git a/recipes-qt/qt5/qtmqtt_git.bb b/recipes-qt/qt5/qtmqtt_git.bb
index ee3d8095..9acf9f0b 100644
--- a/recipes-qt/qt5/qtmqtt_git.bb
+++ b/recipes-qt/qt5/qtmqtt_git.bb
@@ -9,4 +9,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "90504201a6c62d24dd48749a0be106dff7e686d0"
+SRCREV = "51de5f22ca4a6fbbed6a9ed398884cbc0e59f8f8"
diff --git a/recipes-qt/qt5/qtmultimedia_git.bb b/recipes-qt/qt5/qtmultimedia_git.bb
index 6257b2ae..e657fb35 100644
--- a/recipes-qt/qt5/qtmultimedia_git.bb
+++ b/recipes-qt/qt5/qtmultimedia_git.bb
@@ -37,4 +37,4 @@ SRC_URI += "\
# http://errors.yoctoproject.org/Errors/Build/44914/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "26830d435d942ce580dfe17209563c47eb3da722"
+SRCREV = "4077428310aefb64b8030ea0da00343afc986e1a"
diff --git a/recipes-qt/qt5/qtnetworkauth_git.bb b/recipes-qt/qt5/qtnetworkauth_git.bb
index c03b0b13..c497038f 100644
--- a/recipes-qt/qt5/qtnetworkauth_git.bb
+++ b/recipes-qt/qt5/qtnetworkauth_git.bb
@@ -9,4 +9,4 @@ require qt5-git.inc
DEPENDS += "qtbase"
-SRCREV = "a0d040060f6ff1a4db87498afdcf85ce46de0d81"
+SRCREV = "77f55b1db58bb9941791a70185e88829cca9db6d"
diff --git a/recipes-qt/qt5/qtopcua_git.bb b/recipes-qt/qt5/qtopcua_git.bb
index 41a278ca..5d13bbe7 100644
--- a/recipes-qt/qt5/qtopcua_git.bb
+++ b/recipes-qt/qt5/qtopcua_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "5e8d47972cc3cf6e89d87a443b5da863397f6784"
+SRCREV = "1274cfe8d2be35105007c6895f6104a679d075e0"
diff --git a/recipes-qt/qt5/qtpurchasing_git.bb b/recipes-qt/qt5/qtpurchasing_git.bb
index c0d325be..80e21120 100644
--- a/recipes-qt/qt5/qtpurchasing_git.bb
+++ b/recipes-qt/qt5/qtpurchasing_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative"
-SRCREV = "4c45534f40d963142ee4ac957679776b72c098b0"
+SRCREV = "4c873e79bd9d02b707392aacf3699fdca3c990ec"
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index a6d5c301..e44dbd0e 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative qtdeclarative-native"
-SRCREV = "3afec43b69991753416380d88e22b5382b8b0832"
+SRCREV = "3b467b5c5b34795fc4dfcd9cb8822aa3a3d8cf1c"
diff --git a/recipes-qt/qt5/qtremoteobjects_git.bb b/recipes-qt/qt5/qtremoteobjects_git.bb
index b14d2f9d..d4ab7063 100644
--- a/recipes-qt/qt5/qtremoteobjects_git.bb
+++ b/recipes-qt/qt5/qtremoteobjects_git.bb
@@ -24,6 +24,6 @@ PACKAGECONFIG[tools-only] = "CONFIG+=tools-only"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "2a14e88f548fbc20537ed9a2736c2e058a1d59af"
+SRCREV = "9387eae35fe82b441c6349a866929e855363db45"
BBCLASSEXTEND += "native nativesdk"
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb
index 78090b70..25c16288 100644
--- a/recipes-qt/qt5/qtscript_git.bb
+++ b/recipes-qt/qt5/qtscript_git.bb
@@ -36,4 +36,4 @@ DEPENDS += "qtbase"
# http://errors.yoctoproject.org/Errors/Build/44915/
LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
-SRCREV = "da2f08af67916ce09daf6dea185a118e0f8bcd6b"
+SRCREV = "313e6548b0393af9069b043f65ea6e6c0a546487"
diff --git a/recipes-qt/qt5/qtscxml_git.bb b/recipes-qt/qt5/qtscxml_git.bb
index c7d70130..72b9d696 100644
--- a/recipes-qt/qt5/qtscxml_git.bb
+++ b/recipes-qt/qt5/qtscxml_git.bb
@@ -10,7 +10,7 @@ require qt5-git.inc
DEPENDS += "qtbase qtdeclarative qtxmlpatterns qtscxml-native"
-SRCREV = "2d83e09f9d6ca4d604571d7989a359381e6c93ff"
+SRCREV = "60796708aad85281a519a85cdebcfab50914370f"
# Patches from https://github.com/meta-qt5/qtscxml/commits/b5.12
# 5.12.meta-qt5.1
diff --git a/recipes-qt/qt5/qtsvg_git.bb b/recipes-qt/qt5/qtsvg_git.bb
index 4e48e73a..168a6c44 100644
--- a/recipes-qt/qt5/qtsvg_git.bb
+++ b/recipes-qt/qt5/qtsvg_git.bb
@@ -12,4 +12,4 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase"
-SRCREV = "fbad8e7701708c07bfbae73e6c3158fd9e560ee7"
+SRCREV = "0c023adada49bab1098e7df274ad7889828ef439"
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index 7dd038bf..249bd87f 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -32,7 +32,7 @@ EXTRA_QMAKEVARS_PRE += " \
${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \
"
-SRCREV = "bf8ee4c99d56c2bf770343b7db07f68a2c6a7617"
+SRCREV = "f008b2dd19f81af91b0fa7ddc7805a6cc0e381a7"
BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-qt/qt5/qtvirtualkeyboard_git.bb b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
index f7a1dff6..4440a470 100644
--- a/recipes-qt/qt5/qtvirtualkeyboard_git.bb
+++ b/recipes-qt/qt5/qtvirtualkeyboard_git.bb
@@ -49,4 +49,4 @@ FILES_${PN} += "${OE_QMAKE_PATH_DATA}/qtvirtualkeyboard/lipi_toolkit"
DEPENDS += "qtbase qtdeclarative qtmultimedia qtquickcontrols qtsvg qtxmlpatterns qtdeclarative-native"
-SRCREV = "017b7dff8b3e8ebfcd399409b3706afc170124f3"
+SRCREV = "45506f4fcbc945ccc7bbb34d95776875ea0f97c1"
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 13e60d7e..c90e2414 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -37,7 +37,7 @@ PACKAGECONFIG[wayland-libhybris-egl-server-buffer] = "-feature-wayland-libhybris
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
-SRCREV = "60d6d83ea0c43462d5f8e17aaa654ab6f625dd6e"
+SRCREV = "cf378b581009b80510cf54c8b56d4c2d950c1153"
BBCLASSEXTEND =+ "native nativesdk"
diff --git a/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch b/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
index b51c4c72..1aaf9498 100644
--- a/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
+++ b/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
@@ -1,4 +1,4 @@
-From a321d1b96ce0563a08d0bb44c39d24f86608f6ae Mon Sep 17 00:00:00 2001
+From 376b5b262f2ed936920a66167b76edab781ddcff Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Wed, 15 Mar 2017 13:53:28 +0200
Subject: [PATCH] Force host toolchain configuration
@@ -14,11 +14,12 @@ Upstream-Status: Inappropriate [OE specific]
Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
---
src/buildtools/configure_host.pro | 14 +++++++-------
+ src/buildtools/gn.pro | 4 ++--
src/core/config/linux.pri | 2 +-
- 2 files changed, 8 insertions(+), 8 deletions(-)
+ 3 files changed, 10 insertions(+), 10 deletions(-)
diff --git a/src/buildtools/configure_host.pro b/src/buildtools/configure_host.pro
-index dd0d3e32..70161c82 100644
+index dd0d3e3..70161c8 100644
--- a/src/buildtools/configure_host.pro
+++ b/src/buildtools/configure_host.pro
@@ -4,7 +4,7 @@ TEMPLATE = aux
@@ -56,11 +57,26 @@ index dd0d3e32..70161c82 100644
" ar = \"$$which(ar)\" " \
" nm = \"$$which(nm)\" " \
" toolchain_args = { " \
+diff --git a/src/buildtools/gn.pro b/src/buildtools/gn.pro
+index 7766af0..46defa6 100644
+--- a/src/buildtools/gn.pro
++++ b/src/buildtools/gn.pro
+@@ -19,8 +19,8 @@ build_pass|!debug_and_release {
+ gn_bootstrap = $$system_path($$absolute_path(gn/build/gen.py, $$src_3rd_party_dir))
+
+ gn_configure = $$system_quote($$gn_bootstrap) --no-last-commit-position --out-path $$out_path \
+- --cc \"$$which($$QMAKE_CC)\" --cxx \"$$which($$QMAKE_CXX)\" \
+- --ld \"$$which($$QMAKE_LINK)\" --ar \"$$which(ar)\"
++ --cc \"$$which(gcc)\" --cxx \"$$which(g++)\" \
++ --ld \"$$which(g++)\" --ar \"$$which(ar)\"
+ message($$gn_configure)
+ !system("$$pythonPathForSystem() $$gn_configure") {
+ error("GN generation error!")
diff --git a/src/core/config/linux.pri b/src/core/config/linux.pri
-index 85b948db..c529c641 100644
+index 04c9eca..c48fa06 100644
--- a/src/core/config/linux.pri
+++ b/src/core/config/linux.pri
-@@ -112,7 +112,7 @@ contains(QT_ARCH, "mips") {
+@@ -115,7 +115,7 @@ contains(QT_ARCH, "mips") {
host_build {
gn_args += custom_toolchain=\"$$QTWEBENGINE_OUT_ROOT/src/toolchain:host\"
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0001-chromium-Force-host-toolchain-configuration.patch b/recipes-qt/qt5/qtwebengine/chromium/0001-chromium-Force-host-toolchain-configuration.patch
deleted file mode 100644
index d914a862..00000000
--- a/recipes-qt/qt5/qtwebengine/chromium/0001-chromium-Force-host-toolchain-configuration.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-From f430c2c9b3d38f9150588da6dc154aa2285584e6 Mon Sep 17 00:00:00 2001
-From: Samuli Piippo <samuli.piippo@qt.io>
-Date: Wed, 15 Mar 2017 13:53:28 +0200
-Subject: [PATCH] chromium: Force host toolchain configuration
-
-Force gcc/g++ to be used for parts using host toolchain, since
-the option(host_build) does not work in yocto builds.
-
-Upstream-Status: Inappropriate [OE specific]
-Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
-Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
----
- gn/build/gen.py | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
-
-diff --git a/gn/build/gen.py b/gn/build/gen.py
-index 87db4c26bcf..34c853b7f4a 100755
---- a/gn/build/gen.py
-+++ b/gn/build/gen.py
-@@ -310,10 +310,10 @@ def WriteGNNinja(path, platform, host, options, linux_sysroot):
- ld = os.environ.get('LD', 'g++')
- ar = os.environ.get('AR', 'ar -X64')
- else:
-- cc = os.environ.get('CC', 'cc')
-- cxx = os.environ.get('CXX', 'c++')
-+ cc = os.environ.get('CC_host', 'gcc')
-+ cxx = os.environ.get('CXX_host', 'g++')
- ld = cxx
-- ar = os.environ.get('AR', 'ar')
-+ ar = os.environ.get('AR_host', 'ar')
-
- # QTBUG-64759
- # cflags = os.environ.get('CFLAGS', '').split()
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 6e50be35..15d95ccb 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -149,7 +149,6 @@ SRC_URI_append_libc-musl = "\
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/69-based
# 69-based.meta-qt5.3
SRC_URI += " \
- file://chromium/0001-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \
file://chromium/0002-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
file://chromium/0003-chromium-Fix-build-with-gcc8.patch;patchdir=src/3rdparty \
file://chromium/0004-chromium-stack-pointer-clobber.patch;patchdir=src/3rdparty \
@@ -172,8 +171,8 @@ SRC_URI_append_libc-musl = "\
file://chromium/0018-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
"
-SRCREV_qtwebengine = "60f16cae918adc96e5b01e8599b14a34b97902ef"
-SRCREV_chromium = "8d510183ca27142801b56bb50d63cbb2a92d4337"
+SRCREV_qtwebengine = "05369331163c3c07907c2caed98e3eaabbdfe023"
+SRCREV_chromium = "bb8520a5b4a49085e38b70cb4c95baf75ea374e9"
SRCREV = "${SRCREV_qtwebengine}"
SRCREV_FORMAT = "qtwebengine_chromium"
diff --git a/recipes-qt/qt5/qtwebglplugin_git.bb b/recipes-qt/qt5/qtwebglplugin_git.bb
index 6f6fea5d..0cfc14c2 100644
--- a/recipes-qt/qt5/qtwebglplugin_git.bb
+++ b/recipes-qt/qt5/qtwebglplugin_git.bb
@@ -18,4 +18,4 @@ do_configure_prepend() {
EXTRA_QMAKEVARS_PRE += "${@bb.utils.contains('PACKAGECONFIG', 'qtdeclarative', 'CONFIG+=OE_QTDECLARATIVE_ENABLED', '', d)}"
-SRCREV = "d5ed6b5cfd8b8af6c9396a1234df1633aa22dbd8"
+SRCREV = "31f06ca32ebd87c5b1bad6882e2d0b4689c7e85a"