aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2023-01-18 13:06:19 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2023-01-18 13:07:11 +0100
commit052f05bb4f2fcb61af882010659245da949d2b5e (patch)
treef524d5894ac6055e79552f3e6fcc6cbcf46ba2f8
parent9e594819627ac37c7a6d2366c548a7437b38777b (diff)
qtbase: Fix build with 64bit time_t on glibc
* one more fix is needed for evdevkeyboard in 5.12 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/nativesdk-qtbase_git.bb10
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb12
-rw-r--r--recipes-qt/qt5/qtbase/0019-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch (renamed from recipes-qt/qt5/qtbase/0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch)5
-rw-r--r--recipes-qt/qt5/qtbase/0020-evdevkeyboard-fix-input_event-time-related-compile.patch60
-rw-r--r--recipes-qt/qt5/qtbase/0021-Always-build-uic-and-qvkgen.patch (renamed from recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch)2
-rw-r--r--recipes-qt/qt5/qtbase/0022-Avoid-renameeat2-for-native-sdk-builds.patch (renamed from recipes-qt/qt5/qtbase/0020-Avoid-renameeat2-for-native-sdk-builds.patch)2
-rw-r--r--recipes-qt/qt5/qtbase/0023-Bootstrap-without-linkat-feature.patch (renamed from recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch)2
-rw-r--r--recipes-qt/qt5/qtbase_git.bb6
8 files changed, 80 insertions, 19 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb
index be37f552..83eb549b 100644
--- a/recipes-qt/qt5/nativesdk-qtbase_git.bb
+++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb
@@ -25,7 +25,7 @@ FILESEXTRAPATHS =. "${FILE_DIRNAME}/qtbase:"
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.12
+# 5.12.meta-qt5-shared.13
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -45,14 +45,16 @@ SRC_URI += "\
file://0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0017-Fix-Wdeprecated-copy-warnings.patch \
file://0018-qfloat16-Include-limits-header.patch \
+ file://0019-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch \
+ file://0020-evdevkeyboard-fix-input_event-time-related-compile.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.12
+# 5.12.meta-qt5-native.13
SRC_URI += " \
- file://0019-Always-build-uic-and-qvkgen.patch \
- file://0020-Avoid-renameeat2-for-native-sdk-builds.patch \
+ file://0021-Always-build-uic-and-qvkgen.patch \
+ file://0022-Avoid-renameeat2-for-native-sdk-builds.patch \
"
# CMake's toolchain configuration of nativesdk-qtbase
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index 7cf33dc7..d4db457a 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -18,7 +18,7 @@ require qt5-git.inc
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.12
+# 5.12.meta-qt5-shared.13
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -38,19 +38,21 @@ SRC_URI += "\
file://0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0017-Fix-Wdeprecated-copy-warnings.patch \
file://0018-qfloat16-Include-limits-header.patch \
+ file://0019-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch \
+ file://0020-evdevkeyboard-fix-input_event-time-related-compile.patch \
"
# common for qtbase-native and nativesdk-qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-native
-# 5.12.meta-qt5-native.12
+# 5.12.meta-qt5-native.13
SRC_URI += " \
- file://0019-Always-build-uic-and-qvkgen.patch \
- file://0020-Avoid-renameeat2-for-native-sdk-builds.patch \
+ file://0021-Always-build-uic-and-qvkgen.patch \
+ file://0022-Avoid-renameeat2-for-native-sdk-builds.patch \
"
# only for qtbase-native
SRC_URI += " \
- file://0021-Bootstrap-without-linkat-feature.patch \
+ file://0023-Bootstrap-without-linkat-feature.patch \
"
CLEANBROKEN = "1"
diff --git a/recipes-qt/qt5/qtbase/0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch b/recipes-qt/qt5/qtbase/0019-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch
index 17a34761..e6b7bd02 100644
--- a/recipes-qt/qt5/qtbase/0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch
+++ b/recipes-qt/qt5/qtbase/0019-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch
@@ -1,4 +1,4 @@
-From 4e00087b393183493a0f7115fd41efc867bd3421 Mon Sep 17 00:00:00 2001
+From 86c91e5f4340ced36fb33ab380760bbccfdb84e2 Mon Sep 17 00:00:00 2001
From: Khem Raj <raj.khem@gmail.com>
Date: Sun, 1 Jan 2023 21:30:23 -0800
Subject: [PATCH] zlib: Do not undefine _FILE_OFFSET_BITS
@@ -32,6 +32,3 @@ index 20de7cb4ce..f6ab9357c7 100644
#ifndef QT_BOOTSTRAPPED
# include <qconfig.h>
#endif
---
-2.39.0
-
diff --git a/recipes-qt/qt5/qtbase/0020-evdevkeyboard-fix-input_event-time-related-compile.patch b/recipes-qt/qt5/qtbase/0020-evdevkeyboard-fix-input_event-time-related-compile.patch
new file mode 100644
index 00000000..8af46a06
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0020-evdevkeyboard-fix-input_event-time-related-compile.patch
@@ -0,0 +1,60 @@
+From 85e1eb951ab3b1fda04a49e52f50bc9c50af1a13 Mon Sep 17 00:00:00 2001
+From: Peter Seiderer <ps.report@gmx.net>
+Date: Mon, 4 May 2020 23:17:45 +0200
+Subject: [PATCH] evdevkeyboard: fix input_event time related compile
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Fixes:
+
+ evdevkeyboard/qevdevkeyboardhandler.cpp: In member function ‘void QEvdevKeyboardHandler::switchLed(int, bool)’:
+ evdevkeyboard/qevdevkeyboardhandler.cpp:153:28: error: ‘struct input_event’ has no member named ‘time’; did you mean ‘type’?
+ ::gettimeofday(&led_ie.time, 0);
+ ^~~~
+ type
+
+Task-number: QTBUG-84012
+Change-Id: I1d127561e0406ae570da656d3e31f9434c7b8798
+Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
+(cherry picked from commit c5b8b662105cc5ced968da9f567fe1134c52d6b5)
+
+Upstream-Status: Backport [5.15 d9b430560a6ea28fc6024cede34d765c7bd68e22]
+
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ .../input/evdevkeyboard/qevdevkeyboardhandler.cpp | 13 ++++++++++++-
+ 1 file changed, 12 insertions(+), 1 deletion(-)
+
+diff --git a/src/platformsupport/input/evdevkeyboard/qevdevkeyboardhandler.cpp b/src/platformsupport/input/evdevkeyboard/qevdevkeyboardhandler.cpp
+index ad134a825f..f2b47b82bc 100644
+--- a/src/platformsupport/input/evdevkeyboard/qevdevkeyboardhandler.cpp
++++ b/src/platformsupport/input/evdevkeyboard/qevdevkeyboardhandler.cpp
+@@ -58,6 +58,14 @@
+ #include <linux/input.h>
+ #endif
+
++#ifndef input_event_sec
++#define input_event_sec time.tv_sec
++#endif
++
++#ifndef input_event_usec
++#define input_event_usec time.tv_usec
++#endif
++
+ QT_BEGIN_NAMESPACE
+
+ Q_LOGGING_CATEGORY(qLcEvdevKey, "qt.qpa.input")
+@@ -148,8 +156,11 @@ void QEvdevKeyboardHandler::switchLed(int led, bool state)
+ {
+ qCDebug(qLcEvdevKey) << "switchLed" << led << state;
+
++ struct timeval tv;
++ ::gettimeofday(&tv, 0);
+ struct ::input_event led_ie;
+- ::gettimeofday(&led_ie.time, 0);
++ led_ie.input_event_sec = tv.tv_sec;
++ led_ie.input_event_usec = tv.tv_usec;
+ led_ie.type = EV_LED;
+ led_ie.code = led;
+ led_ie.value = state;
diff --git a/recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch b/recipes-qt/qt5/qtbase/0021-Always-build-uic-and-qvkgen.patch
index 48466883..3cb5ab24 100644
--- a/recipes-qt/qt5/qtbase/0019-Always-build-uic-and-qvkgen.patch
+++ b/recipes-qt/qt5/qtbase/0021-Always-build-uic-and-qvkgen.patch
@@ -1,4 +1,4 @@
-From 0eb870c467ecb1f756f665e65798deb21dd360f0 Mon Sep 17 00:00:00 2001
+From 4dde34f5b142ab7700469e566cbed78699438460 Mon Sep 17 00:00:00 2001
From: Martin Jansa <Martin.Jansa@gmail.com>
Date: Sat, 16 Nov 2013 00:32:30 +0100
Subject: [PATCH] Always build uic and qvkgen
diff --git a/recipes-qt/qt5/qtbase/0020-Avoid-renameeat2-for-native-sdk-builds.patch b/recipes-qt/qt5/qtbase/0022-Avoid-renameeat2-for-native-sdk-builds.patch
index 4daa3bee..fa77ef5a 100644
--- a/recipes-qt/qt5/qtbase/0020-Avoid-renameeat2-for-native-sdk-builds.patch
+++ b/recipes-qt/qt5/qtbase/0022-Avoid-renameeat2-for-native-sdk-builds.patch
@@ -1,4 +1,4 @@
-From e45d6335b5030195cffb54a49632e0123477cf42 Mon Sep 17 00:00:00 2001
+From 026db0b6cbffba8c46df8b1eb739ef53df9b413d Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
Date: Sun, 14 Apr 2019 13:27:58 +0200
Subject: [PATCH] Avoid renameeat2 for native(sdk) builds
diff --git a/recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch b/recipes-qt/qt5/qtbase/0023-Bootstrap-without-linkat-feature.patch
index 493d867f..b0bcb776 100644
--- a/recipes-qt/qt5/qtbase/0021-Bootstrap-without-linkat-feature.patch
+++ b/recipes-qt/qt5/qtbase/0023-Bootstrap-without-linkat-feature.patch
@@ -1,4 +1,4 @@
-From 51756824d0aad6965aeec06581b0181e28a6b402 Mon Sep 17 00:00:00 2001
+From d83c11c9c197195164af9a3ac202740c0c8673cb Mon Sep 17 00:00:00 2001
From: Samuli Piippo <samuli.piippo@qt.io>
Date: Fri, 24 Nov 2017 15:16:31 +0200
Subject: [PATCH] Bootstrap without linkat feature
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index a13eb25a..c3c68b1e 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -14,7 +14,7 @@ LIC_FILES_CHKSUM = " \
# common for qtbase-native, qtbase-nativesdk and qtbase
# Patches from https://github.com/meta-qt5/qtbase/commits/b5.12-shared
-# 5.12.meta-qt5-shared.12
+# 5.12.meta-qt5-shared.13
SRC_URI += "\
file://0001-Add-linux-oe-g-platform.patch \
file://0002-cmake-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS.patch \
@@ -34,10 +34,10 @@ SRC_URI += "\
file://0016-Define-QMAKE_CXX.COMPILER_MACROS-for-clang-on-linux.patch \
file://0017-Fix-Wdeprecated-copy-warnings.patch \
file://0018-qfloat16-Include-limits-header.patch \
+ file://0019-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch \
+ file://0020-evdevkeyboard-fix-input_event-time-related-compile.patch \
"
-SRC_URI += "file://0023-zlib-Do-not-undefine-_FILE_OFFSET_BITS.patch"
-
# for syncqt
RDEPENDS:${PN}-tools += "perl"