aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-07-12 11:58:19 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2019-10-30 14:32:53 +0000
commit171871280307126c94faeeb90fb635a26495459d (patch)
tree4c0ef010c14998393253039071f8abdc3c6fe27e
parent4075be1b7e513fbfd36f0f8260a5fe2837e0987a (diff)
qtconnectivity,qtsystems: Account for bluez4 from oe-core
bluez4 has been deprecated for few years now it has been removed completely from oe-core Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtconnectivity_git.bb4
-rw-r--r--recipes-qt/qt5/qtsystems_git.bb4
2 files changed, 2 insertions, 6 deletions
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb
index 1973e26c..7eb0d5b0 100644
--- a/recipes-qt/qt5/qtconnectivity_git.bb
+++ b/recipes-qt/qt5/qtconnectivity_git.bb
@@ -14,10 +14,8 @@ SRC_URI += "file://0001-Add-missing-header-for-errno.patch"
DEPENDS += "qtbase qtdeclarative"
-inherit bluetooth
-
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}"
-PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}"
+PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,bluez5"
EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
diff --git a/recipes-qt/qt5/qtsystems_git.bb b/recipes-qt/qt5/qtsystems_git.bb
index 05741de7..5f5e1ad8 100644
--- a/recipes-qt/qt5/qtsystems_git.bb
+++ b/recipes-qt/qt5/qtsystems_git.bb
@@ -12,10 +12,8 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtbase qtdeclarative udev gconf"
-inherit bluetooth
-
PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}"
-PACKAGECONFIG[bluez] = "CONFIG+=OE_BLUEZ_ENABLED,,${BLUEZ}"
+PACKAGECONFIG[bluez] = "CONFIG+=OE_BLUEZ_ENABLED,,bluez5"
EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"