aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-10-03 20:09:43 +0200
committerMartin Jansa <martin.jansa@lge.com>2021-10-03 15:43:25 -0700
commit17c016212530710b04a82b3202cfcb19c613f677 (patch)
treed12e5122b5d601dc512c97a857b4d44bad46353e
parent2bd32a5ed33b88700e17a90192280695ae2ed32c (diff)
qtwebkit: Fix build with icu-65.1
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebkit/0001-Fix-build-with-icu-65.1-https-bugs.webkit.org-show_b.patch53
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb1
2 files changed, 54 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0001-Fix-build-with-icu-65.1-https-bugs.webkit.org-show_b.patch b/recipes-qt/qt5/qtwebkit/0001-Fix-build-with-icu-65.1-https-bugs.webkit.org-show_b.patch
new file mode 100644
index 00000000..e987eef0
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit/0001-Fix-build-with-icu-65.1-https-bugs.webkit.org-show_b.patch
@@ -0,0 +1,53 @@
+From 94e71ee824df7b3dc126ff96007daaca56829924 Mon Sep 17 00:00:00 2001
+From: "commit-queue@webkit.org" <commit-queue@webkit.org>
+Date: Fri, 4 Oct 2019 21:51:37 +0000
+Subject: [PATCH] Fix build with icu 65.1
+ https://bugs.webkit.org/show_bug.cgi?id=202600
+
+Patch by Heiko Becker <heirecka@exherbo.org> on 2019-10-04
+Reviewed by Konstantin Tokarev.
+
+Source/WebCore:
+
+* dom/Document.cpp:
+(WebCore::isValidNameNonASCII):
+(WebCore::Document::parseQualifiedName):
+
+Source/WTF:
+
+* wtf/URLHelpers.cpp:
+(WTF::URLHelpers::allCharactersInIDNScriptWhiteList):
+
+git-svn-id: http://svn.webkit.org/repository/webkit/trunk@250747 268f45cc-cd09-0410-ab3c-d52691b4dbfc
+---
+ Source/WebCore/dom/Document.cpp | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/Source/WebCore/dom/Document.cpp b/Source/WebCore/dom/Document.cpp
+index 2598b0f1e..28a935b55 100644
+--- a/Source/WebCore/dom/Document.cpp
++++ b/Source/WebCore/dom/Document.cpp
+@@ -4407,12 +4407,12 @@ static bool isValidNameNonASCII(const UChar* characters, unsigned length)
+ unsigned i = 0;
+
+ UChar32 c;
+- U16_NEXT(characters, i, length, c)
++ U16_NEXT(characters, i, length, c);
+ if (!isValidNameStart(c))
+ return false;
+
+ while (i < length) {
+- U16_NEXT(characters, i, length, c)
++ U16_NEXT(characters, i, length, c);
+ if (!isValidNamePart(c))
+ return false;
+ }
+@@ -4474,7 +4474,7 @@ bool Document::parseQualifiedName(const String& qualifiedName, String& prefix, S
+
+ for (unsigned i = 0; i < length;) {
+ UChar32 c;
+- U16_NEXT(qualifiedName, i, length, c)
++ U16_NEXT(qualifiedName, i, length, c);
+ if (c == ':') {
+ if (sawColon) {
+ ec = NAMESPACE_ERR;
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 00ed73d4..6f324e0f 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -19,6 +19,7 @@ SRC_URI += "\
file://0004-Fix-build-bug-for-armv32-BE.patch \
file://0001-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \
file://0008-Fix-build-with-icu-68.patch \
+ file://0001-Fix-build-with-icu-65.1-https-bugs.webkit.org-show_b.patch \
"
inherit cmake_qt5 perlnative pythonnative