aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-09-21 16:27:57 +0200
committerMartin Jansa <martin.jansa@lge.com>2021-10-02 10:48:58 -0700
commit78b9b1e4d9c31ed66c6b48988623d0cf15b78fa2 (patch)
tree4d9b21deebd4617595a11a1c2675f7d61119244e
parent087dea07b6f9d0bd75748a53c8a429739b04e7a1 (diff)
qtbase: inherit pkgconfig
* some features enabled with PACKAGECONFIG need pkgconfig to be detected correctly * fixes: Checking for pkg-config... test config.qtbase.tests.pkg-config FAILED ... Trying source 0 (type pkgConfig) of library dbus ... pkg-config use disabled globally. ... ERROR: Feature 'pkg-config' was enabled, but the pre-condition 'tests.pkg-config' failed. ERROR: Feature 'glib' was enabled, but the pre-condition 'libs.glib' failed. ERROR: Feature 'kms' was enabled, but the pre-condition 'libs.drm' failed. ERROR: Feature 'gbm' was enabled, but the pre-condition 'libs.gbm' failed. ERROR: Feature 'mtdev' was enabled, but the pre-condition 'libs.mtdev' failed. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 4c4cdbd7..1be0f6c0 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -39,6 +39,8 @@ SRC_URI += "\
# for syncqt
RDEPENDS_${PN}-tools += "perl"
+inherit pkgconfig
+
# separate some parts of PACKAGECONFIG which are often changed
PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', 'no-opengl', d)}"
PACKAGECONFIG_FB ?= "${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)}"