aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-05 11:04:25 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2019-12-09 12:11:33 +0100
commit2a2055fab9af0f2d69177ef76485f312e6d1c36b (patch)
treef2e0c0851abb47174eb68264768f59b8ca5c9e0a
parent25039161c1646ce1b6cc30303d4588e43b9b714a (diff)
recipes: Disable clang dependent recipes for riscv64/32
Since clang is not buildable for RISC-V, as yet, these should be disabled as well. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rwxr-xr-xrecipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb5
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb3
-rw-r--r--recipes-qt/qt5/qttools_git.bb3
-rw-r--r--recipes-qt/qwt/qwt-qt5_6.1.4.bb3
4 files changed, 14 insertions, 0 deletions
diff --git a/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb b/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb
index b912d891..5753a3eb 100755
--- a/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb
+++ b/recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bb
@@ -108,8 +108,13 @@ RDEPENDS_${PN} += " \
qtquickcontrols2-dev \
qtquickcontrols2-mkspecs \
"
+RDEPENDS_${PN}_remove_toolchain-clang_riscv32 = "qttools-dev qttools-mkspecs qttools-staticdev qttools-tools"
+RDEPENDS_${PN}_remove_toolchain-clang_riscv64 = "qttools-dev qttools-mkspecs qttools-staticdev qttools-tools"
RRECOMMENDS_${PN} += " \
qtquickcontrols-qmlplugins \
qttools-plugins \
"
+
+RRECOMMENDS_${PN}_remove_toolchain-clang_riscv32 = "qttools-plugins"
+RRECOMMENDS_${PN}_remove_toolchain-clang_riscv64 = "qttools-plugins"
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index a2717ee6..e76aa6aa 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -35,6 +35,9 @@ EXTRA_QMAKEVARS_PRE += "IDE_LIBRARY_BASENAME=${baselib}${QT_DIR_NAME}"
EXTRANATIVEPATH += "chrpath-native"
+COMPATIBLE_HOST_toolchain-clang_riscv32 = "null"
+COMPATIBLE_HOST_toolchain-clang_riscv64 = "null"
+
do_configure_append() {
# Find native tools
sed -i 's:${STAGING_BINDIR}.*/qdoc:${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/qdoc:g' ${B}/Makefile
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb
index fd6de101..1f1d7090 100644
--- a/recipes-qt/qt5/qttools_git.bb
+++ b/recipes-qt/qt5/qttools_git.bb
@@ -30,6 +30,9 @@ PACKAGECONFIG_append_toolchain-clang = " clang"
PACKAGECONFIG[qtwebkit] = ",,qtwebkit"
PACKAGECONFIG[clang] = ",,clang"
+COMPATIBLE_HOST_toolchain-clang_riscv32 = "null"
+COMPATIBLE_HOST_toolchain-clang_riscv64 = "null"
+
export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_BINDIR}/llvm-config"
EXTRA_QMAKEVARS_PRE += " \
diff --git a/recipes-qt/qwt/qwt-qt5_6.1.4.bb b/recipes-qt/qwt/qwt-qt5_6.1.4.bb
index d8e1dcd2..623b45e5 100644
--- a/recipes-qt/qwt/qwt-qt5_6.1.4.bb
+++ b/recipes-qt/qwt/qwt-qt5_6.1.4.bb
@@ -8,6 +8,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=dac2743472b0462ff3cfb4af42051c88"
DEPENDS = "qtbase qtsvg qttools"
+COMPATIBLE_HOST_toolchain-clang_riscv32 = "null"
+COMPATIBLE_HOST_toolchain-clang_riscv64 = "null"
+
inherit qmake5
SRC_URI = " \