aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-01-13 16:04:42 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2020-01-13 16:04:42 +0100
commitbb05449c26bff0394a54ffb864abf1412db3c237 (patch)
tree5921e2d28e3f2845428b612e0a05d3780d33adad
parentede15adc71f7f1c2acd63e96777b5d02d052a681 (diff)
Revert "recipes: Use features_check instead of distro_features_check"
This reverts commit b7f4bd209c03c4f765cec84f4aa247819a6bb2f3. I've accidentally merged this to zeus which doesn't have the feautres_check.bbclass yet. Even for master branch it's problematic, because some people tend to use different branch of meta-qt5 with different OE releases, so if you need to use meta-qt5/master with zeus or older, you'll need to introduce features_check.bbclass (with just "inherit distro_features_check" in your own layer for the compatibility. In the oposite case when using meta-qt5/zeus (or older) with master/dunfell, you'll just get bunch of warnings about deprecated distro_features_check inherit which is safe to ignore.
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 7cd006f5..61a55bff 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -81,7 +81,7 @@ inherit qmake5
inherit gettext
inherit pythonnative
inherit perlnative
-inherit features_check
+inherit distro_features_check
# Static builds of QtWebEngine aren't supported.
CONFLICT_DISTRO_FEATURES = "qt5-static"