aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-09-12 13:37:43 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-21 11:56:52 +0200
commit09caddadc395f7758f86a4a1b93616a02757e59b (patch)
treef86b33e70b713aaa7b9315bfcc65916288b04ee4
parent9c036b3bacea43dbbc937100b6dd2b5fe3f2ee8a (diff)
qtbase: fix build for PACKAGECONFIG gles2
fixes: | In file included from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/X11/Xlib.h:44:0, | from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/EGL/eglvivante.h:244, | from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/EGL/eglplatform.h:38, | from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/EGL/egl.h:39, | from /home/superandy/tmp/oe-core-glibc/work/cortexa9t2hf-vfp-neon-mx6qdl-angstrom-linux-gnueabi/qtbase/5.5.0+gitAUTOINC+2fde9f59ee-r0/git/src/platformsupport/eglconvenience/qeglplatformscreen_p.h:52, | from /home/superandy/tmp/oe-core-glibc/work/cortexa9t2hf-vfp-neon-mx6qdl-angstrom-linux-gnueabi/qtbase/5.5.0+gitAUTOINC+2fde9f59ee-r0/git/src/platformsupport/eglconvenience/qeglplatformscreen.cpp:34: | ../../include/QtCore/../../../git/src/corelib/io/qurl.h:131:9: error: expected identifier before numeric constant | None = 0x0, | ^ Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase/0012-qeglplatformscreen.cpp-reorder-headers-to-fix-build-.patch49
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
2 files changed, 50 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase/0012-qeglplatformscreen.cpp-reorder-headers-to-fix-build-.patch b/recipes-qt/qt5/qtbase/0012-qeglplatformscreen.cpp-reorder-headers-to-fix-build-.patch
new file mode 100644
index 00000000..a1a8791e
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0012-qeglplatformscreen.cpp-reorder-headers-to-fix-build-.patch
@@ -0,0 +1,49 @@
+From f8873b5ba0fa42cc0d2aadfd6c5a449b37799609 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Sat, 12 Sep 2015 12:58:46 +0200
+Subject: [PATCH] qeglplatformscreen.cpp: reorder headers to fix build with egl
+ enabled
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+fixes:
+In file included from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/X11/Xlib.h:44:0,
+ from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/EGL/eglvivante.h:244,
+ from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/EGL/eglplatform.h:38,
+ from /home/superandy/tmp/oe-core-glibc/sysroots/varsomimx6q/usr/include/EGL/egl.h:39,
+ from /home/superandy/tmp/oe-core-glibc/work/cortexa9t2hf-vfp-neon-mx6qdl-angstrom-linux-gnueabi/qtbase/5.5.0+gitAUTOINC+2fde9f59ee-r0/git/src/platformsupport/eglconvenience/qeglplatformscreen_p.h:52,
+ from /home/superandy/tmp/oe-core-glibc/work/cortexa9t2hf-vfp-neon-mx6qdl-angstrom-linux-gnueabi/qtbase/5.5.0+gitAUTOINC+2fde9f59ee-r0/git/src/platformsupport/eglconvenience/qeglplatformscreen.cpp:34:
+../../include/QtCore/../../../git/src/corelib/io/qurl.h:131:9: error: expected identifier before numeric constant
+ None = 0x0,
+ ^
+
+This patch has a very limited lifetime: In branch dev and 5.6 the patched file is gone. Therefore:
+
+Upstream-Status: Pending
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ src/platformsupport/eglconvenience/qeglplatformscreen.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/platformsupport/eglconvenience/qeglplatformscreen.cpp b/src/platformsupport/eglconvenience/qeglplatformscreen.cpp
+index 61f8cdd..ceec797 100644
+--- a/src/platformsupport/eglconvenience/qeglplatformscreen.cpp
++++ b/src/platformsupport/eglconvenience/qeglplatformscreen.cpp
+@@ -31,10 +31,10 @@
+ **
+ ****************************************************************************/
+
+-#include "qeglplatformscreen_p.h"
+-#include "qeglplatformwindow_p.h"
+ #include <QtGui/qwindow.h>
+ #include <qpa/qwindowsysteminterface.h>
++#include "qeglplatformscreen_p.h"
++#include "qeglplatformwindow_p.h"
+ #include <QtPlatformSupport/private/qopenglcompositor_p.h>
+
+ QT_BEGIN_NAMESPACE
+--
+2.1.0
+
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 70e35c23..ecae53be 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -25,6 +25,7 @@ SRC_URI += "\
SRC_URI += "\
file://0009-qmake-don-t-build-it-in-configure-but-allow-to-build.patch \
file://0010-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch \
+ file://0012-qeglplatformscreen.cpp-reorder-headers-to-fix-build-.patch \
"
DEPENDS += "qtbase-native"