aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-09-04 19:17:38 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-08 16:13:58 +0200
commit3f5430de74199ec592206adc5ac628b3febc95fe (patch)
tree76a8d5bbe52b0dfcf2e9a32f3e4c7e97542bd77a
parentbfddb2291ed4f72995d1042a352c0ad1073a4b62 (diff)
qtwebengine: fix build with newer glibc-2.22
* netdb.h staged by glibc-2.22 recipe defines struct addrinfo inside __USE_XOPEN2K unlike other versions which are using __USE_POSIX * fixes: | ../../../src/3rdparty/chromium/third_party/boringssl/src/crypto/bio/socket_helper.c: In function 'bio_ip_and_port_to_socket_and_addr': | ../../../src/3rdparty/chromium/third_party/boringssl/src/crypto/bio/socket_helper.c:40:19: error: storage size of 'hint' isn't known | struct addrinfo hint, *result, *cur; | ^ | ../../../src/3rdparty/chromium/third_party/boringssl/src/crypto/bio/socket_helper.c:58:36: error: dereferencing pointer to incomplete type | for (cur = result; cur; cur = cur->ai_next) { | ^ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine/0002-chromium-third_party-boringssl-Demand-for-newer-POSI.patch37
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0002-chromium-third_party-boringssl-Demand-for-newer-POSI.patch b/recipes-qt/qt5/qtwebengine/0002-chromium-third_party-boringssl-Demand-for-newer-POSI.patch
new file mode 100644
index 00000000..4e09f6ea
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/0002-chromium-third_party-boringssl-Demand-for-newer-POSI.patch
@@ -0,0 +1,37 @@
+From 75e9a963561a73ef2a449d7915cd8b41285ac862 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 27 Jun 2015 13:29:52 -0700
+Subject: [PATCH] chromium/third_party/boringssl: Demand for newer POSIX macro
+
+Reason for change: Define _POSIX_C_SOURCE such that it demands correct
+posix interfaces, netdb.h declares interfaces such as
+getaddrinfo if __USE_POSIX, i.e. POSIX.1:1990 or later.
+However, these interfaces were new in the 2001 edition of POSIX
+therefore ask for Extension from POSIX.1:2001 since we use addrinfo
+structure here.
+
+Change-Id: Icb1c92745d1a0ca958108ae80c270c630628729e
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Reviewed-on: https://boringssl-review.googlesource.com/5253
+Reviewed-by: Adam Langley <agl@google.com>
+Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
+---
+ src/3rdparty/chromium/third_party/boringssl/src/crypto/bio/socket_helper.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/3rdparty/chromium/third_party/boringssl/src/crypto/bio/socket_helper.c b/src/3rdparty/chromium/third_party/boringssl/src/crypto/bio/socket_helper.c
+index ba65a1a..66c3976 100644
+--- a/src/3rdparty/chromium/third_party/boringssl/src/crypto/bio/socket_helper.c
++++ b/src/3rdparty/chromium/third_party/boringssl/src/crypto/bio/socket_helper.c
+@@ -12,7 +12,7 @@
+ * OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+ * CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE. */
+
+-#define _POSIX_SOURCE
++#define _POSIX_C_SOURCE 200112L
+
+ #include <openssl/bio.h>
+ #include <openssl/err.h>
+--
+2.5.0
+
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 6685e53a..09a49db1 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -81,6 +81,7 @@ SRC_URI += " \
file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \
file://0004-Generate-usable-qmake_extras.gypi.patch \
file://0001-chromium-base.gypi-include-atomicops_internals_x86_g.patch \
+ file://0002-chromium-third_party-boringssl-Demand-for-newer-POSI.patch \
"
SRCREV_qtwebengine = "c6573119006014ff7bc0efb2da16ea35d302a1ec"
SRCREV_chromium = "41a1a031cd69e187a9608359ffe56652dcaaa6c5"