aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam YH Lee <adam.yh.lee@gmail.com>2015-09-04 17:28:31 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2015-09-21 11:56:52 +0200
commit53a96286bb6a7516061c8b03d522841c1ca13b93 (patch)
tree406a790b998b3114e47220e1b657c11cd8031694
parent3a16204dc3bc171db079a217201c723499272f81 (diff)
Use `mkdir -p` when creating `/usr/bin`
When QT_DIR_NAME is altered, /usr/bin` is checked. This directory is more often than not already created. Hence `mkdir` with `-p` should be used. Currently it results in a build failure since the directory already exists. Signed-off-by: Adam YH Lee <adam.yh.lee@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 462c24a8..087ebf35 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -172,7 +172,7 @@ do_configure() {
# we need symlink in path relative to source, because
# EffectivePaths:Prefix is relative to qmake location
if [ ! -e ${B}/bin/qmake ]; then
- mkdir ${B}/bin
+ mkdir -p ${B}/bin
ln -sf ${OE_QMAKE_QMAKE_ORIG} ${B}/bin/qmake
fi