aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-11-26 09:06:38 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-12-15 16:46:00 +0100
commitd5536e34ec985c82b621448ab4325e5cbba38560 (patch)
tree1c164217b1e2082e31cd6dca59f7e20962a6c618
parent0454fb083c38f2155a8be3b61930ad1ddf995695 (diff)
qtbase: align target qmake paths/mkspec
With this we can setup qt-creator to build/debug on target again. Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase/0011-configure-paths-for-target-qmake-properly.patch76
-rw-r--r--recipes-qt/qt5/qtbase_git.bb1
2 files changed, 77 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase/0011-configure-paths-for-target-qmake-properly.patch b/recipes-qt/qt5/qtbase/0011-configure-paths-for-target-qmake-properly.patch
new file mode 100644
index 00000000..efd27a55
--- /dev/null
+++ b/recipes-qt/qt5/qtbase/0011-configure-paths-for-target-qmake-properly.patch
@@ -0,0 +1,76 @@
+From fb519b08f564a8a640b1b2f2b6a3bd54a83e19e8 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
+Date: Fri, 13 Nov 2015 12:36:11 +0100
+Subject: [PATCH] configure paths/mkspecs for target qmake properly
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+to use this patch in all qtbase/qtbase-native(sdk) changes ore made
+conditionally based on QT_CROSS_COMPILE
+
+Upstream-Status: Inappropriate [OE specific]
+
+Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
+---
+ configure | 23 +++++++++++++++++++----
+ 1 file changed, 19 insertions(+), 4 deletions(-)
+
+diff --git a/configure b/configure
+index 6edfffd..de74a29 100755
+--- a/configure
++++ b/configure
+@@ -3857,8 +3857,13 @@ if [ "$CFG_COMPILE_EXAMPLES" = "yes" ]; then
+ QMAKE_CONFIG="$QMAKE_CONFIG compile_examples"
+ fi
+
+-shortxspec=`echo $XQMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
+-shortspec=`echo $QMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
++if [ "$QT_CROSS_COMPILE" = "yes" ] ; then
++ shortxspec=linux-g++
++ shortspec=linux-g++
++else
++ shortxspec=`echo $XQMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
++ shortspec=`echo $QMAKESPEC | sed "s,^${relpath}/mkspecs/,,"`
++fi
+
+ QT_CONFIGURE_STR_OFF=0
+
+@@ -3891,7 +3896,11 @@ QT_CONFIGURE_STRS_ALL=$QT_CONFIGURE_STRS
+
+ QT_CONFIGURE_STR_OFFSETS=
+ QT_CONFIGURE_STRS=
+-addConfStr "$CFG_SYSROOT"
++if [ "$QT_CROSS_COMPILE" = "yes" ] ; then
++ addConfStr ""
++else
++ addConfStr "$CFG_SYSROOT"
++fi
+ addConfStr "$QT_REL_HOST_BINS"
+ addConfStr "$QT_REL_HOST_LIBS"
+ addConfStr "$QT_REL_HOST_DATA"
+@@ -3903,6 +3912,12 @@ addConfStr "$shortspec"
+ #-------------------------------------------------------------------------------
+ [ -d "$outpath/src/corelib/global" ] || mkdir -p "$outpath/src/corelib/global"
+
++if [ "$QT_CROSS_COMPILE" = "yes" ] ; then
++ QT_TARGET_PREFIX=$QT_EXT_PREFIX
++else
++ QT_TARGET_PREFIX=$QT_HOST_PREFIX
++fi
++
+ cat > "$outpath/src/corelib/global/qconfig.cpp.new" <<EOF
+ /* License Info */
+ static const char qt_configure_licensee_str [256 + 12] = "qt_lcnsuser=$Licensee";
+@@ -3915,7 +3930,7 @@ static const char qt_configure_installation [12+11] = "qt_instdate=2
+ static const char qt_configure_prefix_path_str [512 + 12] = "qt_prfxpath=$QT_INSTALL_PREFIX";
+ #ifdef QT_BUILD_QMAKE
+ static const char qt_configure_ext_prefix_path_str [512 + 12] = "qt_epfxpath=$QT_EXT_PREFIX";
+-static const char qt_configure_host_prefix_path_str [512 + 12] = "qt_hpfxpath=$QT_HOST_PREFIX";
++static const char qt_configure_host_prefix_path_str [512 + 12] = "qt_hpfxpath=$QT_TARGET_PREFIX";
+ #endif
+
+ static const short qt_configure_str_offsets[] = {
+--
+2.1.0
+
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 0ba8ac89..3ef59231 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -26,6 +26,7 @@ SRC_URI += "\
file://0008-qmake-don-t-build-it-in-configure-but-allow-to-build.patch \
file://0009-linux-oe-g-Invert-conditional-for-defining-QT_SOCKLE.patch \
file://0010-qeglplatformscreen.cpp-reorder-headers-to-fix-build-.patch \
+ file://0011-configure-paths-for-target-qmake-properly.patch \
"
DEPENDS += "qtbase-native"