aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denys@ti.com>2016-03-31 20:47:22 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-20 10:51:51 +0200
commit3af44d648aec077ba313079645be1465c0a8869b (patch)
treea047dcb2b9ae1e726a51e88840c66054a9149767
parent4ec27e218d725677279d265ac1fc256443d665f7 (diff)
qtdeclarative: fix compilation of examples/qquickviewcomparison
git/examples/quick/quickwidgets/qquickviewcomparison/mainwindow.cpp:180:14: error: 'QCoreApplication' has not been declared if (!QCoreApplication::arguments().contains(QStringLiteral("--no_render_alpha"))) Signed-off-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtdeclarative/0001-qquickviewcomparison-fix-QCoreApplication-has-not-be.patch28
-rw-r--r--recipes-qt/qt5/qtdeclarative_git.bb1
2 files changed, 29 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtdeclarative/0001-qquickviewcomparison-fix-QCoreApplication-has-not-be.patch b/recipes-qt/qt5/qtdeclarative/0001-qquickviewcomparison-fix-QCoreApplication-has-not-be.patch
new file mode 100644
index 00000000..1687fbe5
--- /dev/null
+++ b/recipes-qt/qt5/qtdeclarative/0001-qquickviewcomparison-fix-QCoreApplication-has-not-be.patch
@@ -0,0 +1,28 @@
+From 1cdd3278a0b1508640d983720782d39eb919caaf Mon Sep 17 00:00:00 2001
+From: Denys Dmytriyenko <denys@ti.com>
+Date: Thu, 31 Mar 2016 19:38:58 -0400
+Subject: [PATCH] qquickviewcomparison: fix QCoreApplication has not been
+ declared error
+
+Upstream-Status: Pending
+
+Signed-off-by: Denys Dmytriyenko <denys@ti.com>
+---
+ examples/quick/quickwidgets/qquickviewcomparison/mainwindow.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/examples/quick/quickwidgets/qquickviewcomparison/mainwindow.h b/examples/quick/quickwidgets/qquickviewcomparison/mainwindow.h
+index 5b86c93..e77514e 100644
+--- a/examples/quick/quickwidgets/qquickviewcomparison/mainwindow.h
++++ b/examples/quick/quickwidgets/qquickviewcomparison/mainwindow.h
+@@ -44,6 +44,7 @@
+ #include <QWidget>
+ #include <QQuickWidget>
+ #include <QQuickView>
++#include <QCoreApplication>
+
+ QT_FORWARD_DECLARE_CLASS(QRadioButton)
+ QT_FORWARD_DECLARE_CLASS(QCheckBox)
+--
+2.2.0
+
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb
index 93442fb4..9274d00d 100644
--- a/recipes-qt/qt5/qtdeclarative_git.bb
+++ b/recipes-qt/qt5/qtdeclarative_git.bb
@@ -15,6 +15,7 @@ DEPENDS += "qtbase"
SRC_URI += " \
file://0001-qmltestexample-fix-link.patch \
+ file://0001-qquickviewcomparison-fix-QCoreApplication-has-not-be.patch \
"
EXTRA_OEMAKE += "QMAKE_SYNCQT=${STAGING_BINDIR_NATIVE}${QT_DIR_NAME}/syncqt"