aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-10-31 13:07:23 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2020-11-03 17:01:57 +0100
commit1d946dc8f467a37494d3d96a1fa8153199288aff (patch)
tree387461353cbc8a8b96994437d70c6e0b92846890
parentf60771c37c2940734a04674bcf91dcb64711fc12 (diff)
qtwebkit: Fix build when Qt is configured without SSL
backport a patch to fix the build error Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebkit/0007-Disable-code-related-to-HTTP-2-when-Qt-is-configured.patch34
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0007-Disable-code-related-to-HTTP-2-when-Qt-is-configured.patch b/recipes-qt/qt5/qtwebkit/0007-Disable-code-related-to-HTTP-2-when-Qt-is-configured.patch
new file mode 100644
index 00000000..15607c0d
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit/0007-Disable-code-related-to-HTTP-2-when-Qt-is-configured.patch
@@ -0,0 +1,34 @@
+From 32eb0352d98fcf325b0a94a4f7e141d746938a4b Mon Sep 17 00:00:00 2001
+From: Konstantin Tokarev <annulen@yandex.ru>
+Date: Sun, 3 May 2020 18:50:24 +0300
+Subject: [PATCH] Disable code related to HTTP/2 when Qt is configured without SSL support
+
+For enabling HTTP/2 by default we check if Qt uses OpenSSL and its version
+is 1.0.2 or higher via QSslSocket API. While it would be sufficient to
+add guards just there, we are not going to enable HTTP/2 for QT_NO_SSL
+case by default anyway (note that it still can be done in application code).
+
+Change-Id: I77b4a423ff1028725ac2c0953c757dce2db23e05
+---
+Upstream-Status: Backport [https://github.com/qtwebkit/qtwebkit/commit/e7ec14144ce58418d94568c41ac94d4d87969363]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+ Source/WebCore/platform/network/qt/ResourceRequest.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/Source/WebCore/platform/network/qt/ResourceRequest.h b/Source/WebCore/platform/network/qt/ResourceRequest.h
+index 1154d56a0..87e21ec3f 100644
+--- a/Source/WebCore/platform/network/qt/ResourceRequest.h
++++ b/Source/WebCore/platform/network/qt/ResourceRequest.h
+@@ -32,7 +32,7 @@
+ // HTTP/2 is implemented since Qt 5.8, but various QtNetwork bugs make it unusable in browser with Qt < 5.10.1
+ // We also don't enable HTTP/2 for unencrypted connections because of possible compatibility issues; it can be
+ // enabled manually by user application via custom QNAM subclass
+-#if QT_VERSION >= QT_VERSION_CHECK(5, 10, 1)
++#if QT_VERSION >= QT_VERSION_CHECK(5, 10, 1) && !defined(QT_NO_SSL)
+ #define USE_HTTP2 1
+ #endif
+
+--
+2.29.2
+
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index acd97e09..ce7d1b85 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -17,6 +17,7 @@ SRC_URI += "\
file://0004-Fix-build-bug-for-armv32-BE.patch \
file://0005-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \
file://0006-Fix-build-with-bison37.patch \
+ file://0007-Disable-code-related-to-HTTP-2-when-Qt-is-configured.patch \
"
inherit cmake_qt5 perlnative