aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-11-11 09:19:16 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2020-11-11 19:14:14 +0100
commit7a9f639fbd632dbe23af95c7b8123a0b907c6179 (patch)
treed481b94310de59a89fc940ee93080c8c2b5457dc
parentdf46d9212fff57959a7f2a566c04d2892d1369b6 (diff)
qt5-creator: Skip it when meta-python2 is not in layermix
it depends on qtwebengine which inturn depends on chromium which inturn depends on python2 during build. So lets disable it when meta-python2 is not used until such time when chromium does not need python2 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qt5-creator_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qt5-creator_git.bb b/recipes-qt/qt5/qt5-creator_git.bb
index 4338bf20..f8d4aa1d 100644
--- a/recipes-qt/qt5/qt5-creator_git.bb
+++ b/recipes-qt/qt5/qt5-creator_git.bb
@@ -97,3 +97,8 @@ INSANE_SKIP_${PN} += "ldflags"
inherit features_check
REQUIRED_DISTRO_FEATURES ?= "x11 opengl"
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}