aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-10-26 11:03:25 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2021-11-13 11:03:16 +0100
commit287f7d1efe78a957befd4aeabd25bf829902012a (patch)
treecf0d60d4620bf8c702b6fc5514bc676273fd3396
parent6e808aeeced9dc60c5718a7f945b062f19fe8a83 (diff)
qtwebkit: Fix build on mips/clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebkit/mips-atomic.patch21
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb1
2 files changed, 22 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit/mips-atomic.patch b/recipes-qt/qt5/qtwebkit/mips-atomic.patch
new file mode 100644
index 00000000..d29d85ff
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit/mips-atomic.patch
@@ -0,0 +1,21 @@
+fix build on mips
+
+Fixes
+Source/WTF/wtf/Atomics.cpp:63:9: error: definition of builtin function '__sync_add_and_fetch_8'
+int64_t __sync_add_and_fetch_8(int64_t volatile* addend, int64_t value)
+Source/WTF/wtf/Atomics.cpp:68:9: error: definition of builtin function '__sync_sub_and_fetch_8'
+int64_t __sync_sub_and_fetch_8(int64_t volatile* addend, int64_t value)
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/Source/WTF/wtf/Platform.h
++++ b/Source/WTF/wtf/Platform.h
+@@ -88,6 +88,7 @@
+ #else
+ #define WTF_CPU_MIPS 1
+ #define WTF_MIPS_ARCH __mips
++#define __GCC_HAVE_SYNC_COMPARE_AND_SWAP_8 1
+ #endif
+ #if defined(__MIPSEB__)
+ #define WTF_CPU_BIG_ENDIAN 1
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 40ccb6fd..f76b7043 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -23,6 +23,7 @@ SRC_URI += "\
file://0007-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch \
file://0008-Fix-build-with-icu-68.patch \
file://0009-Riscv-Add-support-for-riscv.patch \
+ file://mips-atomic.patch \
"
SRC_URI:append:riscv32 = " file://0010-webdriver-libatomic.patch "