aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Gomez <daniel@qtec.com>2021-10-09 10:11:49 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2021-11-13 11:03:16 +0100
commit52982b287d75e31bb3ec13baebe2913913b165fb (patch)
tree491644e5babbc0c362671b50b5de748a69846f92
parentccebd640ee872b5cf19abdba44fbffe428282403 (diff)
libqofono: Fix new repo and update 0.100 -> 0.103
libqofono repository has been moved to the Sailfish OS GitHub group as part of the migration of Mer and Sailfish to Sailfish OS domain. More details here: https://forum.sailfishos.org/t/changes-needed-to-merge-the-project-names-to-sailfish-os/1672 Update recipe to 0.103 release. Update 0001-also-emit-modemRemoved-and-modemAdded.patch with devtool to fix patch-fuzz QA Issue: WARNING: libqofono-0.100+gitrAUTOINC+047b667f18-r0 do_patch: QA Issue: Patch log indicates that patches do not apply cleanly. [patch-fuzz] Signed-off-by: Daniel Gomez <daniel@qtec.com>
-rw-r--r--recipes-connectivity/libqofono/libqofono/0001-also-emit-modemRemoved-and-modemAdded.patch12
-rw-r--r--recipes-connectivity/libqofono/libqofono_git.bb7
2 files changed, 9 insertions, 10 deletions
diff --git a/recipes-connectivity/libqofono/libqofono/0001-also-emit-modemRemoved-and-modemAdded.patch b/recipes-connectivity/libqofono/libqofono/0001-also-emit-modemRemoved-and-modemAdded.patch
index 0122e051..f33a3912 100644
--- a/recipes-connectivity/libqofono/libqofono/0001-also-emit-modemRemoved-and-modemAdded.patch
+++ b/recipes-connectivity/libqofono/libqofono/0001-also-emit-modemRemoved-and-modemAdded.patch
@@ -1,4 +1,4 @@
-From 05241dc61e8c43a12f91ee9976a2ecb2337a3eaf Mon Sep 17 00:00:00 2001
+From d2ceb83fe889d7cb40ad1e0d71e75d726a87fb28 Mon Sep 17 00:00:00 2001
From: Christophe Chapuis <chris.chapuis@gmail.com>
Date: Sat, 13 Jul 2019 11:17:08 +0000
Subject: [PATCH] onGetModemsFinished: also emit modemRemoved and modemAdded
@@ -7,17 +7,18 @@ VoiceCall only subscribes to these events, so we need to emit these
more "atomic" events too.
Signed-off-by: Christophe Chapuis <chris.chapuis@gmail.com>
+
---
src/qofonomanager.cpp | 21 ++++++++++++++++++---
1 file changed, 18 insertions(+), 3 deletions(-)
diff --git a/src/qofonomanager.cpp b/src/qofonomanager.cpp
-index deeb946..e94a3c7 100644
+index e1da658..38cf0e4 100644
--- a/src/qofonomanager.cpp
+++ b/src/qofonomanager.cpp
-@@ -40,15 +40,30 @@ void QOfonoManager::Private::handleGetModemsReply(QOfonoManager* obj, ObjectPath
+@@ -88,15 +88,30 @@ void QOfonoManager::Private::handleGetModemsReply(QOfonoManager *obj, ObjectPath
{
- bool wasAvailable = available;
+ const bool wasAvailable = available;
QString prevDefault = defaultModem();
- QStringList newModems;
+ QStringList newModems, oldModems;
@@ -49,6 +50,3 @@ index deeb946..e94a3c7 100644
Q_EMIT obj->modemsChanged(modems);
}
QString newDefault = defaultModem();
---
-2.23.0
-
diff --git a/recipes-connectivity/libqofono/libqofono_git.bb b/recipes-connectivity/libqofono/libqofono_git.bb
index d3881951..623e4bf0 100644
--- a/recipes-connectivity/libqofono/libqofono_git.bb
+++ b/recipes-connectivity/libqofono/libqofono_git.bb
@@ -5,13 +5,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
DEPENDS += "qtbase qtdeclarative qtxmlpatterns"
-SRCREV = "4eec0c726844b8293eeab7312c96956a77d40e90"
-SRC_URI = "git://git.merproject.org/mer-core/libqofono.git;branch=master \
+SRCREV = "047b667f18ca73cb7f884f174d1d164a616d6814"
+
+SRC_URI = "git://github.com/sailfishos/libqofono.git;protocol=https;branch=master \
file://0001-also-emit-modemRemoved-and-modemAdded.patch \
"
S = "${WORKDIR}/git"
-PV = "0.100+gitr${SRCPV}"
+PV = "0.103+gitr${SRCPV}"
inherit qmake5