aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Minor <james.minor@ni.com>2024-04-05 12:13:24 -0500
committerMartin Jansa <martin.jansa@gmail.com>2024-04-18 10:12:49 +0200
commit89450b4b7cacccb5811446ec5c2ef6f2333e7027 (patch)
tree24ee46bb1e6368bb7d7c1c6bde6e6581e13235ea
parentfe008b6174862a05de14aa350efec271631697e7 (diff)
qtbase: Remove additional path of the build host from qmake.conf
Commit b61ea2c1a2c338487aee3c5e47d7394c0a5cbc27 stripped host paths for the CFLAGS and CXXFLAGS entries in qmake.conf, but QMAKE_LFLAGS entry in the target's qmake.conf still contains a host path. Fix that by using the same mechanism as the previous commit. Signed-off-by: James Minor <james.minor@ni.com> Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase_git.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index dc71fa95..9ba71afe 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -282,7 +282,8 @@ do_install:append() {
echo "isEmpty(QMAKE_LINK_SHLIB): QMAKE_LINK_SHLIB = $OE_QMAKE_LINK_NO_SYSROOT" >> $conf
echo "isEmpty(QMAKE_LINK_C): QMAKE_LINK_C = $OE_QMAKE_LINK_NO_SYSROOT" >> $conf
echo "isEmpty(QMAKE_LINK_C_SHLIB): QMAKE_LINK_C_SHLIB = $OE_QMAKE_LINK_NO_SYSROOT" >> $conf
- echo "isEmpty(QMAKE_LFLAGS): QMAKE_LFLAGS = ${OE_QMAKE_LDFLAGS}" >> $conf
+ # OE_QMAKE_LFLAGS contains path of the build host, which is not useful for the target.
+ echo "isEmpty(QMAKE_LFLAGS): QMAKE_LFLAGS = ${OE_QMAKE_LDFLAGS}" | sed -e 's/-fdebug-prefix-map=[^ ]*//g' | sed -e 's/-fmacro-prefix-map=[^ ]*//g' >> $conf
echo "isEmpty(QMAKE_OBJCOPY): QMAKE_OBJCOPY = ${TARGET_PREFIX}objcopy" >> $conf
echo "isEmpty(QMAKE_STRIP): QMAKE_STRIP = ${TARGET_PREFIX}strip" >> $conf
echo "isEmpty(CC_host): CC_host = ${CC_host}" >> $conf