aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBernhard Hartleb <bernhard.hartleb@gmail.com>2023-04-13 02:42:55 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2023-04-13 07:24:16 +0200
commit962f45e2661295bab10e17aacf7914ffe8ac59ae (patch)
tree30c9673060ba55a47666c10d1b486b919f1de36e
parente55593fb379f92900da5aaf416805f938cc51efd (diff)
qt3d: Add new Assimp submodule
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qt3d_git.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb
index c858ea7e..89d5ab0d 100644
--- a/recipes-qt/qt5/qt3d_git.bb
+++ b/recipes-qt/qt5/qt3d_git.bb
@@ -16,6 +16,12 @@ DEPENDS:class-target += "qtdeclarative qt3d-native"
SRC_URI += " \
file://0001-Allow-a-tools-only-build.patch \
"
+
+# For assimp submodule
+SRC_URI += " \
+ git://github.com/assimp/assimp.git;name=assimp;branch=assimp_5.0_release;protocol=https;destsuffix=git/src/3rdparty/assimp/src \
+"
+
SRC_URI:append:riscv64 = " file://0001-renderers-opengl-Link-in-libatomic-on-riscv.patch"
SRC_URI:append:riscv32 = " file://0001-renderers-opengl-Link-in-libatomic-on-riscv.patch"
@@ -39,5 +45,8 @@ do_configure:prepend() {
}
SRCREV = "e94b0fa39a2f4bf260969fb18bf075dba39b2df1"
+SRCREV_assimp = "8f0c6b04b2257a520aaab38421b2e090204b69df"
+
+SRCREV_FORMAT = "qt3d_assimp"
BBCLASSEXTEND += "native nativesdk"