aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-01-03 14:12:38 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2023-01-07 15:59:08 +0100
commitb119822b56f88fd50b97ce128cde217a74f85971 (patch)
treeddd96038a4977610faee886f9d33fb1fc2717b31
parentf1ac12036ef750330dffa4a13cf882b7c702288c (diff)
qtpdf,qtwebengine: Fix build with 64bit time_t
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtpdf_git.bb1
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0013-Remove-unsetting-_FILE_OFFSET_BITS.patch37
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
3 files changed, 39 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtpdf_git.bb b/recipes-qt/qt5/qtpdf_git.bb
index 418f4498..5307b340 100644
--- a/recipes-qt/qt5/qtpdf_git.bb
+++ b/recipes-qt/qt5/qtpdf_git.bb
@@ -166,6 +166,7 @@ SRC_URI += " \
file://chromium/0010-chromium-icu-use-system-library-only-targets.patch;patchdir=src/3rdparty \
file://chromium/0011-chromium-Remove-TRUE-to-prep-landing-of-icu68.patch;patchdir=src/3rdparty \
file://chromium/0012-chromium-skia-Fix-build-with-gcc-12.patch;patchdir=src/3rdparty \
+ file://chromium/0013-Remove-unsetting-_FILE_OFFSET_BITS.patch;patchdir=src/3rdparty \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0013-Remove-unsetting-_FILE_OFFSET_BITS.patch b/recipes-qt/qt5/qtwebengine/chromium/0013-Remove-unsetting-_FILE_OFFSET_BITS.patch
new file mode 100644
index 00000000..4484d4ee
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0013-Remove-unsetting-_FILE_OFFSET_BITS.patch
@@ -0,0 +1,37 @@
+From a6ed61f9435d25abdb71c2a2b84b204f180eb822 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 3 Jan 2023 14:10:23 -0800
+Subject: [PATCH] Remove unsetting _FILE_OFFSET_BITS
+
+This does not work when enabling 64bit time_t with glibc which is enabled with -D_TIME_BITS=64, since it also needs
+_FILE_OFFSET_BITS=64 and this does not work when its undefined explicitly
+
+Upstream-Status: Submitted [https://github.com/madler/zlib/pull/764]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ chromium/third_party/zlib/gzguts.h | 9 ---------
+ 1 file changed, 9 deletions(-)
+
+diff --git a/chromium/third_party/zlib/gzguts.h b/chromium/third_party/zlib/gzguts.h
+index 990a4d25149..a03d5005070 100644
+--- a/chromium/third_party/zlib/gzguts.h
++++ b/chromium/third_party/zlib/gzguts.h
+@@ -3,15 +3,6 @@
+ * For conditions of distribution and use, see copyright notice in zlib.h
+ */
+
+-#ifdef _LARGEFILE64_SOURCE
+-# ifndef _LARGEFILE_SOURCE
+-# define _LARGEFILE_SOURCE 1
+-# endif
+-# ifdef _FILE_OFFSET_BITS
+-# undef _FILE_OFFSET_BITS
+-# endif
+-#endif
+-
+ #ifdef HAVE_HIDDEN
+ # define ZLIB_INTERNAL __attribute__((visibility ("hidden")))
+ #else
+--
+2.39.0
+
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 9e3712b9..7f368d99 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -181,6 +181,7 @@ SRC_URI += " \
file://chromium/0010-chromium-icu-use-system-library-only-targets.patch;patchdir=src/3rdparty \
file://chromium/0011-chromium-Remove-TRUE-to-prep-landing-of-icu68.patch;patchdir=src/3rdparty \
file://chromium/0012-chromium-skia-Fix-build-with-gcc-12.patch;patchdir=src/3rdparty \
+ file://chromium/0013-Remove-unsetting-_FILE_OFFSET_BITS.patch;patchdir=src/3rdparty \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based