aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2021-04-08 18:43:40 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2021-04-10 01:39:16 +0200
commitecdb62b1e5a83b892d1385179e71093ce22407ba (patch)
treef6190b85b4117de8da4deaae6bed5997b972ce1b
parent3e9c7363a1f5b7c8a3003cb78fc73b120d56c421 (diff)
qtwebengine: Fix build with GCC 11
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0015-chromium-gcc11-fixes.patch23
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb1
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-gcc11-fixes.patch b/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-gcc11-fixes.patch
new file mode 100644
index 00000000..699a809a
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-gcc11-fixes.patch
@@ -0,0 +1,23 @@
+Include <limits> header
+
+gcc11 complains
+
+../../../../git/src/3rdparty/chromium/third_party/perfetto/src/trace_processor/containers/string_pool.h:256:34: error: no member named 'numeric_limits' in namespace 'std'
+ PERFETTO_DCHECK(value < std::numeric_limits<uint32_t>::max());
+
+This is because its missing right header which perhaps is included
+implicitly in older compilers
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+
+--- a/chromium/third_party/perfetto/src/trace_processor/containers/string_pool.h
++++ b/chromium/third_party/perfetto/src/trace_processor/containers/string_pool.h
+@@ -20,6 +20,7 @@
+ #include <stddef.h>
+ #include <stdint.h>
+
++#include <limits>
+ #include <unordered_map>
+ #include <vector>
+
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index a98bf787..357a519a 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -177,6 +177,7 @@ SRC_URI += " \
file://chromium/0012-chromium-Link-v8-with-libatomic-on-x86.patch;patchdir=src/3rdparty \
file://chromium/0013-chromium-icu-use-system-library-only-targets.patch;patchdir=src/3rdparty \
file://chromium/0014-chromium-Fix-sandbox-Aw-snap-for-syscalls-403-and-40.patch;patchdir=src/3rdparty \
+ file://chromium/0015-chromium-gcc11-fixes.patch;patchdir=src/3rdparty \
"
# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/83-based