aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGordan Markuš <gordan.markus@pelagicore.com>2017-03-30 17:09:03 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-10 13:44:53 +0200
commit1258138ec55334a372d3c634fef5a13b769e4ffe (patch)
tree70536d4ed6618345236aecede47f52639c5591d7
parent793f22fb02eaaeac4c582ac8f322c3aabf17f3bd (diff)
qtbase-native: create empty oe-device-extra.pri
Suppress multiple occurrences of the same warning while configuring and compiling qtbase-native and nativesdk-qtbase. WARNING: Unable to find file git/mkspecs/linux-oe-g++/../oe-device-extra.pri Signed-off-by: Gordan Markuš <gordan.markus@pelagicore.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase-native_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb
index c013029d..da698129 100644
--- a/recipes-qt/qt5/qtbase-native_git.bb
+++ b/recipes-qt/qt5/qtbase-native_git.bb
@@ -83,6 +83,9 @@ PACKAGECONFIG_CONFARGS = " \
export OE_QMAKE_QTCONF_PATH = "foodummy"
do_configure_prepend() {
+ # Avoid qmake error "Cannot read [...]/usr/lib/qt5/mkspecs/oe-device-extra.pri: No such file or directory"
+ touch ${S}/mkspecs/oe-device-extra.pri
+
MAKEFLAGS="${PARALLEL_MAKE}" ${S}/configure -opensource -confirm-license ${PACKAGECONFIG_CONFARGS} || die "Configuring qt failed. PACKAGECONFIG_CONFARGS was ${PACKAGECONFIG_CONFARGS}"
}