aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Mack <daniel@zonque.org>2017-02-23 19:41:44 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-02-26 12:25:50 +0100
commit595e9cf446f320647709f41cfa15a8758932b51d (patch)
tree88aa235daf8de3d46f60539d1dc74728e12146a4
parent61c02506f6f6689e81b3ff709ea2fa28a18bc964 (diff)
qtbase: remove absolute binary paths from mkspec files
When running 'bitbake -c populate_sdk' on an image that has qt5webkit enabled, the uikit feature is enabled in qtbase, which then fails to install with error: qtbase-mkspecs-5.8.0+git0+49dc9aa409-r0 conflicts with /usr/bin/perl The culprit for this is /usr/lib/qt5/mkspecs/features/uikit/devices.pl, which has #!/usr/bin/perl hardcoded. Fix this in a similar way other recipes do it as well and strip out these bits at install time. Signed-off-by: Daniel Mack <daniel@zonque.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtbase_git.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb
index 4e1ab72c..803c3f64 100644
--- a/recipes-qt/qt5/qtbase_git.bb
+++ b/recipes-qt/qt5/qtbase_git.bb
@@ -178,6 +178,10 @@ do_install_append() {
sed -i -e 's|${STAGING_DIR_NATIVE}${prefix_native}|$$[QT_HOST_PREFIX/get]|g' \
-e 's|${STAGING_DIR_HOST}|$$[QT_SYSROOT]|g' \
${D}/${OE_QMAKE_PATH_QT_ARCHDATA}/mkspecs/*.pri
+
+ # Fix up absolute paths in scripts
+ grep -lr /usr/bin/perl ${D}${OE_QMAKE_PATH_QT_ARCHDATA}/ | \
+ xargs -r sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/env perl,'
}
# mkspecs have mac specific scripts that depend on perl and bash