aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-08-10 14:05:14 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-09-05 13:43:11 +0200
commitaa413ccc067000459795854ed74993068b36d64c (patch)
tree1f857845c1372d5a755935b791d8ef149942a0ab
parent20e3c35f9ce30dcd25fac773d2b63f43ac8668a1 (diff)
libqofono: import from meta-luneos layer
* we alreadh have libconnman-qt5 here, so it makes sense to import libqofono as well Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-connectivity/libqofono/libqofono_git.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-connectivity/libqofono/libqofono_git.bb b/recipes-connectivity/libqofono/libqofono_git.bb
new file mode 100644
index 00000000..88df1351
--- /dev/null
+++ b/recipes-connectivity/libqofono/libqofono_git.bb
@@ -0,0 +1,39 @@
+DESCRIPTION = "Qt 5 bindings for the ofono dbus API"
+SECTION = "libs"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+DEPENDS += "qtbase qtdeclarative"
+
+SRCREV = "54435de3bed0b454ef4ea3ea32c7234fcd9f24c6"
+SRC_URI = "git://git.merproject.org/mer-core/libqofono.git"
+S = "${WORKDIR}/git"
+
+PV = "0.87+gitr${SRCPV}"
+
+inherit qmake5
+
+do_install_append() {
+ if ls ${D}${libdir}/pkgconfig/qofono-qt5.pc >/dev/null 2>/dev/null; then
+ sed -i "s@-L${STAGING_LIBDIR}@-L\${libdir}@g" ${D}${libdir}/pkgconfig/qofono-qt5.pc
+ fi
+}
+
+PACKAGES += "${PN}-tests"
+
+FILES_${PN}-dbg += " \
+ /lib/libqofono-qt5/tests/.debug \
+ ${libdir}/qt5/qml/MeeGo/QOfono/.debug \
+"
+FILES_${PN}-tests = " \
+ ${libdir}/libqofono-qt5/tests/tst_* \
+ /opt/tests/libqofono-qt5 \
+"
+FILES_${PN} += " \
+ ${libdir}/qt5/qml/MeeGo/QOfono/qmldir \
+ ${libdir}/qt5/qml/MeeGo/QOfono/libQOfonoQtDeclarative.so \
+"
+FILES_${PN}-dev += " \
+ ${datadir}/qt5/mkspecs \
+ ${libdir}/libqofono-qt5.prl \
+"