aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteffen Sledz <sledz@dresearch-fe.de>2017-07-06 13:44:43 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-10 02:11:03 +0200
commitc6aa602d0640040b470ee81de39726276ddc0ea3 (patch)
treecd1c05cc1d409f796ea802d4a0b5b79b6a7bb5ca
parenta00ec621f37deee477f002b95b7989a60e24aaf8 (diff)
qtquickcontrols2: fix compilation of examples/texteditor
git/examples/quickcontrols2/texteditor/documenthandler.cpp:284:18: error: invalid use of incomplete type 'class QDebug' qWarning() << "load() called before DocumentHandler has QQmlEngine"; Signed-off-by: Steffen Sledz <sledz@dresearch-fe.de> Acked-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes-qt/qt5/qtquickcontrols2/0001-qtquickcontrols2-fix-compilation-of-examples-textedi.patch28
-rw-r--r--recipes-qt/qt5/qtquickcontrols2_git.bb4
2 files changed, 32 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtquickcontrols2/0001-qtquickcontrols2-fix-compilation-of-examples-textedi.patch b/recipes-qt/qt5/qtquickcontrols2/0001-qtquickcontrols2-fix-compilation-of-examples-textedi.patch
new file mode 100644
index 00000000..d08c57e9
--- /dev/null
+++ b/recipes-qt/qt5/qtquickcontrols2/0001-qtquickcontrols2-fix-compilation-of-examples-textedi.patch
@@ -0,0 +1,28 @@
+From 3696a416bd594d3f280c281cb2a66bc837829238 Mon Sep 17 00:00:00 2001
+From: Steffen Sledz <sledz@dresearch-fe.de>
+Date: Thu, 6 Jul 2017 13:28:07 +0200
+Subject: [PATCH] qtquickcontrols2: fix compilation of examples/texteditor
+
+git/examples/quickcontrols2/texteditor/documenthandler.cpp:284:18: error: invalid use of incomplete type 'class QDebug'
+ qWarning() << "load() called before DocumentHandler has QQmlEngine";
+
+Signed-off-by: Steffen Sledz <sledz@dresearch-fe.de>
+---
+ examples/quickcontrols2/texteditor/documenthandler.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/examples/quickcontrols2/texteditor/documenthandler.cpp b/examples/quickcontrols2/texteditor/documenthandler.cpp
+index e57946fd..94ca82ad 100644
+--- a/examples/quickcontrols2/texteditor/documenthandler.cpp
++++ b/examples/quickcontrols2/texteditor/documenthandler.cpp
+@@ -59,6 +59,7 @@
+ #include <QTextCharFormat>
+ #include <QTextCodec>
+ #include <QTextDocument>
++#include <QtCore/QDebug>
+
+ DocumentHandler::DocumentHandler(QObject *parent)
+ : QObject(parent)
+--
+2.13.2
+
diff --git a/recipes-qt/qt5/qtquickcontrols2_git.bb b/recipes-qt/qt5/qtquickcontrols2_git.bb
index 42acb8ad..371f4aef 100644
--- a/recipes-qt/qt5/qtquickcontrols2_git.bb
+++ b/recipes-qt/qt5/qtquickcontrols2_git.bb
@@ -10,4 +10,8 @@ LIC_FILES_CHKSUM = " \
DEPENDS += "qtdeclarative"
+SRC_URI += " \
+ file://0001-qtquickcontrols2-fix-compilation-of-examples-textedi.patch \
+"
+
SRCREV = "6f7852a307c7ebbdb3b6efa00cbf7626b072bbc1"